PDA

Voir la version complète: Résolu charset ISO-8859-9 n'est pas pris en charge?



contemptx
09-09-11, 12:04
un de vos employés ont répondu pour me dire qu'ils ont mis à jour mes forums.
Mais j'ai répondu à leur disant qu'il ya des erreurs sans réponse:

certains fils sont montrant une erreur:

Lien:
http://www.cardshare.tv/forum/italian-italiano/66681-a.html

Erreur:
Attention: htmlspecialchars () [function.htmlspecialchars]: charset `ISO-8859-9 'n'est pas supporté, en supposant que l'iso-8859-1 dans [chemin] / includes / vbenterprisetranslator_functions_bbcode.php sur la ligne 281
Attention: htmlspecialchars () [function.htmlspecialchars]: charset `ISO-8859-9 'n'est pas supporté, en supposant que l'iso-8859-1 dans [chemin] / includes / vbenterprisetranslator_functions_bbcode.php sur la ligne 281

r.dziadusz
12-09-11, 10:51
Votre forum est ne répond pas pour le moment. vBET supporte tous les encodages, mais il est préférable que votre forum utilise l'encodage UTF-8.
C'est peut-être le problème de configuration, s'il vous plaît vérifier à nouveau le fichier readme - attention sur Configuration vBulletinTM.
Par ailleurs, il est le seul avertissement n'est pas une erreur, s'il vous plaît noter que.

contemptx
12-09-11, 16:07
J'ai vérifié la configuration ne peut toutefois pas voir quelque chose de mal.
Ce n'est pas seulement un avertissement que les pages de ce spectacle sur ne fonctionnent pas, mais juste montrer l'erreur.

r.dziadusz
12-09-11, 18:53
Ok,
Votre fonction PHP ne suppord ce charset, donc vous pouvez faire 2 choses:
a) changer votre jeu de caractères dans une de ces:
ISO-8859-1, ISO-8859-15, UTF-8 mais ce n'est pas sugested et très problématique
b) vous pouvez simplement désactiver les avertissements en ajoutant "@" avant que la fonction de la ligne 281:


avant:

$content = htmlspecialchars($content,ENT_COMPAT,vB_Template_Runtime::fetchStyleVar('charset'),false);

après:

$content = @htmlspecialchars($content,ENT_COMPAT,vB_Template_Runtime::fetchStyleVar('charset'),false);

Faites-nous savoir si le problème est résolu

contemptx
14-09-11, 15:27
Il a cessé de montrer l'erreur, cependant ce que le plugin vBET essaie de faire et ne peut pas faire est de provoquer la charge sérieusement haut et faire fonctionner le site très lent.

contemptx
15-09-11, 09:28
Après la modification que vous avez dit hier, le site tourne horriblement lent et se bloque.
Je suis actuellement impressionné par le niveau de soutien offert à l'heure actuelle, les choses étaient envisage de travail avant, j'ai alors payé pour une mise à niveau qui a été fait, mais le site ne fonctionne plus correctement.

Yesday j'ai perdu plus de £ 50 dans les recettes.
J'ai un forum occupé et ne peut pas se permettre des choses à vous continuez comme cela, je voudrais que cette résolu dès que possible.

J'ai repris le changement pour l'instant.

r.dziadusz
15-09-11, 09:49
Nous sommes désolés que vous ayez à attendre,
Tout d'abord assurez-vous que le cache est activé

S'il vous plaît vérifier ce http://www.vbenterprisetranslator.com/forum/vbet4-general-discussions/408-vbet-performance.html sujet. S'il vous plaît se concentrer sur le point 2, 16, 18, mais tous les lire

Si le problème persiste quitter désactiver toutes les langues sans que l'un, vérifiez si les caches sont presque pleines

Aussi, vous pouvez demander à votre fournisseur d'hébergement, si vous utilisez dernière version de PHP

En outre, vous pouvez vérifier quel est le problème sur le serveur. Après le login chercher problème avec Consuption mémoire, ou de surcharge procesor. Cherchez à savoir si il ya un processus responsable de cela.

contemptx
15-09-11, 12:29
Ma charge du serveur se situe entre 0,50 à 1,50 = très faible.
vBulletin AdminCP = travailler très rapide ainsi que d'autres sites et les panneaux de commande sur le serveur.

J'ai activé le cache Invité, mais ce n'est pas la question.
Le problème est que beaucoup d'utilisateurs sont d'atteindre les pages d'erreurs et vBET ne fonctionne pas correctement de sorte que son s'écraser sur le site.

r.dziadusz
15-09-11, 15:19
Pleace remarquerez que ce n'est pas bug vBET. Il happend raison de PHP - PHP manuel (http://php.net/manual/en/function.htmlspecialchars.php).
Ces avertissements ne devraient pas bloquer le site, mais comme je l'ai dit s'il vous plaît essayer de désactiver les langues et savoir si le forum est plus rapide

vBET
16-09-11, 20:42
Le problème est que beaucoup d'utilisateurs sont d'atteindre les pages d'erreurs et vBET ne fonctionne pas correctement de sorte que son s'écraser sur le site.

Désolé - quelles erreurs avez-vous encore? Radek vous a donné solution pour celui qui est décrit et vous confirme que ceux-ci sont allés. S'il vous plaît indiquer quel est votre nouveau numéro afin que nous pourrons vous aider avec:)

r.dziadusz
24-09-11, 07:52
Pas de réponse, pensez à régler

Automatic Translations (Powered by Google, Microsoft®, Yandex, SDL Language Cloud, IBM Watson and Apertium):
AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.10.1 enjoy automatic translations