PDA

View Full Version: Gelöst Speicher Probleme



norku
15-03-11, 17:40
Ich weiß nicht, ob diese Vbet Zusammenhang ist, aber es begann zu passieren, nachdem ich es installiert, also werde ich hier fragen, bin:)

Ich erhalte den folgenden Fehler, wenn Sie auf den vBSEO 'Likes empfangen "und" Likes Angesichts "-Tasten auf dem Benutzerprofil-Seite:


Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 200593 bytes) in /home/xxxx/public_html/forum/includes/functions.php on line 6862


Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home/xxxx/public_html/forum/includes/class_core.php(4430) : eval()'d code on line 458

Wie gesagt, dieser begann zu geschehen nach der Installation Vbet aber ich denke, ich werde einige Coaching hier brauchen, weil die Zahlen nicht passen die Symptome.

Speicher-Info:

Von phpinfo: memory_limit Local - 128M Master - 128M

Von php.ini:
; Suhosin Settings.

suhosin.post.max_vars = 2048

suhosin.request.max_vars = 2048

suhosin.cookie.encrypt = Off

suhosin.memory_limit = 32M

suhosin.session.encrypt = Off

VBulletin: PHP Memory Limit 32M

Server-Speicher in Verwendung in dem Moment: 25,00% (262.136 von 1048576)

Die Fehlermeldungen sind darauf hindeutet, dass ich den Speicher erhöhen müssen, aber ich sehe keine andere Symptome von zu wenig Speicher, während der Nutzung des Forums und ich habe keine Berichte aus meinen Gliedern. Ich nehme an, aber dass sie auch sehen, das "Likes" fatal error.

Habt ihr begegnet Probleme wie diese während der Nutzung Vbet? Ich wäre dankbar für irgendwelche Tipps, was es zu versuchen.

kamilkurczak
15-03-11, 18:31
hallo,
Ok ich werde es auf meinem Test Forum Test. Sie können einfach versuchen, dass vBET diesem Thema machen - einfach deaktivieren vBET und versuchen, es wieder tun - Wenn das Problem stil existieren und vBET ist deaktiviert - dies ist nicht vBET Thema. Wenn das Problem verschwindet - das ist vBET Problem, und wir werden es beheben.

Zweitens - Sie können den Grenzwert von memory_limit in der php.ini zu erhöhen, um 64 MB und starten Sie Ihren Server. (Bitte nur über dieses Thema in google zu lesen).
mit vBET Sie haben 52 weitere Inhalte und 52 weitere Benutzer im Forum (wenn Sie alle Sprachen aktiviert) - Kosten für die Server-Speicher. Wir sind immer noch workin zu machen vBET effizienter (neue Relase sehr bald).
Hier haben Sie eine Liste der


Dank

norku
15-03-11, 19:13
Dank. Mich würde interessieren, in Ihren Ergebnissen. Ich deaktiviert Vbet und lud die "Likes"-Seite. Jetzt bekomme ich nur eine leere weiße Seite - kein Memory-Fehler. Auch nicht ganz das, was ich nach:)

Ich werde warten, zu hören, was Sie auf Ihrem Test-Site zu entdecken, bevor ich den Speicher Einstellung in der php.ini.

norku
16-03-11, 00:13
Ich bearbeitete meine php.ini und erhöhte das memory limit auf 64M und dann neu gestartet Apache aber vbulletin scheint zu ignorieren, dass Einstellung und ist immer noch beklagen, dass nicht genügend Speicher vorhanden ist (gleiche Fehler wie ich in post 1 geschrieben).

norku
16-03-11, 09:24
Hallo,

Konnten Sie den Fehler wiederholen? Ich kann nicht verstehen, warum Vbulletin AdminCP zeigt eine 32M Memory Limit, wenn php.ini 64M hat.

kamilkurczak
16-03-11, 09:51
nein, ich kann es nicht reproduzieren auf meinem Test-Forum (i angeklickt mag Tasten auf Benutzerseite).
Haben Sie den Server neu starten nach der Änderung in der php.ini?
Bitte fragen Sie, ob Ihr Host-Provider

norku
16-03-11, 09:55
Ja, ich neu gestartet Apache nach Änderung der php.ini, aber es hatte keine Wirkung. Sehr seltsam. Ich überprüfte meine allgemeine Speicherauslastung und es war weit unter 32M ohnehin so sehr seltsam, dass ich bekomme diese Speicherfehler. Ich habe mein Gastgeber bat, dies zu prüfen.

norku
16-03-11, 11:54
Gelöst. Ich hatte eine unvollständige php.ini in der Wurzel. Alles ist korrekt funktioniert jetzt.

kamilkurczak
21-03-11, 22:42
ok für diese Bestätigung:) gelöst

Automatic Translations (Powered by Google, Microsoft®, Yandex, SDL Language Cloud, IBM Watson and Apertium):
AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations delivered by vBET 4.10.1