Important: This page is using cookies (cookies). Using this website without turning off cookies in browser, means that you agree for using it.
Buy Now! Features Downloads

Earn with us!

If you would like to start earning money with vBET join to Affiliate Program.
Results 1 to 7 of 7

Thread: Does not strip away the no-translate tag for TITLE, default language

  1. #1
    Junior Member
    Join Date
    Apr 2011
    Posts
    14

    Default Does not strip away the no-translate tag for TITLE, default language

    vBET 4.3.0 seems to handle the < !--vBET_SNTA--> (minus the space of course) tag wrong for the TITLE tag in forum home.

    If I use the no translate tag, the tab in the browser present correctly an untranslated text for translated languages. But for the forum default languge (at least when it is english) shows the tags in the tab. vBET misses to strip away the tag.

    Firefox 4.0.1 and Opera 11.10

  2. #2
    vBulletin Enterprise Translator (vBET) Staff
    Join Date
    May 2010
    Posts
    1,000

    Default

    hello,

    Please - I need url to the thread or page with this issue
    Thanks

  3. #3
    Junior Member
    Join Date
    Apr 2011
    Posts
    14

    Default

    PM with url sent

  4. #4
    Michał Podbielski (vBET Staff) vBET's Avatar
    Join Date
    Oct 2009
    Posts
    3,032
    Blog Entries
    1

    Default

    Are you using notranslate tag in thread title? It shouldn't be used there! Please note that ti you want to keep title not translated then you must use langtitle with language code which doesn’t exists, in example [ langtitle=not] (without space). Please note that vBulletin do not support tags in titles at all. We made lot of effort to support langtitle tag in title and this is only tag supported in title. For reliability and performance we support not translation of title by same bbcode as for translation - so by langtitle bbcode.

    Please tell did it help. If I misunderstood something, then please send URL to page when we can see the issue.
    Last edited by vBET; 29-05-11 at 15:01.

  5. #5
    Junior Member
    Join Date
    Apr 2011
    Posts
    14

    Default

    No, I am not talking about the Thread Title. I'm talking about wrapping vboptions.bbtitle with the VBET_SNTA tag in the FORUMHOME template part.

    When looking at a translated page, everything is correctly handled; so the addon is definitely reading the tag there. But when I look at the forum page with the forum default language; it is correctly handled everywhere but the one wrapped in the HTML-tag TITLE, where it does not strip away the tag when it is not needed.

    So what I am trying to keep untranslated is the forum name (Option -> Site Name -> Forum Name).

    I send you a PM with a link.

  6. #6
    Michał Podbielski (vBET Staff) vBET's Avatar
    Join Date
    Oct 2009
    Posts
    3,032
    Blog Entries
    1

    Default

    OK I see it after you send link in PM. Two things:
    1. It is harmless, because it is just html comment
    2. Of course we will check it closer and correct - son I will give you more details.

  7. #7
    Michał Podbielski (vBET Staff) vBET's Avatar
    Join Date
    Oct 2009
    Posts
    3,032
    Blog Entries
    1

    Default

    Reproduced and solved Solution will be included in next release.

    For quick fix please:
    1. Open /includes/vbenterprisetransaltor_functions_hooks.php
    2. Find:
    PHP Code:
    $output =& str_replace(array('<!--vBET_SNTA--><!--vBET_NRE-->''<!--vBET_ENTA-->'), ''$output); 
    3. Replace by:
    PHP Code:
    $output =& str_replace(array('<!--vBET_SNTA-->''<!--vBET_NRE-->''<!--vBET_ENTA-->'), ''$output); 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31