Important: This page is using cookies (cookies). Using this website without turning off cookies in browser, means that you agree for using it.
Buy Now! Features Downloads

Earn with us!

If you would like to start earning money with vBET join to Affiliate Program.
Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: People who visit my site are first asked a question in russian?

  1. #21
    Senior Member
    Join Date
    Sep 2010
    Posts
    256

    Default

    Thats not the explanation, my browser has NEVER been set to russian but i saw it when i logged out just as he did, i cant vouch that his browser has never been russian but he's indian, lives in New Dehli and types and speaks in English so why on earth would our cookies be read as russian?

  2. #22
    Retired ;)
    Join Date
    Aug 2011
    Posts
    441

    Default

    my apologize it read headers, you might even never set/use russian language, but your browser can thin you were. This is all can I say without checking it - sorry I can't see this popup

  3. #23
    Senior Member
    Join Date
    Sep 2010
    Posts
    256

    Default

    I have turned the russian language off, seeing the pop-up will not help you as once you have dismissed it, it doesn't come back (at least not for a while!), it's not possible for my browser to "think" i have set or use russian language, the only language that has ever been set in my browser is the default English UK, as i said i cant vouch for the person who reported it, i have experienced it before and im pretty sure others are too.

    In order for a language mistake to take place i'd either have to physically change it, use software to change it (vBET) or us a russian proxy (or proxy set up to fake being russian) only one of which is possible for me and thats vBET.

  4. #24
    Michał Podbielski (vBET Staff) vBET's Avatar
    Join Date
    Oct 2009
    Posts
    3,032
    Blog Entries
    1

    Default

    Hi. I do not understand where are you going to. You got simple answer - the behavior is forced by you - you set it in settings.
    And you can easily turn it off in Admin CP -> vBET -> Misc -> Redirect to user language.
    Go there and set Disabled. vBET will not ask or redirection anymore.

    It is great that vBET behaves how you configured it. It would be bad if it ignore your settings. For software doesn't matter which language user speaks or what does he claims about his browser settings. For software only thing that matters are actual headers which comes with request. And those are checked with settings we are discussing about. Nothing more. That is how vBET works here and you can easily change it if you want. by your configuration.

    I suggest to check your browser settings when it will happen again (it you still will have asked redirections turned on). And if you will not find there in language settings the language you are asked to be redirected, then check also what comes to the server (add some logs) - please remember that Internet is a big place and your packages comes by lot of places - it is possible that some proxy server adds own headers to your request. Anyway - there is no magic. If you where asked to redirect by vBET and it was redirect to Russian language then rout request had in language headers Russian language on the top of all languages known by vBET. You can check it yourself if you want - just go to file /includes/vbenterprisetranslator_functions_lang.php and check function vbet_getRedirectionLanguage. This is also good place to add your logs if you thing that we have bug and want to prove it to us.

    If you prefer to disable full application instead of one parameter (which you set yourself) - do what you think, think what you do... It is your forum. We are happy to explain you why this happened and how you can change it. If you need more help please just write

  5. #25
    Senior Member
    Join Date
    Sep 2010
    Posts
    256

    Default

    Michael, thanks for the response, yes i have configured vBET to ask and vBET should work this way without problems, however the issue was that unregistered or peopel who log out were being asked the redirect question, vBET, as far as i know should not work this way, also the language is ALWAYS russian, so here's the two scenario's:
    1. Unregistered user from India visits the site, see's the pop up (in russian) asking if he wants to set his language to russian, he declines and can view the site as normal in english, if he accepts (but please bear in mind as he doesn't speak russian he cannot read the pop up) he's transported to Microsoft Office Help - Microsoft Office Discussion - Excel VBA Programming - Access Programming

    2. I get told about this (and have experienced it myself in the past) and log out of the forum, select the link to take me to the place i was viewing before and then i get the pop up in Russian, the the same scenario as above takes place

    If we are logged out why would we be presented with the pop up? the pop up is only for logged in people isn't it?

    It won't be my server as its in the UK and is dedicated, i have total control over it, as i sadi though, i've turned the Russian language off now so hopefully that will stop the issue.

  6. #26
    Michał Podbielski (vBET Staff) vBET's Avatar
    Join Date
    Oct 2009
    Posts
    3,032
    Blog Entries
    1

    Default

    Quote Originally Posted by Simon Lloyd View Post
    If we are logged out why would we be presented with the pop up? the pop up is only for logged in people isn't it?
    No this happens for people who starts new session:
    Quote Originally Posted by Parameter description
    Redirection will happen only at the beginning of new session (client must have cookies enabled or will be redirected each time).
    And it is recognized by cookies.

    Also as I wrote before only what matters for your server is what language header comes with request. And it appears that in booth your scenarios header with Russian language came with request. Please check your server configuration - maybe you have set some default language added when no language header is set. Anyway I doubt that we have bug here. This functionality wasn't modified for very long time and it is working fine. We can check it if it will happen again in logs - most probably it will show what I wrote - that Russian language code was send in appropriate header. If I'm wrong we will correct the bug, but first we need to confirm that there is any bug.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31