Important: This page is using cookies (cookies). Using this website without turning off cookies in browser, means that you agree for using it.
Buy Now! Features Downloads Check vBET on vBulletin 5

Earn with us!

If you would like to start earning money with vBET join to Affiliate Program.
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Many problems installing on vbulletin 5

  1. #1
    Junior Member
    Join Date
    Sep 2015
    Posts
    13

    Exclamation Many problems installing on vbulletin 5

    Hello, i have some problems installing on vbulletin 5
    I have uploaded files, set my google api key and all needed settings on admincp

    When i tried to import the product-vbenterprisetranslator.xml i got the error:

    [QUOTE]
    Importing Product, Please Wait...

    [:]
    Warning: require_once(...//vbenterprisetranslator_functions_admin.php): failed to open stream: No such file or directory in .../includes/adminfunctions_product.php(881) : eval()'d code on line 2
    Fatal error: require_once(): Failed opening required '/home/forumsrv/public_html/core//vbenterprisetranslator_functions_admin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/forumsrv/public_html/core/includes/adminfunctions_product.php(881) : eval()'d code on line 2
    [\QUOTE]

    [\QUOTE]

    so i added this line to my "+core+includes+config.php" to decalre the "['Misc']['admincpdir']"
    [QUOTE]$config['Misc']['admincpdir'] = 'admincp';[\QUOTE]
    vbulletin 5.1.9 does not have this line from default.

    How can this xml ask for a variable that is not present??

    Anyway, after that it installed. I went to vbet settings and added my google api key and set all needed settings.

    After i edited my .htaccess and added first this lines (provided on do-not-upload+tools+redirecting-rules):
    [QUOTE]RewriteEngine On
    Options FollowSymLinks

    RewriteRule ^\?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)\archive\index.php\(.*)?$ archive\index.php?\$2&language=$1 [L,QSA]
    RewriteRule ^\?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)\$ index.php?language=$1 [L,QSA]
    RewriteRule ^\?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)\(.*)?$ $2?language=$1 [L,QSA]
    [\QUOTE]


    Did not worked at all, any language flag i selected language was still english

    then i added the rest lines on the .htaccess:
    [QUOTE]RewriteCond %{QUERY_STRING} !redirected=
    RewriteCond %{QUERY_STRING} !do=
    RewriteCond %{REQUEST_URI} !(admincp|modcp|clientscript|cpstyles|images|css|js|login|auth|ajax)
    RewriteRule ^(.*)$ vbenterprisetranslator_front_controller.php?redirected=$1 [L,QSA][\QUOTE]

    Worked, when i clicked on language flag it changed the forum language, BUT.. the image attachments were not showing and i could not logon on admincp,
    when i tried to login on admincp i got this error:
    [QUOTE] No input file specified. [\QUOTE]


    EDIT 2-10-15:

    Please read my last post on this thread to get helped for installing on vbulletin 5.1.9
    Last edited by rafail; 02-10-15 at 18:24.

  2. #2
    vBulletin Enterprise Translator (vBET) Staff
    Join Date
    Aug 2012
    Posts
    481

    Default

    Hi.
    Thank you for the information about config.xml. Previous versions include a line $config['Misc']['admincpdir'] = 'admincp';. I do not know why it was removed in the latest version of vB.
    Your .htaccess should look like this:
    Code:
    RewriteEngine On
    Options FollowSymLinks
    
    RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
    RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
    RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1 [L,QSA]
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    
    #In some cases where you have other mod_rewrite rules, you may need to comment out the following line
    	#and change it to match your folder name. This resets the other mod_rewrite rules for just this directory
    	#If your site was www.example.com/forum, the setting would be /forum/
    	#RewriteBase / 
    
    	# Send css calls directly to the correct file VBV-7807
    	RewriteRule ^css.php$ core/css.php [NC,L]
    
    # Redirect old install path to core.
    RewriteRule ^install/ core/install/ [NC,L]
    
    # Main Redirect
    RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]
    
    # Because admincp is an actual directory.
    RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
    </IfModule>
    
    <IfModule mod_deflate.c>
        AddOutputFilterByType DEFLATE application/atom+xml \
                              text/javascript \
                              application/x-javascript \
                              application/javascript \
                              application/json \
                              application/rss+xml \
                              application/vnd.ms-fontobject \
                              application/x-font-ttf \
                              application/xhtml+xml \
                              application/xml \
                              font/opentype \
                              image/svg+xml \
                              image/x-icon \
                              text/css \
                              text/html \
                              text/plain \
                              text/x-component \
                              text/xml
    </IfModule>
    
    <IfModule mod_expires.c>
    	ExpiresActive On
    	ExpiresByType application/x-javascript A1209600
    	ExpiresByType text/javascript A1209600
    	ExpiresByType application/javascript A1209600
    	ExpiresByType text/css A31536000
    	ExpiresByType image/x-icon A2592000
    	ExpiresByType image/icon A2592000
    	ExpiresByType application/x-ico A2592000
    	ExpiresByType application/ico A2592000
    	ExpiresByType image/gif A2592000
    	ExpiresByType image/jpeg A1209600
    	ExpiresByType image/jpg A1209600
    	ExpiresByType image/png A1209600
    	ExpiresByType application/x-shockwave-flash A1209600
    	ExpiresByType font/ttf A2592000
    	ExpiresByType font/otf A2592000
    	ExpiresByType font/x-woff A2592000
    	ExpiresByType image/svg+xml A2592000
    	ExpiresByType font/truetype A2592000
    	ExpiresByType font/opentype A2592000
    	ExpiresByType application/x-font-woff A2592000
    	ExpiresByType application/vnd.ms-fontobject A2592000
    </IfModule>
    
    <IfModule mod_headers.c>
        Header set Connection keep-alive
    	<filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
    		Header set Cache-Control "max-age=2592000, public"
    	</filesmatch>
    	<filesmatch "\.(jpg|jpeg|png)$">
    		Header set Cache-Control "max-age=1209600, public"
    	</filesmatch>
    	<filesmatch "\.(eot|woff|otf|ttf|svg)$">
    		Header set Cache-Control "max-age=2592000, public"
    	</filesmatch>
    	# css and js should use private for proxy caching https://developers.google.com/speed/docs/best-practices/caching#LeverageProxyCaching
    	<filesmatch "\.(css)$">
    		Header set Cache-Control "max-age=31536000, private"
    	</filesmatch>
    	<filesmatch "\.(js)$">
    		Header set Cache-Control "max-age=1209600, private"
    	</filesmatch>
    </IfModule>
    
    RewriteCond %{QUERY_STRING} !redirected=
    RewriteCond %{QUERY_STRING} !do=
    RewriteCond %{REQUEST_URI} !(admincp|modcp|clientscript|cpstyles|images|css|js|login|auth|ajax)
    RewriteRule ^(.*)$ vbenterprisetranslator_front_controller.php?redirected=$1 [L,QSA]
    Please send me a PM access details to Admin CP and FTP. I would like check your settings.

  3. #3
    Junior Member
    Join Date
    Sep 2015
    Posts
    13

    Default

    when i put that htaccess i cannot login on admincp, it says "no input file"
    sent you pm with admin password
    ftp is disabled and i access it through cpanel
    if needed let me know

  4. #4
    Junior Member
    Join Date
    Sep 2015
    Posts
    13

    Default

    sent you also ftp login pm

  5. #5
    vBulletin Enterprise Translator (vBET) Staff
    Join Date
    Aug 2012
    Posts
    481

    Default

    To disable add language code to an attachment on your forum:
    add to AdminCP->vBET->Translation Options->Ignore URLs:
    Code:
    /filedata/
    /fetch
    /image.php
    .
    To fix an issue with AdminCP, try turning off in server settings FastCGI.
    Last edited by Marcin Kalak; 30-09-15 at 18:00.

  6. #6
    Junior Member
    Join Date
    Sep 2015
    Posts
    13

    Default

    there is no such option in admincp and fastcgi is already off

  7. #7
    vBulletin Enterprise Translator (vBET) Staff
    Join Date
    Aug 2012
    Posts
    481

    Default

    This option should be in a AdminCP->vBET->Translation Options->Ignore URLs. Are you sure you disable FastCGI?

  8. #8
    Junior Member
    Join Date
    Sep 2015
    Posts
    13

    Default

    i added urls, added the htaccess you provided and i got white characters and could not login to admincp. fastcgi is not even installed on my server

  9. #9
    vBulletin Enterprise Translator (vBET) Staff
    Join Date
    Aug 2012
    Posts
    481

    Default

    Do you have mod_rewrite enabled? In phpinfo is written that FastCGI is enabled.

  10. #10
    Junior Member
    Join Date
    Sep 2015
    Posts
    13

    Default

    CGI is enabled, not FastCGI. FastCGi is not even installed. phpinfor says cgi/fastcgi because it means one or other.
    I tried using DSO, it opens cpanel but i get an error on main page: Warning: Cannot modify header information - headers already sent in .../includes/vbenterprisetranslator_functions.php on line 223
    also when i turned to dso and added the htaccess content i got white characters on forum (on default english language)
    i have added the 3 lines on ignore urls.

    So i turned back to CGI (not FASTCGI) and removed the htaccess lines so the forum can work.
    I cannot understund this situation, is there any way it can work or not? have you even tasted it on vbulletin 5.1.9? I need help here, i have provided you with ftp and admincp credentials what else should i do to get it work?

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33