Important: This page is using cookies (cookies). Using this website without turning off cookies in browser, means that you agree for using it.
Buy Now! Features Downloads Check vBET on vBulletin 5

Earn with us!

If you would like to start earning money with vBET join to Affiliate Program.
Results 1 to 4 of 4

Thread: Redirect loop problem when we enable "guest file cache"

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    14

    Default Redirect loop problem when we enable "guest file cache"

    I saw this topic but those advices doesn't work for us.

    We've followed all instructions ( /do-not-upload/readme.html ) and we
    did it all except number 4 (FORUM_ROOT/vbseo/includes/functions_vbseo_createurl.php)
    but we have good specific reasons for not doing this. Furthermore, we haven't noticed that translated URL would affect on redirect loop so we need to find out the real problem.

    We've made all necessary things in our htaccess file according to your
    instructions and it's working great but not when we enable "guest file
    cache" (when "guest file cache" is disabled, everything is working fine).
    We use VBSEO 3.5.2 (latest).

  2. #2
    Banned
    Join Date
    Nov 2010
    Posts
    95

    Default

    It must be a really strong reason that you don't want to integrate "functions_vbseo_createurl.php", but until we don't know it, we can't do anything for you - this modification is a part of the whole procedure of vbSEO's integration.
    Try to disable vbSEO and enable guest-cache, then give a sign, if translations work correctly in this case.

  3. #3
    Junior Member
    Join Date
    Mar 2010
    Posts
    14

    Default

    We had two tests:

    A)
    -OFF: VBSEO
    -ON: VBET file cache
    -OFF: functions_vbseo_createurl.php (without integration)
    FILE CACHE WORKS GREAT, WITHOUT REDIRECT LOOP

    B)
    -ON: VBSEO
    -ON: VBET file cache
    -ON: functions_vbseo_createurl.php (with integration)
    FILE CACHE CAUSES REDIRECT LOOP


    For example, if some thread have English subject: "funny pictures", Spain flag in footer will have following URL: /es/t1000/funny-pictures/
    When I click on this flag and came to Spanish translate, my link will have URL: /es/t1000/funny-fotos/

    For Google crawler, (/es/t1000/funny-pictures/) != (/es/t1000/funny-fotos/)
    Because we know that Google robots are very sensitive and only one different symbol in URL causes bed indexing (maybe is this specific for us and our forum - but we have to accept that), we don't want to change all our URLs.

    We would like to enable this great option and we are sure that you can make this working without translated URLs. So, if you want to make this working on our forum (and make some extra money of course), send us a PM here on the forum and I'll give you our official e-mail where we can talk about details.

    You can mark this thread as solved.

    Thank you
    Last edited by cesarica; 17-11-10 at 03:59.

  4. #4
    Banned
    Join Date
    Nov 2010
    Posts
    95

    Default

    Could you check carefully, did you correctly modify vbseo_url.php, according to the vbSEO Integration description?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33