Important: This page is using cookies (cookies). Using this website without turning off cookies in browser, means that you agree for using it.
Buy Now! Features Downloads Check vBET on vBulletin 5

Earn with us!

If you would like to start earning money with vBET join to Affiliate Program.
Results 1 to 1 of 1

Thread: Apertium bug

  1. #1
    MichaƂ Podbielski (vBET Staff) vBET's Avatar
    Join Date
    Oct 2009
    Posts
    2,966
    Blog Entries
    1

    Default Apertium bug

    It appears that Apertium API has internal bug and it is working wrong - when several translations are used in one request, it translates only last text instead of all of requested. We already send notice to Apertium, but we got no response.

    Until Apertium correct their bug you have 3 choices:
    1. Ignore it, but Apertium translations will have bugs and will not be cached
    2. Disable Apertium in options (but it gives free translations without limits): AdminCP -> vBET -> Translation Providers -> Apertium FREE Translation API
    3. Use quick fix below to ask only for one translation per request (NOTE: this will significantly affect performance for not cached translations)

    Quick fix (not planned to be included in release, because it is internal Apertium bug):
    1. Open file includes\vbenterprisetranslator_class_translator.php
    2. Find:
      Code:
      const MAX_URL_SEGMENTS = 10000;
    3. Replace with:
      Code:
      const MAX_URL_SEGMENTS = 1;
    Last edited by vBET; 26-02-18 at 04:33.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33