PDA

Visualizza la versione completa: Risolto Problemi occasionali con conversione URL



simit patel
25-11-09, 17:06
Ciao,

Sto usando vbet dal ramo 2.X, e sono stati potenziamento lungo la strada. ho appena aggiornato alla 3.2.2.

ora, quando clicco su le bandiere, i notare i cambiamenti URL pure. tuttavia, a volte la pagina viene caricata correttamente, ma altre volte, ho semplicemente compare una pagina bianca con la scritta "pagina non trovata". il mio sito è informedtrades.com. ho installato vbseo pure.

ho visto alcune persone che hanno riferito esperienze simili, ma non ho visto nessuno parlarne che si verificano solo qualche volta, né vedo la gente che aveva solo un problema dopo l'aggiornamento recente. scusa se questo era già stato affrontato e l'ho perso.

qualche idea su come risolvere il problema?

grazie
SIMIT

vBET
25-11-09, 19:44
Ciao. Credo di avere trovato il motivo. Sul link del forum che hanno i caratteri speciali vengono affermato di non essere trovato. Io non so perché ancora.

Non siamo in grado di riprodurre sul nostro server (come potete vedere qui si sta lavorando bene) quindi per favore PM me accedere ai dettagli al vostro Admin CP e FTP.

jorgejgm
25-11-09, 23:03
Ciao,

Sto usando vbet dal ramo 2.X, e sono stati potenziamento lungo la strada. ho appena aggiornato alla 3.2.2.

ora, quando clicco su le bandiere, i notare i cambiamenti URL pure. tuttavia, a volte la pagina viene caricata correttamente, ma altre volte, ho semplicemente compare una pagina bianca con la scritta "pagina non trovata". il mio sito è informedtrades.com. ho installato vbseo pure.

ho visto alcune persone che hanno riferito esperienze simili, ma non ho visto nessuno parlarne che si verificano solo qualche volta, né vedo la gente che aveva solo un problema dopo l'aggiornamento recente. scusa se questo era già stato affrontato e l'ho perso.

qualche idea su come risolvere il problema?

grazie
SIMIT
Ciao, mi è successo anche una volta, ma se si ricarica la pagina di nuovo e lo fa bene. La verità che è rara, saluti.

vBET
26-11-09, 03:55
La verità è che non importa per quanto è raro che - non dovrebbe accadere a tutti e noi faremo del nostro meglio per rendere funziona sempre:)

simit patel
26-11-09, 15:18
Ho ripristinato vbet 312, che funziona bene. così, il problema è legato a qualche differenza tra 312 e 322. inoltre, quando ho ritornato a 312, la prima cosa che ho fatto è stato un prodotto di sovrascrittura. il problema persisteva. Poi, quando ho caricato i file di 312, che sembrava risolvere il problema. così, forse il problema riguarda una modifica di file tra 312 e 322.

anche la pena notare è che ho vbblogs installato. questo non ha risentito affatto; gli URL nei blog non venivano scritte in caratteri stranieri. né in 322, né nel 312.

Mi piacerebbe davvero sfruttare le nuove funzionalità di 322. c'è qualche cosa che posso fare che, alla luce della situazione?

grazie
SIMIT

AGGIUNTO: e, naturalmente, ho l'ultima versione di vbseo installata.

vBET
26-11-09, 15:23
Non è migliore idea di reinstallato fatto quando il supporto è sulla vostra tavola ...

Inoltre trovo che questo è un problema di configurazione vBSEO. I modelli che hai per thread non permetterà segni stranieri:


'VBSEO_URL_THREAD' => '(\d+)-([a-z\._\-ŠŽšžźŔÁÂĂÄĹÇČÉĘËĚÍÎĎŃŇÓÔŐÖŘŮÚŰÜÝŕáâăäĺçčéęëěíîďńňóôőöřůúűüý˙µA-Z\d-]+)\.html',


dovrebbe essere qualcosa di simile:


'VBSEO_URL_THREAD' => '([^/]+)/(\d+)-([^/]+)\.html',


Ma non cambiare manualmente. Tale modello è in molti posti in configurazione vBSEO. Si prega di PM me accedere ai dettagli al CP vBSEO e farò sapere quale parametro di configurazione è responsabile di questo.

vBET
26-11-09, 15:38
Il motivo è sbagliato configurazione vBSEO.

Impostare l'opzione "Sostituisci caratteri non inglesi negli URL?" a "Conserva caratteri non inglesi in URL".

Questo misteriosamente sparire dal nostro manuale di integrazione. Mi dispiace per le difficoltà:) solo set di parametri e sarà bene:)

jorgejgm
26-11-09, 16:28
Il motivo è sbagliato configurazione vBSEO.

Impostare l'opzione "Sostituisci caratteri non inglesi negli URL?" a "Conserva caratteri non inglesi in URL".

Questo misteriosamente sparire dal nostro manuale di integrazione. Mi dispiace per le difficoltà:) solo set di parametri e sarà bene:)

Per lo spagnolo c'è un problema con le lettere QUESTO lettere N, O, í, ecc ecc (A RIMUOVERE IL TRANSLATE N, O, I.Dopo aver attivato il "sostituire i caratteri non inglesi" vbseo sostituito con la lettera n o (I) nell'URL. Questo è molto buono per seo.Con l'opzione "Mantenere Non-English caratteri in URLs" caratteri vengono sostituiti da ~. Qualcosa che riguarda il seo molto. Per future revisioni della VB sarà "risolto" o è tecnicamente impossibile?.Grazie.

vBET
26-11-09, 19:12
Dopo aver attivato il "sostituire i caratteri non inglesi" vbseo sostituito con la lettera n o (I) nell'URL. Questo è molto buono per seo.Con l'opzione "Mantenere Non-English caratteri in URLs" caratteri vengono sostituiti da ~. Qualcosa che riguarda il seo molto. Per future revisioni della VB sarà "risolto" o è tecnicamente impossibile?.Grazie.

Questo viene fatto vBSEO - vBET non ha tali sostituzioni. È necessario configurare opportunamente vBSEO. Si può avere l'opzione per mantenere non Espagnol ans personaggi anche configurare manualmente in FORUM_DIR / INCLUES / parametro config_vbseo.php $ vbseo_custom_char_replacement. Grazie che si sarà in grado di lavorare con URL tradotti e mantenere i propri URL per lingua madre, come quelli in cui.

Guardate qui:

http://www.forum.simple-nlp.pl/informacje/1274-pierwsze-na-swiecie-forum-o-nlp-wspierajace-wielojezyczna-spolecznosc.html

Si tratta di URL in cui le lettere polacco (come SAEC) è stato cambiato grazie a $ vbseo_custom_char_replacement e conserva ancora tutte le altre lettere, non in inglese. Questo è lo stesso link per il giapponese:

http://www.forum.simple-nlp.pl/ja/informacje/1274-nlp多言語のサポートのための世界初のフォーラム!.html

Anche questo è buon esempio perché si dovrebbe tenere non in inglese / Espagnol personaggi - alcune lingue hanno noly non inglese / Espagnol caratteri.

Questo è esempio di come è possibile impostare $ valore vbseo_custom_char_replacement (per le lettere polacco):


$vbseo_custom_char_replacement = array(
'ˇ' => 'A',
'¦' => 'S',
'¬' => 'Z',
'±' => 'a',
'¶' => 's',
'Ľ' => 'z',
'ą' => 'a',
'ę' => 'e',
'ć' => 'c',
'ż' => 'z',
'ś' => 's',
'ź' => 'z',
'ó' => 'o',
'ł' => 'l',
'ń' => 'n',
'Ą' => 'A',
'Ę' => 'E',
'Ć' => 'C',
'Ż' => 'Z',
'Ś' => 'S',
'Ź' => 'Z',
'Ó' => 'O',
'Ł' => 'L',
'Ń' => 'N'
);


Quindi, come vedete - è possibile mantenere dio modo SEO per i collegamenti esistenti e aperto per i collegamenti tradotto in 52 lingue:)

Spero che questo aiuto in caso di altre domande basta chiedere - siamo qui per aiutarti:)

jorgejgm
26-11-09, 20:27
Grazie molto di nuovo, funziona perfettamente. Grazie.

Automatic Translations (Powered by Google, Microsoft®, Yandex, SDL Language Cloud and Apertium):
AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.9.2 you can enjoy automatic translations