PDA

Voir la version complète: Résolu Problèmes occasionnels avec conversion URL



simit patel
25-11-09, 18:06
Bonjour,

J'ai été en utilisant vBET depuis la branche 2.X, et ont été mise à jour le long du chemin. Je viens de mettre à 3.2.2.

maintenant, quand je clique sur les drapeaux, je remarque l'URL change aussi. Cependant, parfois, la page se charge correctement, mais d'autres fois, j'ai simplement obtenir une page blanche qui dit "page non trouvée". mon site est informedtrades.com. J'ai vBSEO installé.

J'ai vu certaines personnes rapportant des expériences similaires, mais je n'ai vu personne parler a lieu uniquement une partie du temps, ni je vois des gens qui avaient seulement un problème après cette mise à jour récente. désolé si cela a déjà été traitée et je l'ai raté.

des idées sur la façon de régler le problème?

Merci
simit

vBET
25-11-09, 20:44
Salut. Je pense avoir trouvé le modèle. Sur votre liens forum qui ont des caractères spéciaux sont réclamés de ne pas être trouvé. Je ne sais pas encore pourquoi.

Nous ne sommes pas en mesure de le reproduire sur nos serveurs (comme vous pouvez le voir ici, il fonctionne bien), de sorte s'il vous plaît me PM accéder aux détails de votre PC Admin et FTP.

jorgejgm
26-11-09, 00:03
Bonjour,

J'ai été en utilisant vBET depuis la branche 2.X, et ont été mise à jour le long du chemin. Je viens de mettre à 3.2.2.

maintenant, quand je clique sur les drapeaux, je remarque l'URL change aussi. Cependant, parfois, la page se charge correctement, mais d'autres fois, j'ai simplement obtenir une page blanche qui dit "page non trouvée". mon site est informedtrades.com. J'ai vBSEO installé.

J'ai vu certaines personnes rapportant des expériences similaires, mais je n'ai vu personne parler a lieu uniquement une partie du temps, ni je vois des gens qui avaient seulement un problème après cette mise à jour récente. désolé si cela a déjà été traitée et je l'ai raté.

des idées sur la façon de régler le problème?

Merci
simit
Bonjour, J'ai aussi arrivé une fois, mais si vous rechargez la page à nouveau et le fait bien. La vérité qui est rare, salutations.

vBET
26-11-09, 04:55
La vérité est que ce n'est pas grave pour aussi est-il rare - il ne devrait pas arriver du tout et nous ferons de notre mieux pour rendre ça fonctionne tout le temps:)

simit patel
26-11-09, 16:18
Je revins à vBET 312, qui fonctionne très bien. ainsi, la question est liée à une certaine différence entre 312 et 322. Aussi, quand j'ai repris à 312, la première chose que j'ai faite a été d'un produit écraser. le problème persistait. puis, quand j'ai téléchargé les fichiers de 312, qui semblait pour résoudre le problème. oui, peut-être le problème est lié à un fichier d'édition a fait entre 312 et 322.

également intéressant de noter, c'est que je n'ai vbblogs installé. ce ne fut pas touché du tout; URL dans les blogs n'étaient pas écrites en caractères étrangers. ni en 322, ni en 312.

J'aimerais vraiment profiter des nouvelles fonctionnalités en 322. est de toute façon je peux le faire à la lumière de la situation?

Merci
simit

AJOUT: et bien sûr j'ai la dernière version de vBulletin installé.

vBET
26-11-09, 16:23
Elle n'est pas la meilleure idée pour réinstalle faite lorsque le soutien est sur votre planche ...

Aussi je trouve que c'est un problème avec la configuration du site est interdite. Les modèles que vous avez pour le thread ne permettra pas de signes étrangers:


'VBSEO_URL_THREAD' => '(\d+)-([a-z\._\-ŠŽšžźŔÁÂĂÄĹÇČÉĘËĚÍÎĎŃŇÓÔŐÖŘŮÚŰÜÝŕáâăäĺçčéęëěíîďńňóôőöřůúűüý˙µA-Z\d-]+)\.html',


il doit être quelque chose comme ceci:


'VBSEO_URL_THREAD' => '([^/]+)/(\d+)-([^/]+)\.html',


Mais ne changez pas manuellement. Ce schéma est en de nombreux endroits dans la configuration du site est interdite. S'il vous plaît me PM accéder aux détails de votre PC vBSEO et je vais trouver quel paramètre de configuration est responsable de cela.

vBET
26-11-09, 16:38
La raison est erroné de configuration vBulletin.

Réglez l'option "Remplacer caractères non anglais dans les URL?" à «tenir les non-caractères anglais dans les URL".

Cette mystérieusement disparaître de nos manuels d'intégration. Désolé pour les troubles:) vient de mettre le paramètre et il sera très bien:)

jorgejgm
26-11-09, 17:28
La raison est erroné de configuration vBulletin.

Réglez l'option "Remplacer caractères non anglais dans les URL?" à «tenir les non-caractères anglais dans les URL".

Cette mystérieusement disparaître de nos manuels d'intégration. Désolé pour les troubles:) vient de mettre le paramètre et il sera très bien:)

Pour l'espagnol il ya un problème avec les lettres CETTE lettres N, O, I, etc etc (LA TRADUIRE POUR ENLEVER N, O, I.Après avoir activé vBulletin « remplacer les caractères non anglais » remplacé par la lettre n ou (I) dans l'URL. C'est très bon pour le référencement.Avec l'option « Conserver Non anglophones caractères dans les URLs » caractères sont remplacés par ~. Quelque chose qui affecte la seo beaucoup. Pour les révisions futures de VB seront « résolus » ou est techniquement impossible?.Merci.

vBET
26-11-09, 20:12
Après avoir activé vBulletin « remplacer les caractères non anglais » remplacé par la lettre n ou (I) dans l'URL. C'est très bon pour le référencement.Avec l'option « Conserver Non anglophones caractères dans les URLs » caractères sont remplacés par ~. Quelque chose qui affecte la seo beaucoup. Pour les révisions futures de VB seront « résolus » ou est techniquement impossible?.Merci.

Cela se fait par vBulletin - vBET ne fait de tels remplacements. Vous devez configurer correctement vBSEO. Vous pouvez avoir l'option de garder pas Espagnol SNA personnages aussi configurer manuellement dans FORUM_DIR / inclues / paramètre config_vbseo.php $ vbseo_custom_char_replacement. Merci que vous serez capable de travailler avec traduits URL et conserver votre URL pour la langue maternelle que ceux où.

Regardez ici:

http://www.forum.simple-nlp.pl/informacje/1274-pierwsze-na-swiecie-forum-o-nlp-wspierajace-wielojezyczna-spolecznosc.html

C'est URL où les lettres polonaises (comme SAEC) a changé grâce à $ vbseo_custom_char_replacement et il garde encore toutes les autres lettres pas l'anglais. C'est le même lien pour le Japonais:

http://www.forum.simple-nlp.pl/ja/informacje/1274-nlp多言語のサポートのための世界初のフォーラム!.html

Aussi ce n'est bon exemple pourquoi vous devriez garder pas l'anglais / Espagnol personnages - certaines langues ont noly pas l'anglais / Espagnol caractères.

C'est par exemple la façon dont vous pouvez définir la valeur vbseo_custom_char_replacement $ (pour les lettres polonais):


$vbseo_custom_char_replacement = array(
'ˇ' => 'A',
'¦' => 'S',
'¬' => 'Z',
'±' => 'a',
'¶' => 's',
'Ľ' => 'z',
'ą' => 'a',
'ę' => 'e',
'ć' => 'c',
'ż' => 'z',
'ś' => 's',
'ź' => 'z',
'ó' => 'o',
'ł' => 'l',
'ń' => 'n',
'Ą' => 'A',
'Ę' => 'E',
'Ć' => 'C',
'Ż' => 'Z',
'Ś' => 'S',
'Ź' => 'Z',
'Ó' => 'O',
'Ł' => 'L',
'Ń' => 'N'
);


Donc, comme vous voyez - vous pouvez garder Dieu SEO façon pour vos liens existants et d'ouvrir des liens traduits en 52 langues:)

J'espère que cela va aider en cas de toute autre question il suffit de demander - nous sommes là pour vous aider:)

jorgejgm
26-11-09, 21:27
Merci beaucoup encore une fois, fonctionne parfaitement. Je vous remercie.

Automatic Translations (Powered by Google, Microsoft®, Yandex, SDL Language Cloud, IBM Watson and Apertium):
AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.9.99 you can enjoy automatic translations