PDA

View Full Version: Løst Lejlighedsvise problemer med URL Conversion



simit patel
25-11-09, 18:06
Hej,

Jeg har brugt vbet siden 2.X branchen, og har været opgradere undervejs. Jeg har netop opgraderet til 3.2.2.

nu, når jeg klikker på flagene, jeg mærker URL skifter så godt. Men nogle gange siden indlæses korrekt, men andre gange, jeg simpelthen får en hvid side, der siger "siden ikke fundet". mit site er informedtrades.com. Jeg har vbseo installeret så godt.

Jeg så nogle mennesker rapportering lignende oplevelser, men jeg kunne ikke se nogen tale om det forekommer kun noget af tiden, heller ikke jeg kan se folk, der kun havde et problem efter den seneste opgradering. beklager, hvis dette allerede var behandlet, og jeg savnede det.

nogen ideer til, hvordan du løser problemet?

tak
simit

vBET
25-11-09, 20:44
Hej. Jeg tror, jeg fandt mønsteret. På dit forum links som har specialtegn hævdes at være ikke fundet. Jeg ved ikke hvorfor endnu.

Vi er ikke i stand til at reproducere det på vores servere (som du kan se her er det fungerer godt), så kan du PM mig adgang detaljer til din Admin CP og FTP.

jorgejgm
26-11-09, 00:03
Hej,

Jeg har brugt vbet siden 2.X branchen, og har været opgradere undervejs. Jeg har netop opgraderet til 3.2.2.

nu, når jeg klikker på flagene, jeg mærker URL skifter så godt. Men nogle gange siden indlæses korrekt, men andre gange, jeg simpelthen får en hvid side, der siger "siden ikke fundet". mit site er informedtrades.com. Jeg har vbseo installeret så godt.

Jeg så nogle mennesker rapportering lignende oplevelser, men jeg kunne ikke se nogen tale om det forekommer kun noget af tiden, heller ikke jeg kan se folk, der kun havde et problem efter den seneste opgradering. beklager, hvis dette allerede var behandlet, og jeg savnede det.

nogen ideer til, hvordan du løser problemet?

tak
simit
Hej, jeg også sket én gang, men hvis du har genindlæst siden igen og gør det godt. Sandheden, som er sjældne, hilsener.

vBET
26-11-09, 04:55
Sandheden er, at det ikke betyder noget, så er det sjældent - det bør ikke ske på alle, og vi vil gøre vores bedste for at gøre det virker hele tiden:)

simit patel
26-11-09, 16:18
Jeg vendte tilbage til vbet 312, der virker fint. så er problemet knyttet til en vis forskel mellem 312 og 322. også, da jeg vendte tilbage til 312, det første jeg gjorde, var et produkt overskrive. problemet stadig fortsatte. Da jeg uploadede filerne på 312, der syntes at løse problemet. ja, måske det problem vedrører en fil redigere der mellem 312 og 322.

også værd at bemærke er, at jeg har vbblogs installeret. det var ikke påvirket overhovedet; URL'er i blogs ikke blev skrevet i udenlandske karakterer. hverken i 322, eller i 312.

Jeg vil virkelig gerne drage fordel af de nye funktioner i 322. er der alligevel jeg kan gøre, at i lyset af den situation?

tak
simit

TILFØJET: og selvfølgelig har jeg den nyeste version af vbseo installeret.

vBET
26-11-09, 16:23
Det er ikke god ide at lavet geninstallerer, når støtten er på din bord ...

Også finder jeg ud af, at dette er et problem med vBSEO konfiguration. De mønstre, som du har til tråden vil ikke tillade, for udenlandske tegn:


'VBSEO_URL_THREAD' => '(\d+)-([a-z\._\-ŠŽšžźŔÁÂĂÄĹÇČÉĘËĚÍÎĎŃŇÓÔŐÖŘŮÚŰÜÝŕáâăäĺçčéęëěíîďńňóôőöřůúűüý˙µA-Z\d-]+)\.html',


det skal være noget som dette:


'VBSEO_URL_THREAD' => '([^/]+)/(\d+)-([^/]+)\.html',


Men ikke ændrer den manuelt. Et sådant mønster er i mange steder i vBSEO konfiguration. Venligst PM mig adgang detaljer til din vBSEO CP og jeg vil finde ud af, hvilken konfiguration parameter er ansvarlig for dette.

vBET
26-11-09, 16:38
Årsagen er forkert vBSEO konfiguration.

Sæt option "Erstat ikke-engelske tegn i URL'er?" til "Hold ikke-engelske tegn i webadresser".

Dette mystisk vis forsvinder fra vores integration manual. Sorry for problemer:) bare indstille parameter, og det vil være fint:)

jorgejgm
26-11-09, 17:28
Årsagen er forkert vBSEO konfiguration.

Sæt option "Erstat ikke-engelske tegn i URL'er?" til "Hold ikke-engelske tegn i webadresser".

Dette mystisk vis forsvinder fra vores integration manual. Sorry for problemer:) bare indstille parameter, og det vil være fint:)

For den spanske der er et problem med bogstaverne DETTE BOGSTAVER N, O, I, etc etc (Oversæt FJERN til n, o, jeg.Efter at have aktiveret "erstatte ikke-engelske tegn" vbseo erstattes med bogstavet n eller (I) i URL-adressen. Det er meget godt for seo.Med indstillingen "Bevar ikke-engelske tegn i webadresser" tegn erstattes af ~. Noget, som påvirker seo meget. Til fremtidige revisioner af VB "løses" eller teknisk set er umuligt?.Tak.

vBET
26-11-09, 20:12
Efter at have aktiveret "erstatte ikke-engelske tegn" vbseo erstattes med bogstavet n eller (I) i URL-adressen. Det er meget godt for seo.Med indstillingen "Bevar ikke-engelske tegn i webadresser" tegn erstattes af ~. Noget, som påvirker seo meget. Til fremtidige revisioner af VB "løses" eller teknisk set er umuligt?.Tak.

Dette gøres ved vBSEO - vBET ikke foretaget sådanne erstatninger. Du har mulighed for behørigt at konfigurere vBSEO. Du kan have mulighed for at holde ikke Espagnol tegn ans også konfigurere manuelt i FORUM_DIR / inclues / config_vbseo.php parameteren $ vbseo_custom_char_replacement. Tak at du vil være i stand til at arbejde med oversat URL'er og holde dine eksisterende URL til modersmål som dem, hvor.

Se her:

http://www.forum.simple-nlp.pl/informacje/1274-pierwsze-na-swiecie-forum-o-nlp-wspierajace-wielojezyczna-spolecznosc.html

Det er webadresse, hvor polske bogstaver (ligesom śąęć) blev ændret takket være $ vbseo_custom_char_replacement og det stadig holder alle andre ikke engelske bogstaver. Det er samme link for japanske:

http://www.forum.simple-nlp.pl/ja/informacje/1274-nlp多言語のサポートのための世界初のフォーラム!.html

Også dette er godt eksempel på, hvorfor du bør holde ikke engelsk / Espagnol tegn - nogle sprog har noly ikke engelsk / Espagnol tegn.

Dette er eksempel, hvordan du kan indstille $ vbseo_custom_char_replacement værdi (for polske bogstaver):


$vbseo_custom_char_replacement = array(
'ˇ' => 'A',
'¦' => 'S',
'¬' => 'Z',
'±' => 'a',
'¶' => 's',
'Ľ' => 'z',
'ą' => 'a',
'ę' => 'e',
'ć' => 'c',
'ż' => 'z',
'ś' => 's',
'ź' => 'z',
'ó' => 'o',
'ł' => 'l',
'ń' => 'n',
'Ą' => 'A',
'Ę' => 'E',
'Ć' => 'C',
'Ż' => 'Z',
'Ś' => 'S',
'Ź' => 'Z',
'Ó' => 'O',
'Ł' => 'L',
'Ń' => 'N'
);


Så som du ser - du kan holde Gud SEO måde for din eksisterende forbindelser og åbne for oversatte links i 52 sprog:)

Jeg håber dette vil hjælpe i tilfælde af andre spørgsmål, bare spørg - vi er her for at hjælpe dig:)

jorgejgm
26-11-09, 21:27
Mange tak igen, virker perfekt. Tak.

Automatic Translations (Powered by Google, Microsoft®, Yandex, SDL Language Cloud, IBM Watson and Apertium):
AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.9.99 you can enjoy automatic translations