PDA

View Full Version : vbMediaWiki Vector integration



cevo
13-09-10, 09:42
I am currently using this mod
vbulletin.org/forum/showthread.php?t=247279

It doesn't seems to compatible with vBET since when I tried to browsing to this page
mysite/forum/de/wiki

It was returned "Page not found"

Normally the wiki page must be access using this url
mysite/forum/wiki

Any htaccess modification need to be fix?

vBET
13-09-10, 14:11
Please show us your actual .htaccess rules and point those which are made for vbMediaWiki (if any).

cevo
13-09-10, 19:45
Here is all I got



#===VBSEO

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /forum/

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

### VBET

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/index.php [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

## END VBET


### VBSEO
#RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteCond %{REQUEST_URI} !(media/|admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

vBET
13-09-10, 20:04
I just checked link you gave:

YOURFORUM_DOMAIN/forum/wiki
and it also doesn't work. Please first make sue that the mod is working at all, or give appropriate URL to access its pages.

cevo
14-09-10, 22:43
I just checked link you gave:

YOURFORUM_DOMAIN/forum/wiki
and it also doesn't work. Please first make sue that the mod is working at all, or give appropriate URL to access its pages.


Sorry I was told you the wrong url, actually it should be mydomain/wiki not mydomain/forum/wiki

vBET
15-09-10, 12:11
So everything is clear now :) You have to integrate it as described here: How to translate pages outside forum directory? (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1546)

This will make links to translated pages recognized. If after this pages will not translate (but work), then please use also this integration instruction for mods which doesn't supports global_complete hook (http://www.vbenterprisetranslator.com/forum/vbet4-integration-other-plugins/486-vbet-integration-instructions.html#post1787) (I do not know will it be necessary of not - I'm giving this information just in case ;))

cevo
15-09-10, 13:02
This code should be in mydomain/forum/.htaccess ?? or mydomain/.htaccess?


RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1&vbet_outside=true [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1&vbet_outside=true [L,QSA]


If it should be in mydomain/forum/.htaccess
Which location I should place the code? after or before the vBET existing condition?
It just placed it before the vBET and result is : it cause existing vBET feature to broken and not even translate at all.

And this code should be in mydomain/wiki/.htaccess right?


RewriteCond %{QUERY_STRING} !vbet_outside=true
RewriteRule ^(.*)$ $1?vbet_outside=true [L,QSA]

vBET
15-09-10, 16:02
You do not change your .htaccess in forum directory. This is already working. Now you have to integrate directories outside forum.

It is clearly described, that first set of rules you have to add into .htccess in forum PARENT directory. So mydomain/.htaccess

And yes - 2nd set you add into wiki directory :)

cevo
15-09-10, 21:25
I managed to make it almost working.
When browsing to following URL My Wiki got translated properly.


http://mydomain/zh-CN/wiki


However, the navigation menu of wiki alway pointed to incorrect url which is


http://mydomain/forum/zh-CN/wiki.


How can I fix this ?

vBET
16-09-10, 15:41
Do you have turned on option URL tracking outside forum directory?
Do you use ABSOLUTE link (starts from http) for wiki in your output html?

cevo
16-09-10, 19:55
Do you have turned on option URL tracking outside forum directory?
Do you use ABSOLUTE link (starts from http) for wiki in your output html?

1. Yes I have already turned on.

2. I don't undetstand this question what you mean by "output html"?

vBET
16-09-10, 20:08
1. Yes I have already turned on.

2. I don't undetstand this question what you mean by "output html"?

I mean when you see page on broswer and go to html source - this is output html send by your server. If the link is relatice then it will not work appropriatelly. Must be absolute. Please note that this requrement is only for sections outside forum directory.

cevo
17-09-10, 06:32
OK, I managed to fixed the problem by make the wiki to be absolute url instead of relative path. THANK A LOT FOR YOUR SUPER SUPPORT !!

vBET
17-09-10, 10:55
OK, I managed to fixed the problem by make the wiki to be absolute url instead of relative path. THANK A LOT FOR YOUR SUPER SUPPORT !!

Glad you like it! :D

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vB Enterprise Translator 4.9.99