PDA

View Full Version : Solved Get error message every moving threads



basketmen
08-09-10, 11:34
I get this error message every moving threads


Fatal error: Call to undefined function vbet_vbseo_filter_replace_text() in /home/username/public_html/vbseo/includes/functions_vbseo_createurl.php on line 47


still using default language, the threads are moved, but its looks like not redirecting to rewrited url again after succesfully moving the thread, still with domain.com/showthread.php?t=123456 and get the error message, look in screenshot






http://i291.photobucket.com/albums/ll284/basketmen/3.jpg

vBET
08-09-10, 22:51
Looks like some issue with .htaccess - I was making special integration there (PM) so your rules are not standard and this is the issue (request comes without out seo file, so our additional functions are not included and integrated vBSEO code is not working). We agreed by PM that I will still work on those rules (for your special member pages) so I still have access details - I will correct it on place :)

basketmen
08-09-10, 23:16
Looks like some issue with .htaccess - I was making special integration there (PM) so your rules are not standard and this is the issue (request comes without out seo file, so our additional functions are not included and integrated vBSEO code is not working). We agreed by PM that I will still work on those rules (for your special member pages) so I still have access details - I will correct it on place :)
ah so because of that, it is ok then not too important/not urgent for now, because the threads are moved, only get that error message, it is more important the member pages


this thread solved

vBET
09-09-10, 07:34
Thanks for feedback. I already find out solution for that, so after solving member pages I will solve also this issue.

vBET
10-09-10, 07:36
This issue seems to be easier to solve thant your memberpages special case. So it is solved now (I will stil work on member pages).

Please note that because of your customized .htaccess rules you will have to made 1 additional integration step with vBSEO every time you made update of vBSEO. This step is one more change in file FORUM_ROOT/vbseo/includes/functions_vbseo_createurl.php. So when you will change this file according to normal integration instructions, please also:
1. Find:

<?php
2. Add AFTER:

require_once(dirname(__FILE__). '/../../includes/vbenterprisetranslator_functions_vbseo.php');

This solves the issue with moving threads :)

basketmen
10-09-10, 07:55
This issue seems to be easier to solve thant your memberpages special case. So it is solved now (I will stil work on member pages).

Please note that because of your customized .htaccess rules you will have to made 1 additional integration step with vBSEO every time you made update of vBSEO. This step is one more change in file FORUM_ROOT/vbseo/includes/functions_vbseo_createurl.php. So when you will change this file according to normal integration instructions, please also:
1. Find:

<?php
2. Add AFTER:

require_once(dirname(__FILE__). '/../../includes/vbenterprisetranslator_functions_vbseo.php');

This solves the issue with moving threads :)
yes its working, thank you very much :)

so we dont need to change in the bold


require_once(dirname(__FILE__). '/../../includes/vbenterprisetranslator_functions_vbseo.php');

to our own path like

require_once(dirname(__FILE__). '/home/username/includes/vbenterprisetranslator_functions_vbseo.php');

vBET
10-09-10, 11:53
Do not change it - it is already working solution. If you want to change it to specific path in your server then just set there full hard-coded path, but even this is not necessary here.

basketmen
23-09-10, 13:07
MichaƂ i am sorry just found this


When i go to admincp --> then go to Moderate LinkBacks, or Incoming LinkBacks, or Outgoing LinkBacks page but i only get this error message :


Warning: require_once(/home/username/public_html/modcp/includes/functions.php) [function.require-once]: failed to open stream: No such file or directory in /home/username/public_html/includes/init.php on line 155

Fatal error: require_once() [function.require]: Failed opening required '/home/username/public_html/modcp/includes/functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/username/public_html/includes/init.php on line 155


if i remove this line those linkback page is opened again normal, so its looks make some vbseo feature wrong path


require_once(dirname(__FILE__). '/../../includes/vbenterprisetranslator_functions_vbseo.php');


can you make that line more perfect again? if not maybe i will use if not conditional for those linkbacks page like


if (THIS_SCRIPT != 'scriptname') {
require_once(dirname(__FILE__). '/../../includes/vbenterprisetranslator_functions_vbseo.php');
}

vBET
23-09-10, 13:30
This solution was not prepared to work in admincp just on forum pages. You have to add condition which will change path in case of admincp, or will just not add this vBET file then.

basketmen
23-09-10, 17:09
got it so here is what i do


- in vbseo_moderate.php file after <?php i add this

define('THIS_SCRIPT', 'vbseo_moderate');

- then in functions_vbseo_createurl.php i wrap your code with if no conditional


if (THIS_SCRIPT != 'vbseo_moderate') {
require_once(dirname(__FILE__). '/../../includes/vbenterprisetranslator_functions_vbseo.php');
}



its working now if anyone need it too

vBET
24-09-10, 15:33
You had this issue because as I remember your server is using customized .htaccess rules. So this issue is not common. Anyway - thanks for sharing :) It can be useful for those who also will require customized .htaccess rules because of some other mods integration.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 gives automatic translations