PDA

View Full Version : word " af " in mid of URLs



newsoftw
26-08-10, 14:57
hi every one...

i have updated the vb from 3.8.4 to vb suite 4.0.6 with vbet 2.4.3.

after that the Google webmaster detecting the word " af " in mid of URLs of forum any thread or post


http://www.newsoftworld.com/forum/af/f11/_-aaa-congratulations-bara-nawab-100-posts-aaa-_-aaa-5646/
404 (Not found) 1 pages Aug 20, 2010

http://www.newsoftworld.com/forum/af/f11/_-aaa-congratulations-mr-sweet-rocky-3000-posts-aaa-_-aaa-10772/
404 (Not found) 1 pages Aug 20, 2010

http://www.newsoftworld.com/forum/af/f11/_-aaa-congratulations-mr-sweet_rocky-500-posts-aaa-_-aaa-4043/
404 (Not found) 1 pages Aug 20, 2010

plz help on that issue and how to fix or remove the " af " word from thread or post.

screen shot:
http://i38.tinypic.com/vsdyit.jpg


i contacted with vbseo team hey should sad to:
" Those are from the translator mod language codes. You will need to consult the mod author for support on that. "


my .htaccess file details:

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.newsoftworld\.com
RewriteRule (.*) http://www.newsoftworld.com/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]


#************************************************************-

#Rules for SEO translation links with vbSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]



Thanks in ADVNS
Best Regards
Admin of NSW
Ayaz Ali

kamilkurczak
27-08-10, 15:34
after translation you have:

http://www.newsoftworld.com/forum/f11/_-aaa-congratulations-bara-nawab-100-posts-aaa-_-aaa-5646/?language=pl
this is not ok:
?language=pl

So go to admincp->vBET-> Main and make a good configuration.

set Translation links type to Create URL's according to SEO link consensus (i.e. '/en/address')

and

set link type to VBSEO_URI

kamilkurczak
27-08-10, 16:13
ahh you are using a free version.
please search your vbet menu here
Configure in AdminCP -> vBulletin Options -> vBulletin Options -> vB Enterprise Translator

sorry for that

ok here you have a configuration instruction:
http://www.vbulletin.org/forum/showthread.php?t=232456


5. Configure in AdminCP -> vBulletin Options -> vBulletin Options -> vB Enterprise Translator
You MUST configure at least Forum language option. NOTE that there are some other important options - especially if your forum is in subdirectory or if you use vbSEO.

newsoftw
28-08-10, 18:57
thanks for reply...

sir i done all above sitting are u provide me after that vbet translator working stopped and show 404 error.

when i add the file: vbseo_sitemap_functions.php in vbseo_sitemap directory for vbseo sitemap 2.6b after that the sitemap report not going to be open and also google webmaster also not detect the siemap means not working


also plz check my .haccess file sitting and is it ok or not ?

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.newsoftworld\.com
RewriteRule (.*) http://www.newsoftworld.com/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]


#************************************************************-

#Rules for SEO translation links with vbSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]




also which below rule i use for my old link from ?language=pl to /af/forum/ for the google redirection

1. RewriteCond %{QUERY_STRING} (hl=)(zh-TW|zh-CN|..)$
RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1\?language=%2 [L,R=301]

2. RewriteCond %{QUERY_STRING} (hl=|language=)(zh-TW|zh-CN|..)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%2/$1? [L,R=301]


plz hep on that issue.


Thanks in ADVNS
Best Regards
Admin of NSW
Ayaz Ali

kamilkurczak
29-08-10, 15:57
Rules for SEO translation links with vbSEO (have to be included before all rules to vbseo.php)


<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.newsoftworld\.com
RewriteRule (.*) http://www.newsoftworld.com/$1 [L,R=301]

#Rules for SEO translation links with vbSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]


#************************************************************-



what now?

newsoftw
29-08-10, 16:56
thanks for reply


sir i add all Rules which are u provide as above but still same 404 page error show:
http://www.newsoftworld.com/forum/af/


and sitemap working start

i don't know why its not working with me ?


thanks

kamilkurczak
31-08-10, 13:44
in which folder the file is (.htaccess)?
in forum folder? if not can you copy this file into forum folder?
put this file into 'forum' folder

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

#Rules for SEO translation links with vbSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]


#************************************************************-

newsoftw
31-08-10, 14:29
thanks for reply

sir my .htaccess is not in forum folder and my .htaccess file is present in the root directory
coz my CMS is run from root and forum is run from sub directory " forum " folder.

kamilkurczak
31-08-10, 15:38
so, jusy put a .htaccess file from my previous post into your forum folder
(forum)

newsoftw
31-08-10, 20:17
thanks for reply

sir when i move my .htaccess file from root directory to forum folder so my forum is not properly working coz i am using the vbseo rule and sitting under the below thread :

http://www.vbseo.com/f5/vbseo-3-5-release-candidate-1-here-39776/index10.html#post254125

in this thread i used the /forums (or another folder name) vb4 install rule and sitting so this is the reason i am placed my .htaccess file in root directory.

plz check the vbseo thread for the reason of placed my .htaccess file in root directory.

so how i can fix this problem.


thanks

kamilkurczak
31-08-10, 21:39
old file may be in the root directory. but file from my previous post please put into a "forum" folder.

You should have to files. one .htaccess in root folder and on (from my post) in "forum" folder

newsoftw
05-09-10, 10:38
thanks for reply

sir when i placed one copy of .haccess file in root directory and one in forum directory so after that my forum give me below error :

Not Found
The requested document was not found on this server.

Web Server at newsoftworld.com

so i deleted the .htaccess file from root directory.

vBET
05-09-10, 20:45
At this moment I see that your translations links are not working at all. Please give me you actual WHOLE .htaccess conent from your forum directory.

newsoftw
06-09-10, 11:08
thanks for reply.

sir my .htaccess file is placed in root directory and not present in forum directory by the new Rule or sitting of vbseo in below thread:
vBSEO 3.5 Release Candidate 1 is here! - vBulletin SEO Forums (http://www.vbseo.com/f5/vbseo-3-5-release-candidate-1-here-39776/index10.html#post254125)

in this thread i used the /forums (or another folder name) vb4 install rule and sitting so this is the reason my .htaccess file placed in root directory.


my whole .htaccess file in root directory :


<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.newsoftworld\.com
RewriteRule (.*) http://www.newsoftworld.com/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]


#************************************************************-
#Rules for SEO translation links with vbSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]



please solve this problem coz Google webmaster is detected the upto 82000 link as 404 page and if you have proper solution so i will remove it permanently coz my website ranking down day by day and also my sitemap also not working from last 12 days.

Thanks and don't mind

vBET
06-09-10, 20:43
Please note that we didn't use .htaccess in folder other that forum directory. So solution below is not tested. Still hope it should help.



<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.newsoftworld\.com
RewriteRule (.*) http://www.newsoftworld.com/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^forum/(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=forum/ [L,QSA]
RewriteRule ^forum/(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]

newsoftw
07-09-10, 19:13
thanks for reply.

vbet translator is working start but every things show wrong as please check the below link:
http://www.newsoftworld.com/forum/af/

so now how i can fix this problem.

thanks

vBET
07-09-10, 19:22
Please see here:
http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq.html#post1537

newsoftw
07-09-10, 20:19
thanks for reply.

1. You didn't fallow installation instructions. You MUST configure Forum language option. Just configure mod:
a) i reupload the all file to my forum directory and then i add the .htaccess file to my root directory with the above .htaccess file sitting which provided by you.
now my .haccess file:



<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forum/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.newsoftworld\.com
RewriteRule (.*) http://www.newsoftworld.com/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^forum/(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=forum/ [L,QSA]
RewriteRule ^forum/(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]



b) then i edited the vbseo_sitemap_functions.php in vbseo_sitemap directory for Integration :

Find:



vbseo_log_entry("
[showthread] forum_id: $forumid, thread_id: $threadrow[threadid], total posts: $totalposts, pages: $totalpages, views: $threadrow[views] $prior");



And place AFTER it...

For SEO links




//additional code
$alanguages = array ('af','sq','ar','be','bg','ca','zh-CN','hr','cs','da','nl','en','pl','et','tl','fi','fr','gl','de','el','iw','hi','hu','is','id','ga','it','ja','ko','lv','lt','mk','ms','mt','no','fa','pt','ro','ru','sr','sk','sl','es','sw','sv','zh-TW','th','tr','uk','vi','cy','yi');
if(!$archived) {
$strlenhost = strlen($vbseo_vars['bburl']."/");
$currentthreadurl = vbseo_url_thread($threadrow, 1, $archived);
$currentthreadurl_before = substr($currentthreadurl,0,$strlenhost);
$currentthreadurl_after = "/".substr($currentthreadurl,$strlenhost);
$lastpost =& $threadrow['lastpost'];
$vbseo_stat['t'] += sizeof($alanguages);
foreach($alanguages as $language) {
vbseo_add_url($currentthreadurl_before.$language.$currentthreadurl_after, $prior, $lastpost, $freq);
}
}
//end additional code



c) forum language = English
d) Link Type = VBSEO_URI
e) Forum directory = /forum
f) Translation links type = Create URL's according to SEO link consensus (i.e. '/en/address')



2. You set wrong Google Translation API key - set it to appropriate value or remove it (not advised - just set it appropriately)
a) one time i checked with Google API key and one time without Google API key but still same error.


3. For some reason you was blocked by Google
a) i create the new file in root directory as name test.php which report is below:
http://www.newsoftworld.com/test.php



Starting translation test
Test result: {"responseData": {"translatedText":"powitanie"}, "responseDetails": null, "responseStatus": 200}
Test error:



means i done all sitting but still same problem with me.

so now what i do for this problem to fix it.


thanks

newsoftw
12-09-10, 19:46
i am waiting 4 response but still not any help....


thanks

vBET
16-09-10, 16:09
Please PM me access details to your Admin CP and FTP. As I wrote before we didn't use before vBET with .htaccess outside forum folder. I look on it again, but found nothing - I need to check it on your forum.

You can also just use .htaccess inside of forum folder (need changes in actual rues) like vBET supports it right now.

newsoftw
16-09-10, 19:18
Thanks for reply sir.

i sent you all my VB Admin CP and FTP access details in PM and please check it.

thanks

vBET
16-09-10, 19:28
Yes - just saw and checked. Acces is OK, but I cannot find on your FTP your forum directnory nor .htaccess file (see PM). Please PM me exact locations.

newsoftw
16-09-10, 20:38
thanks for reply sir.


please check again my PM ( sent to you ).

thanks

vBET
16-09-10, 23:08
You had in rules:


redirected=forum/ and redirected=forum/$2


Should be:


redirected=/forum/ and redirected=/forum/$2

Cause found and corrected, so translated pages are generating now.

Now you have one more issue - styles are not working.

newsoftw
17-09-10, 06:53
thanks for great help.

i found the better solution is that i removed the vbet from my forum and now the server load and database error both are solved coz when any body open then translated link of my forum so it take very much time not be open and when the link is so it show no styles on translated pages.

so now just till me how to stop Google redirection translated links means when i removed the vbet Google still search translated link of my forum.

well i am very thankful who help me in this issue.

thanks

vBET
20-09-10, 12:44
Rule which will redirect all translated pages to not translated one:


RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2 [L,QSA]

Please adopt it to your special case and test it.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vB Enterprise Translator 4.9.99