PDA

View Full Version : Solved Problem with styles and vBET



Santori
15-08-10, 18:13
Hello: I describe my setup. Vbulletin-4.0.5 and I have installed the latest version vBET. 'I have vbseo running, but have not integrated with vBSEO vBET. I changed the files and vBSEO sitemap vBSEO forum and I disappeared. So I left the originals. 'I have not changed. Htacess either. Vbeta seems to work well without being integrated with vBSEO, corrígame if I'm wrong, please. My problem:-I have three different styles to choose by the user chooses them usuario.El and all is well. -I have several forums with a default style, so that when you enter gets this style. -With activated vbeta not work. I can not associate forums styles. Please tell me how to solve this problem. Thank you very much.

Santori
16-08-10, 20:41
Please, I need a solution to this.

vBET
16-08-10, 22:34
Please note that it you do not integrate vBET with vBSEO, then it will work, but links will not be translated. Ii is better for your SEO to integrate and have links translated, so we advice this. If you have issues with integration - first make sure you made everything as it is displayed. Then open new thread with bug report for that. Also please write which vBSEO version are you using.

About default styles for forums. First - please tell does it also doesn't work when guest cache is disabled. 2nd - please describe how you paired default style with forum? Is it some vBuletn configuration (where) or it is done by some mod. We need details to be able to reproduce the issue and solve it. Also we need to know is it really a bug, or some integration issue.

Santori
17-08-10, 00:48
Hello:

I change the option:Use Full File Cache For Guests (BETA!)No.

I set defaults styles by vbulletin normal functions. no mods.

You can test this: Go to admincp-Forum and moderators.

Take any forum and put personalized style for any forum.
Set Rewrite election by user : yes

If you enter to this forum the style changes. No matter what style do you use at the moment.

Now doesn,t works.

Thanks a lot

Santori
18-08-10, 15:14
Hi, more info: I have installed vbulletin 4.0.6. No nigún mod or vBSEO. Unable to attach to any style to any forum vbeta

Santori
19-08-10, 10:32
Please look at me this is a normal function of vbulletin what does not.

kamilkurczak
19-08-10, 11:00
you mean. forum style chosing by user? I must be logged or not?

Santori
19-08-10, 13:47
No. It´s not neccesary.


You can see this in my page:

aquaterraria.com - Inicio (http://www.aquaterraria.com)

This page have three general styles, the users can choose they:

white
Green
Brown

If you go to the forum:

Dendrobates (http://www.aquaterraria.com/dendrobates)

The style changes ( color , header...). This style is only for this forum and the user can´t choose it.

When I active Vber , not works.

kamilkurczak
20-08-10, 18:17
do you have a vBET actived now? or not? because I was on your site and this style is workng only on the main site.

Santori
20-08-10, 21:28
Of course I have not activated! I can not turn vBET until this bug!

Santori
20-08-10, 21:50
I explain it to him again , to see if you understands. This is my place:main Page: White Colour , green or brown. The user can choose the one who prefer.aquaterraria.com (http://www.aquaterraria.com/forum.php)This is the forum: green Colour. With logo distinct. It is automatic. The user can not choose it. Neither change it.Dendrobates (http://www.aquaterraria.com/dendrobates/)This is a normal function of Vbulletin. When active VBET , this forum sees with the style predetermined for all the forum. It sees white. It does not see green. I can not put VBET because have several forums with personalised styles and if I put his program sees all equal.

vBET
21-08-10, 16:56
OK - I think I understand now the issue. But please confirm (vBulletin is huge - I have forums for years and still didn't use most of options).

For the subforum which you point you have selected default style - it cannot be changed by users and it is set for this forum by default. So when someone goes there is automatically switches to this style. And when someone is there he cannot switch style. Is that right?

Please tell us where we can set this option so we will be able reproduce the issue.

Also please tell us does it stops working when vBET Guest Cache is disabled, enabled or in booth cases. If it works with Guest Cache disabled then please turn on vBET and just disable Guest Cache until we will solve the issue.

Santori
21-08-10, 22:56
OK Thanks for responding.With cache enabled for guests: does not work.With cache disabled guests: does not work.The best way to test this e:1. create a new style from the style by defecto:2. in the new style to change something like the color of the body or the logo.3. Establish that the style is not selectable by the usuarios.4. Go to "Forum & Moderators": Go to: Admin forums Select any forum and go to Style options. Select: Style for this forum: Put the new style. Select rewrite style selected by user: yes. When you go to this forum the style changes. I think that's it.

kamilkurczak
23-08-10, 14:27
Thanks for this description, now I can reproduce it. Confirmed and will be fixed.
Thanks one more time. :)

Santori
24-08-10, 02:08
You're welcome. It's rare use this option. I am happy with your product and I hope this is resolved soon. Greetings!

vBET
24-08-10, 04:24
Solved and will be released in next version. For quick fix please:
1. Go to Admin CP -> Plugin Manager
2. Find and edit plugin "vB Enterprise Translator - Redirections"
3. Find there:

$this->load_style();
4. Put BEFORE:

$this->read_input_context();

Santori
24-08-10, 17:52
Thanks! Works perfect: D

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET 4.9.99