PDA

View Full Version : Solved Use Full File Cache For Guests (BETA!)



tsak76
29-07-10, 06:21
when this is turned on guests cant choose style :p

kamilkurczak
29-07-10, 14:50
ok, confirmed.
I reproduced it on my test forum. Now we will work on a solution. We will try to fix it.

tsak76
30-07-10, 14:19
any fix for this ? i need to use this cache option instead of the db

vBET
30-07-10, 21:13
Yes. It is already solved and will be included in next release. For quick fix:
1. Edit file /includes/vbenterprisetranslator_functions_guestcache.php
2. Find:

return DIR.'/'.VBET_GUEST_CACHE_DIR.'/'.($_REQUEST['language'] ? $_REQUEST['language'] : $vbulletin->options['vbenterprisetranslator_forumlanguage']).'/'.$filename.'.html';
3. Replace by:

return DIR.'/'.VBET_GUEST_CACHE_DIR.'/'.($_REQUEST['language'] ? $_REQUEST['language'] : $vbulletin->options['vbenterprisetranslator_forumlanguage']).'/'.$filename.$vbulletin->userinfo['styleid'].'.html';
4. (Optional but advised) Remove whole guest cache directory and copy it again from vBET package (remember about privileges) - we are changing files name conventions (styleid included) so old files will not be used anymore and it will be only waist of space. Please note that next release will have automatic old files cleaner included.

tsak76
30-07-10, 23:08
ok but we should not cache the default forum lang or not ?

tsak76
30-07-10, 23:14
oops i just see an error in translated pages post displays it was written in 1903 lol 06/10/1903, 16:02 in my def lang it shows 03-06-10, 16:02

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.2