PDA

View Full Version : Solved Vbulletin 404 page has display errors - major bug



Snake
14-07-10, 19:13
Found a new bug, basically with vbet enabled the vbulletin 404 page loses all css and formatting.

It does it on this forum too; http://www.vbenterprisetranslator.com/forum/vbet-good-stories/71999-another-success-story.html#post3562

I would very much like a quick fix for this, it makes my forum look bad.

Thanks.

kamilkurczak
15-07-10, 14:48
ok, confirmed.. this is a vBET bug. i will try to fix it.

kamilkurczak
15-07-10, 17:30
I found the code with bug. this is in global_start hook in vBET php file.
I noticed the part of code where the bug is. Now I am working on solution.

Snake
20-07-10, 00:09
Great news, when do you think you will have a fix?

vBET
20-07-10, 22:39
Hi :) Please note that I'm back - and I will handle this issue. I have few issues on my back, but will try to handle it asap. Cannot tell exactly when, but feel free to kick me if I will not answer you in 2 days ;)

Snake
20-07-10, 22:42
ok thanks. :)

vBET
22-07-10, 08:22
Fixed and will be included in next release. For quick fix please:
1. Edit /includes/vbenterprisetranslator_functions_hooks.php
2. Find:


$threadrow = verify_id('thread', $_GET['t'], 1, 1);
$threadurl = $vbulletin->options['vbenterprisetranslator_forumdir'].'/'.vbseo_thread_url_row($threadrow, $_GET['page'] ? $_GET['page'] : 1);
if ($threadrow && $threadurl != $_SERVER['VBSEO_URI']) {
exec_header_redirect($threadurl);
}

3. Replace by:


$threadrow = verify_id('thread', $_GET['t'], false, 1);
if ($threadrow) {
$threadurl = $vbulletin->options['vbenterprisetranslator_forumdir'].'/'.vbseo_thread_url_row($threadrow, $_GET['page'] ? $_GET['page'] : 1);
if ($threadrow && $threadurl != $_SERVER['VBSEO_URI']) {
exec_header_redirect($threadurl);
}
}

Snake
22-07-10, 10:04
Not working, just get blank white page on my forum.

kamilkurczak
22-07-10, 10:30
ok, code is edited, now the code is working good.
I deleted this part:

$_SERVER['VBSEO_URI']);

it made an php error

Snake
22-07-10, 11:02
Looks good, thanks.

vBET
22-07-10, 15:29
Yes - sorry. That was part of log which wasn't removed by addident. Thanks Kamil for correction :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages thanks to vB Enterprise Translator PRODUCER_PRODUCT_VERSION