PDA

View Full Version : vBET and vBulletin 3.6



vBET
03-07-10, 13:13
NOTE: This instructions are working for vBET 3.3.4 We have confirmation that those are not working with vBET 3.3.6 version. We will update it when it will be possible (vB 3.6 is not officially supported and we need access to some forum on such old version).
NOTE: This integration will made your archive pages to be able to translate, but EXCEPT archive sub-forum pages - there is bug in vBulletin which do not allow to do that.

This article describes additional integration steps required for vBulletin 3.6 (tested on 3.6.12). Please note that vBET 3.x oficially supports vBulletin 3.8. Still some of our clients successfully run it on vB 3.6 (or 3.7). And because 3.6 is not officially supported it requires some additional steps during installation and upgrade. Those steps will allow your archive pages to work and be translated correctly.

NOTE those steps are necessary if:
- You are working without vBSEO.
- You are using language= links
If you are using vBSEO and/or vBET SEO translation links, then please first check does your archive pages are working and translating well after vBET installation – if yes, then do NOT made any of additional steps.

Installation additional steps (do only once):
1. Copy directory (with all content) upload/images to your archive directory on your FTP

Update additional steps (do every time when you update vBET:
1. Disable plugin 'Handle flags in archive' for hook archive_process_start (Admin CP -> Plugins & Products -> Plugin Manager)
2. Open file includes/vbenterprisetranslator_functions_hooks.php
3. Find:

<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';
4. Change relative link images/vbet/flags/vbet.css to absolute one in your archive directory, like:

<link rel="stylesheet" type="text/css" href="http://YOUR_FORUM_URL_HERE/archive/images/vbet/flags/vbet.css"/>';
5. Find:

: '').'><img class="vbet-flag vbet-'.$code.'" width="16" height="11" src="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/clear.gif" alt="'.$name.'" '
6. Change relative link images/vbet/flags/vbet.css to absolute one in your archive directory, like:

: '').'><img class="vbet-flag vbet-'.$code.'" width="16" height="11" src="http://YOUR_FORUM_URL_HERE/archive/images/vbet/flags/clear.gif" alt="'.$name.'" '

EDIT:
If in your can not see flags in your archive, make this additional steps:
1. Enable plugin 'Handle flags in archive' for hook archive_process_start (Admin CP -> Plugins & Products -> Plugin Manager)
2. Edit plugin - Handle flags in archive
3. Find line
<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';
4. Change relative link images/vbet/flags/vbet.css to absolute one in your archive directory, like:

$metatags .= '
<link rel="stylesheet" type="text/css" href="http://YOUR_FORUM_URL_HERE/archive/images/vbet/flags/vbet.css"/>';
5. Save

PS.
Great thanks to mario06 for possibility to made this integration :)

mario06
15-08-10, 10:55
I installed v336 today and I applied the so called fixes but they don't work anymore, I've noticed some changes in the new files, can't you update this thread too when you update the versions? I had 2/3 hrs of downtime to get my site up and running again, this angers!!

mario06
16-08-10, 08:51
Where's the support?

vBET
16-08-10, 23:00
Thanks for your note. Please take our apologies that we didn't answer on Sunday, we didn't consider this issue critical.

Please send Kamil PM with access details to your forum and link to this issue. Because we do not officially support vBET 3.6 we need access to someone server to be able to work on this issue.

mario06
17-08-10, 07:40
I don't understand "We don't support 3.6"? I paid you an extra 30 dollars for the 3.6 mod and I pretend that on every update you keep this in mind with the relative updates, I will not send anyone my login details anymore because on August 7th someone tried to attack me through SSH.

I want a fix asap.

Regards

kamilkurczak
17-08-10, 18:27
hello,

Now, I will be try to find and fix this issue.
We cant reproduce this issue on our test forum so I need to have a full access to your forum admincp and FTP. Please sent it to me by PM.
Ofcourse, I will not change your forum traffic

mario06
17-08-10, 21:15
what do you mean you canot produce this error?

Your the compiler of vbenterprisetranslator_functions_hooks.php of version 334 so you should know what you changed in version 336 and apply detailed instructions.

A person can not give out his server details for every little problem, if you can not update this for me refund my money, when vbulletin.com update their board that don't overhaul the entire coding system otherwise all mods applied afterwards would be dead.

A little good sense should be used when updating this product, I'm getting angry because the same things are said over and over -> server and ftp :/

kamilkurczak
18-08-10, 08:30
We cant reproduce this issue because
vBET 3.x oficially supports vBulletin 3.8 not 3.6 and we use vBulletin 3.8 versions (on this forum and our test forum).
Michał sent to me his applications and now I know more in this thread.
As Michał wrote - please, PM to me your admincp andftm details.

mario06
18-08-10, 16:58
I know what you officially support because you keep on reminding me over and over and over again BUT I paid 30Dollars extra for this 3.6 compatibility addon/fix so that it could be ""officially supported"".

Did you read the fix that Michael posted on the first post of this thread with the relative 2 step fix for vBulletin 3.6.12 and vBET 3.3.4? Since you coded the 3.4, 3.5 and 3.6 of the vbenterprisetranslator_functions_hooks.php I don't see why you can't find the 2 additional steps for 3.6 because this confuses me?!?

I will not PM you my server data because everything is explained in the first post so fix it in the 3.6 version and email me the php files and I'll take care of uploading it.

I'm getting very frustrated with the same response.

Furthermore since Michael did start supporting 3.6.12 with charging me the extra fee he could support others that have it too, the problem is a "simple archive problem" that was resolved with 2 simple steps, maybe you should put up version 3.6.12 in local mod since its occupies 120mbs I don't know where the problem is.


Mr. kamilkurczak, do I need to post the PayPal Transaction ID for the additional 30 Dollars that I paid???????

vBET
18-08-10, 19:46
Please note that you didn't paid for us to officially support old version of vBET - you paid for integration specific version of vBET with your vB version in area of archive translations.

We do not officially support vB 3.6 and you can read this in first post here. I never started officially support vB 3.6 - please read first post of this thread again. I never charged you for supporting vB 3.6 - please read our PM again and please do not confuse my employee by false statements. Once again - you pid for integration of vBET version existing then with your vB version on area of archive translation. You do not need to post PayPal transaction Id - service which you paid was already delivered.

Because we do not officially support old versions we cannot guarantee that future releases of vBET will be also compatible with those. And in case if not we cannot solve issues without access to real forum - we do not officially support versions older than 3.8 and because of that we do not have testing environments or that.

If you want have your issue solved please just fallow given instruction. By not doing this you not allowing us to help you. If you want help - please fallow instructions. If not - then issue is closed. We are not able to help you when you do not allow us to do this.

Please note that we do not have to made anything in area of vB 3.6 - it is not officially supported. We offer you free help here. You can take this offer or refuse it, it is your choice, but please do not blame us for your choices.

mario06
18-08-10, 20:15
Free help??? When I paid $30 you never said anything about a one time deal, on the contrary here is a copy of your PM response (censored of course) that clearly states that you would give me the fix on every update:

http://img30.imageshack.us/img30/8772/vbet3.jpg

These are your words:
I will prepare you special document with necessary steps after each update(clearly means future vBET versions) to integrate with vbulletin 3.6 -> In plain English this means that on every vBET update I had to follow your special document for integration with vBulletin 3.6.

I'm waiting for the 2 step fix as paid for.

kamilkurczak
20-08-10, 19:40
As Michał wrote - we cant reproduce it and still need access to admincp and FTP so please if you can - PM to me or vBET

mario06
21-08-10, 06:33
I followed the above guide to the letter, the flags are there but invisibile but when you pass the mouse over it you se en pl ecc... just like I said the flags are not showing.

This is the only difference that I've noticed between 3.3.4 ans 3.3.6

3.3.4:

<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';

3.3.6:

$style['css'] .= '<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';

As you can see something in this area has clearly changed causing me the problems

vBET
21-08-10, 16:18
Free help??? When I paid $30 you never said anything about a one time deal, on the contrary here is a copy of your PM response (censored of course) that clearly states that you would give me the fix on every update:

http://img30.imageshack.us/img30/8772/vbet3.jpg

These are your words:
I will prepare you special document with necessary steps after each update(clearly means future vBET versions) to integrate with vbulletin 3.6 -> In plain English this means that on every vBET update I had to follow your special document for integration with vBulletin 3.6.

I'm waiting for the 2 step fix as paid for.

This is not true. You paid for integration service and this service was delivered. Also - please stop trying to manipulate our staff. This text which you are showing, it means that after update you will remove our changes and you have to do it again, otherwise you simply return to default code. It doesn't means that we guarantee that it will work on other versions. We cannot guarantee this, because we do not support vB 3.6.

If you want to quote publicly our private discussion this is what I wrote you before you paid:


I just logged in and first thing which I saw is that you have unsupported vBulletin version - vBET3.x is officially supported on vBulletin 3.8 version. You have 3.6... So there is no any vBET bug.
Anyway - even that we do not need to spend even a minute for that issue we ill check it. If I will be able find issue fast then there is no problem. If not then we advise to:
- update vBulletin (best)
- or just disable all vBET hoks for archive and stay without archive pages translation
- or bought integration service for $30, bur because it is on not supported vBulletin version we cannot assure you that we even will be able to make it work (we simply do not know that version and what is supported there).


Also please give us FTP access right now. I need to check does your version even supports all of hooks.

I put some text in red – just as you do it, to pay your attention on it. The text in bold was also bold in my PM.

You never paid for instructions - I wrote it and publish it because I wanted to do this and I wrote the text which you are pointing at after you paid for integration service - so please do not manipulate our staff by trying to convince that it was part of agreement. Whole agreement is in text which is above. You even asked to write thanks for you in this thread, because you didn't liked the idea that I wrote those instructions.

Please note: you already got what you paid for. You got integration and your archive pages was working as much as it was possible for vB 3.6

Now we offer you free support even that we do not have to do this - vB 3.6 is not and newer will be officially supported. If you want us to solve your issue - please PM access details just like you did it before.

We offer you free support for this issue, even that we do not have to do this. We did it for the very beginning of this issue. We do not know what you are trying to accomplish here by refusing to accept our support and in same time asking again for it, screaming and pointing in red some text in very manipulative way, but please note that out statement in this issue is official and final: vBET 3.x officially supports vBulletin 3.8. Older vBulletin versions are not officially supported. We offer you support and will to solve this issue for free. We find no joy in strange game which you play here. You already send us access once and we solved your issue according to integration service which you paid for - just do it again and we will do it for free this time, even that you are using vBulletin version which is not officially supported. This offer is available until 25th of this month. After this day we will no longer offer you free service in this case. You can take it or refuse it - it is your own choice. And only you are responsible for your own choices. We really want to help you very strong, but we are not able to do this against your own will.

vBET
21-08-10, 16:28
I followed the above guide to the letter, the flags are there but invisibile but when you pass the mouse over it you se en pl ecc... just like I said the flags are not showing.

This is the only difference that I've noticed between 3.3.4 ans 3.3.6

3.3.4:

<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';

3.3.6:

$style['css'] .= '<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';

As you can see something in this area has clearly changed causing me the problems

No we cannot without living vB 3.6 instance with vBET installed there. We cannot guess how looks vB 3.6 code and how it will behave after some changes. We need to check it and see it live, and we cannot do it on our forums, because we do not have such old version and do not officially support it. Also please note that the change you describe was made because of bug report - previously link to CSS was in wrong HTML section. If you just want to have it working - please just undo this change which you noticed. If you want it to work with appropriate HTML structure - we need access to your forum and check the possibility to put our link inside of HTML head section.

mario06
22-08-10, 06:23
This is what you wrote before adding the fix:


I just logged in and first thing which I saw is that you have unsupported vBulletin version - vBET3.x is officially supported on vBulletin 3.8 version. You have 3.6... So there is no any vBET bug.
Anyway - even that we do not need to spend even a minute for that issue we ill check it. If I will be able find issue fast then there is no problem. If not then we advise to:
- update vBulletin (best)
- or just disable all vBET hoks for archive and stay without archive pages translation
- or bought integration service for $30, bur because it is on not supported vBulletin version we cannot assure you that we even will be able to make it work (we simply do not know that version and what is supported there).


Also please give us FTP access right now. I need to check does your version even supports all of hooks.


This is what you wrote after applying the fix which means after the above PM and it clearly states -> I will prepare you special document with necessary steps after each update to integrate with vbulletin 3.6 -> In plain English this means that on every vBET update I had to follow your special document for integration with vBulletin 3.6. So don't reword everything so that it seems straight for you because the English Language isn't a theory.
http://img30.imageshack.us/img30/8772/vbet3.jpg

I can not give my server logins for security reasons and again I don't know why you cannot send me the hook.php file to upload to the server myself.

vBET
22-08-10, 11:05
You just repeat what both me and you already wrote. This was already discussed and it was already explained - please note that writing same messages is considered as spam. If you just want to write again same thing we will have to start to remove such notices because those made only garbage for future users. This is public place and spam is not allowed. Please read again your message here:
http://www.vbenterprisetranslator.com/forum/vbet-integration-other-plugins/810-vbet-vbulletin-3-6-a-2.html#post4533
and my answer here:
http://www.vbenterprisetranslator.com/forum/vbet-integration-other-plugins/810-vbet-vbulletin-3-6-a-2.html#post4578

You also was already answered for question why we cannot just made modification and send it to you - see here:
http://www.vbenterprisetranslator.com/forum/vbet-integration-other-plugins/810-vbet-vbulletin-3-6-a-2.html#post4579

Also please note that you already send us once access details to your forum, so argument about security reason is hard to believe. And since beginning of using vBET you know that you are using it on not supported vBulletin version - each issue on your forum will require our access there (if we will to support it, because we do not have to).

As I wrote - I do not understand what kind of game you are plying by refusing our free help and in same time demand it, but we are tried of this. You have solution - give us access details just like you did it before. If you do not want our help - it is your choice. Because of your strange attitude and waist of time by repeating same thing in circle, we made this proposition limited - see previous pots. We are very happy to help you - but cannot do it against your own will.

Please note that this discussion is considered as finished. Unless you have something new to write, please do not spam. We gave you solution - free support on your forum and solving the issue. Take it or not - your choice. Please note that we will be really happy to help you :)

basketmen
07-09-10, 05:40
i am using vb 3.6 too, here is what i do so the vb archive working too, just want to share it, if some one can make it more perfect please share it too


1. Fixing the flags in archive, if the flags not showing in your archive pages, use this step

go to your admin panel --> Plugins & Products --> Plugin Manager --> search for plugin "Handle flags in archive" without quotes

find


$metatags .= '
<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';


replace vBulletin Enterprise Translator (vBET) - Powered by vBulletin (http://www.vbenterprisetranslator.com/forum/) with your forum path, the flags not showing because wrong images pathor because the archive folder rewrited too in vbseo, so we are fixing it here


$metatags .= '
<link rel="stylesheet" type="text/css" href="http://www.yourdomain.com/forumfolderifany/images/vbet/flags/vbet.css"/>';



now reload and check again you archive, the flags should be showed in your archives pages too








2. If you use rewrited archive page using vbseo, and the link in translated archive page is wrong link you can fix it too


for example wrong link like this, it will get Page not found error


http://www.domain.com/forum/es/f-2.html

its should be like this, above url are missing a folder name in the bold below, some people using /archive/ ,or /sitemap/ folder name or other folder name


http://www.domain.com/forum/es/archive/f-2.html











to fix this we can use vbseo CRR

go to your vbseocp.php --> Custom Rewrite Rules --> add this line (in the bottom of CRR column) if your archive folder name using /archive/ like this http://www.domain.com/forum/archive/


'f-(\d+).html' => 'f/archive/f-$1.html'



if your archive folder using /sitemap/ folder name like this http://www.domain.com/forum/sitemap/ just change the folder name


'f-(\d+).html' => 'f/sitemap/f-$1.html'




this will do the trick, you can use vbet for vb 3.6 archive pages









3. If you get error message like this in the top of archive page sometime (this is not related or because 2 step above)


Warning: filemtime() [function.filemtime]: stat failed for [path]/vbet_guestcache/pl/_showthread_php_t_295527.html in [path]/includes/vbenterprisetranslator_functions_guestcache.php on line 53


use this meto instruction (http://www.vbenterprisetranslator.com/forum/vbet4-bug-reporting/932-warnings-guest-cache.html#post4453), i use it and its works

mario06
10-09-10, 16:00
@Michael
It isn't finished because you've decided it, it's finished when I solve the problem.
Regards

@basketman
did you do this all by yourself? That's great I'll try it in the next few days and let you know.
Regards mate

PS. Do I have disregard everything in the first post and simply do your modding?
Do I just do the 2 first steps since I don't have vBSEO?

basketmen
10-09-10, 16:06
@Michael
It isn't finished because you've decided it, it's finished when I solve the problem.
Regards

@basketman
did you do this all by yourself? That's great I'll try it in the next few days and let you know.
Regards mate


i just using already fixing code in this thread and another forum and have many testing

i already use it for few days and its still working, pm me if you need my url








PS. Do I have disregard everything in the first post and simply do your modding?
Do I just do the 2 first steps since I don't have vBSEO?

ah this can be different case, the problem no.1 and 2 i get i think caused by vbseo, because vbseo rewrited my archive pages

you can try Michał code first, if its not working, try mine, try it with your experiment, and make sure you have file backup to restore if the edited file not working

mario06
10-09-10, 16:13
You got a PM :)

mario06
10-09-10, 18:53
'f-(\d+).html' => 'f/archive/f-$1.html'

Can someone modify this so that it can be added in the htaccess file?

mario06
10-09-10, 19:05
i am using vb 3.6 too, here is what i do so the vb archive working too, just want to share it, if some one can make it more perfect please share it too


1. Fixing the flags in archive, if the flags not showing in your archive pages, use this step

go to your admin panel --> Plugins & Products --> Plugin Manager --> search for plugin "Handle flags in archive" without quotes

find


$metatags .= '
<link rel="stylesheet" type="text/css" href="http://www.vbenterprisetranslator.com/forum/images/vbet/flags/vbet.css"/>';


replace vBulletin Enterprise Translator (vBET) - Powered by vBulletin (http://www.vbenterprisetranslator.com/forum/) with your forum path, the flags not showing because wrong images pathor because the archive folder rewrited too in vbseo, so we are fixing it here


$metatags .= '
<link rel="stylesheet" type="text/css" href="http://www.yourdomain.com/forumfolderifany/images/vbet/flags/vbet.css"/>';



now reload and check again you archive, the flags should be showed in your archives pages too








2. If you use rewrited archive page using vbseo, and the link in translated archive page is wrong link you can fix it too


for example wrong link like this, it will get Page not found error


http://www.domain.com/forum/es/f-2.html

its should be like this, above url are missing a folder name in the bold below, some people using /archive/ ,or /sitemap/ folder name or other folder name


http://www.domain.com/forum/es/archive/f-2.html











to fix this we can use vbseo CRR

go to your vbseocp.php --> Custom Rewrite Rules --> add this line (in the bottom of CRR column) if your archive folder name using /archive/ like this http://www.domain.com/forum/archive/


'f-(\d+).html' => 'f/archive/f-$1.html'



if your archive folder using /sitemap/ folder name like this http://www.domain.com/forum/sitemap/ just change the folder name


'f-(\d+).html' => 'f/sitemap/f-$1.html'




this will do the trick, you can use vbet for vb 3.6 archive pages









3. If you get error message like this in the top of archive page sometime (this is not related or because 2 step above)




use this meto instruction (http://www.vbenterprisetranslator.com/forum/vbet4-bug-reporting/932-warnings-guest-cache.html#post4453), i use it and its works

This does not work on a non vBseo forum

basketmen
11-09-10, 11:49
Can someone modify this so that it can be added in the htaccess file?
maybe i am wrong how to write this in htaccess, but try this or this can be example, add in htaccess below RewriteEngine On



RewriteRule f-(.*).html$ f/archive/f-$1.html



or




RedirectMatch 301 f-(.*)\.html$ http://www.yourdomain.com/f/archive/f-$1.html

vBET
12-09-10, 14:13
@Michael
It isn't finished because you've decided it, it's finished when I solve the problem.
Regards


Please read carefully - as finished is considered discussion about what you paid for (this is what we was writing about in last posts) and I asked you to not write same messages.
Of course as long as you have the issue and want to give some new information you are absolutely free to do it. Just as I wrote:
"Please note that this discussion is considered as finished. Unless you have something new to write, please do not spam."

Please read it whole again if you want to be sure about meaning of this quote:
http://www.vbenterprisetranslator.com/forum/vbet-integration-other-plugins/810-vbet-vbulletin-3-6-a-2.html#post4588

Also if you took impression that you are not allowed to write here, please take my apologies for this misunderstanding. I will keep my attention to be more precise in the future. Sorry again :)

mario06
15-09-10, 07:54
There's a member here that found a workaround for this problem but he uses vBSEO and I don't so it doesn't work for me. I don't understand why you can't provide a fix without accessing my servers, like I said I will not give my server details out.

If this member fixed the coding himself then why aren't you able to do so since you're the coder? Like I said and showed in the above threads that your fix in the first post works but the flags aren't showing (they're invisible) but when you hover over them with your mouse you can see them and click to translate like normal, I'm talking about the archive flags of course.

You tell me not to write the same messages but I MUST considering that I'm still here with no support.

PS. I understand English very well considering that it's my Mother Language.

Regards

basketmen
15-09-10, 08:09
There's a member here that found a workaround for this problem but he uses vBSEO and I don't so it doesn't work for me. I don't understand why you can't provide a fix without accessing my servers, like I said I will not give my server details out.

If this member fixed the coding himself then why aren't you able to do so since you're the coder? Like I said and showed in the above threads that your fix in the first post works but the flags aren't showing (they're invisible) but when you hover over them with your mouse you can see them and click to translate like normal, I'm talking about the archive flags of course.

You tell me not to write the same messages but I MUST considering that I'm still here with no support.

PS. I understand English very well considering that it's my Mother Language.

Regards

i think i just lucky before and its maybe not perfect, also i am sure if i give my ftp details to Michał he can solved it too, i already purchase a integration/installation service $30 before, and its done even its need time, i believe Michał is one of greatest coder that using vbulletin, just try more cooperative with him and give hints that can help

btw i just considering to remove the archive feature in vb after read this thread (http://www.vbseo.com/f34/how-completely-turn-off-vbulletin-archive-24545/) and this post (http://www.vbseo.com/f34/how-completely-turn-off-vbulletin-archive-24545/index2.html#post175320), because they said its enough with sitemap generator

vBET
15-09-10, 15:03
There's a member here that found a workaround for this problem but he uses vBSEO and I don't so it doesn't work for me. I don't understand why you can't provide a fix without accessing my servers, like I said I will not give my server details out.

If this member fixed the coding himself then why aren't you able to do so since you're the coder? Like I said and showed in the above threads that your fix in the first post works but the flags aren't showing (they're invisible) but when you hover over them with your mouse you can see them and click to translate like normal, I'm talking about the archive flags of course.

You tell me not to write the same messages but I MUST considering that I'm still here with no support.

PS. I understand English very well considering that it's my Mother Language.

Regards

You are with no support, because you refused our support. Also vBet 3.x officially supports only vBulletin 3.8 what you know wery well. You are using vBET on not supported vBulletin version - on vBulletin 3.6 which is much older than supported vBulletin 3.8

Questions you gave was already answered - I think that more that once - I do not want to repeat again and again, please just read previous messages.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET 4.9.2