PDA

View Full Version : Solved vBET Serious Bug Found!!



mario06
29-06-10, 09:38
I now understand why my site isn't being indexed correctly in 52x.

With vBet installed it's giving NOT FOUND on all of my archive files, after 6 hours of escluding everything single mod 1 by 1 it came out to this, I've tryed 3.33 and 3.34 and without vBet my archive works fine..



Please give me a fix for this problem!

Best regards

mario06
29-06-10, 11:14
No one from the vbet staff is here? I need a fix!

PS. I didn't have this problem with the free version

Regards

kamilkurczak
29-06-10, 11:39
hmm i can't reproduce this issue. Can you show me how I can do that?

mario06
29-06-10, 13:41
I'm uploading my site wait 5 minutes and i'll link you in pm

mario06
29-06-10, 13:45
I pm'ed you waiting for a response, vbet is turned on and my archive threads give NOT FOUND(404), as soon as you confirm this I'll disable it so that you can browse the archive again so that you can see for yourself that it works without vbet.

regards

mario06
29-06-10, 14:01
kamilkurczak, I've been waiting here for you too confirm the bug and you go offline after 20 minutes without answering me?

That's not the right way to treat paying customers!

mario06
29-06-10, 19:00
I need help where is everyone?

mario06
30-06-10, 05:29
How long do I have to wait?

vBET
30-06-10, 07:42
Sorry you had to wait. I already send Kamil reminder about your issue. Also please note that you do not have to disable whole vBET - it should be enough to disable just vBET plugins for archive (all with 'archive' in hook name). This will allow you to use vBET and work your archive (but not translating archive) until we solve the issue :)

As I saw Kamil was not able to reproduce it on our server and asked you for detailed instructions about it (do we need to do something special to see it or just whole archive is down). If we will not reproduce it on our server, we will need access details to your Admin CP and FTP to be able to check why it happens and correct it.

Also if you have other plugins (not including vBSEO) which are using some archive hooks please try to temporary disable those plugins and check does vBET will work correctly for archives then. It is to check do we have some conflict issues here.

mario06
30-06-10, 09:35
I already tried disabling the vBET archive plugin yesterday but the archive is still broken when vBET is enabled so I must disable vBET to get the archive working.

The problem is simple.

1. vBET On
= Archive broken

2. vBET Off
= Archive working

Like I said above I uninstalled every single plugin (1by1) yesterday and found vBET to be the culprit, after testing I restored a backup.

There's really nothing special to do to in getting the not found (404) error, all you have to the is go to the bottom right of the page and click on Archive and follow trough the threads|posts (even as a guest).

For access I don't have a problem, let's establish a time to do it.

Regards


PS. I had to add archives|sitemap in my robots.txt because google started giving me errors on the archive hitting 17k (404).


PS2. I don't have vBSEO installed maybee vBET is hooking|looking for it.

Regards

kamilkurczak
30-06-10, 15:11
hello,

I need access to your admincp adn ftp.. Please send PM to me with this data.

I will try to find the issue.

mario06
30-06-10, 18:34
You have a PM.
Regards

kamilkurczak
01-07-10, 12:08
I found the plugin with bug.. now I will try to find a solution.

kamilkurczak
01-07-10, 15:09
please, just look to your PM

mario06
01-07-10, 18:36
the account stopped working because of a multipe ip detection, now the account login is working again .. your almost there :)

Regards

vBET
03-07-10, 13:55
OK so - after working on this issue we found that there is no bug in vBET here. It is because your forum uses vBulletin 3.6 and vBET officially supports vB3.8

Anyway we found a way to make it work even on not officially supported vBulletin 3.6: http://www.vbenterprisetranslator.com/forum/vbet-integration-other-plugins/810-vbet-vbulletin-3-6-a.html
Those changes are already done on your forum.

Please note that still translated archive pages for forums are not working. This is because of vBulletin error so ask vBulletin team to solve it. If you add any parameter to forum archive page (this one with f-) then blank page appears. I mean any parameter - even just ?x=y and it crashes even with vBET disabled. So with this case you have to ask vB team to correct their bug and most probably translations will start working (everything is fine for archive main and thread pages).

Because there was no vBET bug here I move thread to troubleshooting section.

mario06
06-07-10, 12:29
Please note that still translated archive pages for forums are not working. This is because of vBulletin error so ask vBulletin team to solve it
They'll told me to uninstall it because everything worked before the vBET mod.


Please note that still translated archive pages for forums are not working?
Didn't you fix it?

What so different about 3.6.12 and 3.85? The major changes are relevant to social networking it seems to me that your comparing vb 3 to vb 4, a little more effort on your part wouldn't have hurt no?

vBET
07-07-10, 13:32
Just as I described to you the bug is in vBulletin. They simply flus you away. Maybe because of wrong issue desription. It is not vBET fault - original archive is working fine. Translation of forum archive pages is not working and it will not work, because vBulletin crasches the page if in URL is addes any parameter. And it is not vBET - you can dissable vBET add to url ?x=y and you will still have crasched achrive forum page.

I already described it before. And gave you a way to check yourself that it is vBulletin bug. Please write them that you do not need to have vBulletin to crasch those pages - it is enought to add any parameter to URL. And it crasches with vBET dissabled. So to not allow them to flush you away again ;)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vB Enterprise Translator 4.9.2