PDA

View Full Version : Solved Goto new post and mark forums read



Snake
26-06-10, 01:17
With vbet enabled if i view a thread and then it gets a new post and then i click goto first unread post the browser always goes to the first post rather than the new post.

Also if i click mark forums read i get a 404 error.

Both features work with vbet disabled.

Snake
26-06-10, 01:20
It does it here too, all the goto first new post links on the forum home goto the first post and never update to show you have viewed the post, they always stay bold.

Mark forums read on the home page redirects to the forum home and marks nothing!

Ramses
26-06-10, 03:04
I watched this issue here on vbet too, on my forum there isn't this issue.

Snake
27-06-10, 20:28
This is a fairly serious bug, it breaks many functions my users need. Is it being looked into? Thanks.

kamilkurczak
28-06-10, 09:47
ok snake, i would try to reproduce this bug

kamilkurczak
28-06-10, 10:38
I can not reproduce the problem, maybe I have an older version of the forum. Please write me what you have the exact version of vBulletin, and I'll try to reproduce it on vB version like your forum.

Please try to find a conflict with other mods. To do this, disable the other mods and leave only vBET. if the error does not occur, switch the turn further mods to see where is the conflict.

steve
28-06-10, 11:39
I can not reproduce the problem

I also can't reproduce the mark forum as read problem, i've only tested on two forums (separate servers). Forums running vb 3.8.x latest vbet and vbseo.

However going to the latest unread post is a problem on both, i've received dozens of complaints. It is also not functioning for me here. When I disable vbet on my forums, the problem disappears.

kamilkurczak
28-06-10, 12:03
ok now it's found on our forum. Goto new post options.

I'll try to find a solution.

steve
30-06-10, 00:00
ok now it's found on our forum. Goto new post options.

I'll try to find a solution.

Hows this going? the new post link isn't working and we have a lot of annoyed members :(

Snake
30-06-10, 00:07
I have to agree, no support, no fix, major bug, sort it out!

Snake
30-06-10, 09:01
WHERE IS SUPPORT, FIX YOUR DAM MOD FFS!

kamilkurczak
30-06-10, 16:34
hello,

We can reproduce this bug on our forum and it will be solved in the next relase..
If it will be easy, We will give you a quick-fix

Snake
30-06-10, 17:30
Frankly it isnt good enough, its a major function, and it is causing my members to really complain, so i will just complain to you.

You should have fixed this days, even weeks ago, you have to release a bug patch. Soon. It's what any other paid mod would do.

:mad:

kamilkurczak
30-06-10, 17:40
We will try to fix the bug as soon as possible.

steve
30-06-10, 23:26
Frankly it isnt good enough, its a major function, and it is causing my members to really complain, so i will just complain to you.


I'm now getting about 50-60 emails per day regarding this problem, a fix will be good. It worked fine before this release.

steve
01-07-10, 11:41
I'm now getting about 50-60 emails per day regarding this problem, a fix will be good. It worked fine before this release.

Is this being worked on? Can I please have an eta?

kamilkurczak
01-07-10, 12:43
I found some reason for this issue. is caused by a plugin in global_start.
If I turn off this plugin, this option works good.

maybe the order of plugins?

I work on it. Please be patient

steve
01-07-10, 23:24
I found some reason for this issue. is caused by a plugin in global_start.
If I turn off this plugin, this option works good.


I don't have any idea what that means.

kamilkurczak
01-07-10, 23:43
I wrote that we found a plugin, which is the issue. We're working on.

steve
04-07-10, 08:59
How is the fix for this issue progressing?

kamilkurczak
04-07-10, 14:36
We know where exacly is bug. We found it in vbet_global_start function in vBET php file.

probably, we pass a bad url to the vBulletin function (exec_header_redirect).

Michał is working on this.

steve
05-07-10, 07:53
No problem, we really need a fix for this problem asap

vBET
05-07-10, 08:33
Done :) Sorry you had to wait. Solution will be included in next release. We are already using it on our forum, so new post redirection is working fine here.

For quick fix please:
1. Edit includes/vbenterprisetranlator_functions_hooks.php
2. Find:

if (THIS_SCRIPT == 'showthread' && 'VBSEO_URI' == $vbulletin->options['vbenterprisetranslator_linkstype'] && $_GET['t']) {
3. Replace by:

if (THIS_SCRIPT == 'showthread' && 'VBSEO_URI' == $vbulletin->options['vbenterprisetranslator_linkstype'] && $_GET['t'] && $_REQUEST['goto'] != 'newpost') {

vBET
05-07-10, 08:38
I see in title that you described 2 issues in one thread. But Kamil confirmed only one of those. Please tell exactly how you mark forum read. I just cannot find such option - probably looking in wrong place ;)

Snake
05-07-10, 19:10
I see in title that you described 2 issues in one thread. But Kamil confirmed only one of those. Please tell exactly how you mark forum read. I just cannot find such option - probably looking in wrong place ;)

Its on the homepage, underneath the forums and if you double click the icon on the left of each forum description.

kamilkurczak
05-07-10, 20:35
I checked it on our test forum and I do not have this bug
404 error. Everything is working properly.

So, please send to Michał (vbet) full access to your admincp and FTP by PM. He will try to find a solution and fix it!

Thanks:)

kamilkurczak
09-08-10, 12:37
I still waiting for answer. no answer - I assume that is ok.
If not ok, please write here and I will open this thread again

Snake
12-08-10, 00:36
This issue still exists, in forumdisplay (http://www.computer-juice.com/forums/f10/), if i click the arrow to goto new post for a thread, it always takes me to the first post, not the first unread post.

Register on my forum and you will see it.

If i disable vbet, the issue goes away.

http://www.computer-juice.com/error.gif

Snake
12-08-10, 01:04
Upgraded to 3.3.5 and all urls issues seem fixed, so no problem, thanks.

kamilkurczak
12-08-10, 13:22
ok :)
thanks for confirmation

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vBET Translator PRODUCER_PRODUCT_VERSION