View Full Version : Solved Upgrade error

22-06-10, 16:45
/home/www/doc/*****/mysite/www/forum/global.php(238) : eval()'d code on line 3
Get this after upgrading from 333 to 334, uploaded all files and imported product (checked overwrite existing product).
Any hints?

22-06-10, 16:49
Please give your exact vB version and content of global.php file around line 238 (and point which one is 238).

22-06-10, 16:54
VB version is 3.84 global.php is:

// if user can control panel, allow selection of any style (for testing purposes)
// otherwise only allow styles that are user-selectable
$styleid = intval($styleid);
$style = NULL;

($hook = vBulletinHook::fetch_hook('style_fetch')) ? eval($hook) : false;

if (!is_array($style))
$style = $db->query_first_slave("
FROM " . TABLE_PREFIX . "style
WHERE (styleid = $styleid" . iif(!($vbulletin->userinfo['permissions']['adminpermissions'] & $vbulletin->bf_ugp_adminpermissions['cancontrolpanel']) AND !$userselect, ' AND userselect = 1') . ")
OR styleid = " . $vbulletin->options['styleid'] . "
ORDER BY styleid " . iif($styleid > $vbulletin->options['styleid'], 'DESC', 'ASC') . "
define('STYLEID', $style['styleid']);

I'm not sure if dreamweaver is showing the correct line so I added the complete code arround this, 238 is
($hook = vBulletinHook::fetch_hook('style_fetch')) ? eval($hook) : false;

22-06-10, 17:04
Please turn off vBET plugin for style_fetch hook and check does it's working now. If not, then please turn off other plugins for style_fetch hooks one by one (can turn on previous) and check when it will start to work. When you find the one which is guilty - please tell us which one it is.

22-06-10, 19:21
Thanks, disabling vbet style_fetch solves this error, but now there aren't flags showing only the placeholders.
Sorry, I saw where I made the mistake, I come back in a second.
Alright, I'm very sorry to made you unnecessary work I simply uploaded the folders in a wrong directory. All is now fine.

22-06-10, 22:14
Now it works well but a vBET functionality is disabled. This may not be so.
This functionality has been disabled in order to analyze what is wrong.

Please write now if it works when the plugin is enabled?

If it does not work is an issue and we need to fix in order to use all the functionality.

22-06-10, 23:15
As I said in my previous post it was my fault, I uploaded the vbet folders to root instead forum directory. It is all fine.

22-06-10, 23:30
OK so - just to be sure. Now you are running with all our plugins turned on - true? :) Because if it is fine with some disabled, then not all vBET parts will work appropriately (I asked to disable only to determine the cause). We understand that you made folder mistake, but you also wrote that you disabled the hook which I described and now we are not sure did you enabled it again.

So for your client good (your good) we want to be sure that you do not loose anything and you are running vBET with all plugins turned on. Please confirm so we will be able to sleep well ;)

22-06-10, 23:41
Yes Michal, all plugins are enabled. Even the guest cache is on now, I hope this will show effects in lowering the server load soon. Thanks for your great support.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.99