PDA

View Full Version : Solved Thanks for vbet but i notice some strange problem with cmps_index page



symbianist
15-06-10, 14:28
Thanks for vbet but i notice some strange problem with cmps_index page.
I have my cmps_index.php pag renamed to bindex.php. But when i am trying to click the trnalstor for example arabic, it is showing a cut link like


www.mywebsite.com/ar/b
which is supposedly to be


www.mywebsite.com/ar/bindex.php

And it is same for all translation. what shall i do to fix this error. thanks in advance.

vBET
15-06-10, 17:35
vBET cuts index.php from URL - that is why you have this issue. For quick fix please:
1. Edit file /includes/vbenterprisetranslator_functions_url.php
2. Find:


if (false !== strpos($address, 'index.php') && false === strpos($address, '/archive/')) {
$address = str_replace('index.php','',$address);
}

2. Replace by:


if (false !== strpos($address, '/index.php') && false === strpos($address, '/archive/')) {
$address = str_replace('/index.php','/',$address);
}


Please confirm does it help. We will include it in next release so you will be calm about it during updates :)

symbianist
16-06-10, 10:25
I am wrong. It is the original index.php renamed to bindex.php and my cmps_index.php to be index.php.
My translator in index.php (originally cmps_index.php) seems working fine, but the bindex.php(originally index.php) not working.

And i cannot find this codes in /includes/vbenterprisetranslator_functions_url.php


if (false !== strpos($address, 'index.php') && false === strpos($address, '/archive/')) {
$address = str_replace('index.php','',$address);
}

This is what i have in /includes/vbenterprisetranslator_functions_url.php

if ($index = strpos($address, 'index.php')) {
$address = str_replace('index.php','',$address);
}


Please reply asap.

vBET
16-06-10, 20:08
OK - this code which you found is the one. I gave you code from version not released yet. But do not use it - because the issue is something else that you described in first place.

About real issue. First - make sure it is not done by some vBSEO settings (like custom rewrite or something).

When you will be sure that it is not vBSEO, then please PM your forum URL and access details for Admin CP, vBSEO CP and FTP - we will have to check it on place.

vBET
05-07-10, 07:41
Because it went to PM - to confirm can issue be closed?

vBET
07-08-10, 11:56
No confirmation - closing issue. In case if it is still active please respond here and it will be reopened.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 gives automatic translations