PDA

View Full Version : Solved Not translating from anything but English?



widotcom
04-06-10, 16:35
Works great translating English to anything else... However, if I navigate to /forum/es/********** and then post in spanish, it doesn't convert the post back to English (or any other language).

I've set:

Show original text for user : Added by Javascript

and also tried the other options, but none seem to work. I'm sure it's something silly I'm doing....

Also, I'm not seeing translated URLs, but I'm okay with that for now. (using vBSEO)

kamilkurczak
04-06-10, 22:16
hello,

firstly (about your second issue) - Links that have been translated, you need to change two files:
1. FORUM_ROOT/includes/functions_vbseo_createurl.php
2. FORUM_ROOT/includes/functions_vbseo_url.php
the full instruction you have in do-not-upload folder (readme) - Part of the vBSEO integration (Integration with other mods)

Now about the main issue (translating): go to->admincp-> vBET-> google
I suggest setting the trust google When trust worthy in the Google Language Detection
You can set the level of confidence - I propose to set 0.1 (10%) in the Google Language Detection Confidence
By default if it is 0.1 - so if Google is at least 10% sure about the message language then vBET will mark new message by lang bbcode automatically. If Google will not be sure enough - message stays as it is and admin can update it manually if it is necessary.

required, you need to manually edit existing posts. You must put the existing text in [lang=] tags.
everything is described here: http://www.vbenterprisetranslator.com/forum/vbet4-general-discussions/409-how-does-works-manual-about-multi-language-support.html

widotcom
05-06-10, 00:03
Translating issue : I get it, if I want to post in spanish, I can be on any language, including default, but must put a [ lang = es] BBCODE around my post then, correct? And then the system will auto-translate to whatever language (once I add the lang BBCODE)?

ETA: Missed one step on the vbSEO instructions... it all works now.. THANK YOU******

One minor thing and am wondering if this is okay.. looking at a thread now.. Title is:

Realmente bueno nueva característica .

the URL includes the accented i ... is that okay in google etc?

realmente-bueno-nueva-caracter%C3%ADstica-628861/

kamilkurczak
07-06-10, 15:25
hello,

it is not ok (caracter%C3%ADstica)

Pleae make sure that you made all necessary configurations of vBulletin (and vBSEO if you have) described in readme.html in installation package. If you didn't then you can have issues with some languages characters.

translating problem: if you set "Trust Google when result is trust worthy" new posts will be automatically put in lang bbcode, but you must pack up the old posts in this tag.
If you write in forum native language this text will not be packed in a tag.

kamilkurczak
10-06-10, 09:35
oh, I'm sorry..

This is not a issue. Try to check this link in another browser (Opera, Firefox),
should be translated correctly.
This is a browser issue. google crawls this link correctly (with the the letter).

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Integration with Google translations by vB Enterprise Translator 4.9.2