PDA

View Full Version : Solved content inside code php bbcodes should not be translated



magmf
30-05-10, 17:57
Guys,

I have some problems with content inside bbcodes php and code

same examples



<?
$diary_directory = opendir(".");
while($filename = readdir($diary_directory))
{
$filesplit = explode(".", $filename);
$check_filename = $filesplit[0];
if(ereg("[0-9]{6}", $check_filename))
{
$check_filename .= ".$filesplit[1]";
$valid_filename[] = $check_filename;
}
}
closedir($diary_directory);
for($index = 0; $index < count($valid_filename); $index++)
{
print("$valid_filename[$index]<br>");
}
?>






<?
$diary_directory = opendir(".");
while($filename = readdir($diary_directory))
{
$filesplit = explode(".", $filename);
$check_filename = $filesplit[0];
if(ereg("[0-9]{6}", $check_filename))
{
$check_filename .= ".$filesplit[1]";
$valid_filename[] = $check_filename;
}
}
closedir($diary_directory);
for($index = 0; $index < count($valid_filename); $index++)
{
print("$valid_filename[$index]<br>");
}
$diary_directory = opendir(".");
while($filename = readdir($diary_directory))
{
$filesplit = explode(".", $filename);
$check_filename = $filesplit[0];
if(ereg("[0-9]{6}", $check_filename))
{
$check_filename .= ".$filesplit[1]";
$valid_filename[] = $check_filename;
}
}
closedir($diary_directory);
for($index = 0; $index < count($valid_filename); $index++)
{
print("$valid_filename[$index]<br>");
}
$diary_directory = opendir(".");
while($filename = readdir($diary_directory))
{
$filesplit = explode(".", $filename);
$check_filename = $filesplit[0];
if(ereg("[0-9]{6}", $check_filename))
{
$check_filename .= ".$filesplit[1]";
$valid_filename[] = $check_filename;
}
}
closedir($diary_directory);
for($index = 0; $index < count($valid_filename); $index++)
{
print("$valid_filename[$index]<br>");
}
$diary_directory = opendir(".");
while($filename = readdir($diary_directory))
{
$filesplit = explode(".", $filename);
$check_filename = $filesplit[0];
if(ereg("[0-9]{6}", $check_filename))
{
$check_filename .= ".$filesplit[1]";
$valid_filename[] = $check_filename;
}
}
closedir($diary_directory);
for($index = 0; $index < count($valid_filename); $index++)
{
print("$valid_filename[$index]<br>");
}
?>


in native language is working perfectly but in other languages is crashing and translating this content that should not be translated.

magmf
30-05-10, 17:58
stange this bug should be only happening on vbulletin 4 because here is not happening. anyone can help me ?

magmf
30-05-10, 18:07
just confirmed

native language teste do vbet (http://under-linux.org/f106/teste-do-vbet-138632/)

spanish Prueba Vbeta (http://under-linux.org/es/f106/teste-do-vbet-138632/)


so looks like this is happening only on vb4 versions

kamilkurczak
31-05-10, 14:54
what about your settings in admincp?

which option you have set id vBET-> google -> Google Language Detection?

magmf
31-05-10, 17:29
Always trust user

magmf
31-05-10, 17:33
but what google language detection has with content inside bbcode php and code ?

Keep in mind here on vbet 3.3.3 and vbulletin 3.8.5 is working fine but not in my website as you saw in links above

kamilkurczak
31-05-10, 18:59
so, try to set Trust "Google when result is trust worthy" and "Google Language Detection Confidence" level on 0.1.

and see what happens. If it's not we will try to find a solution.

magmf
31-05-10, 19:03
nothing changed for me :(

magmf
31-05-10, 19:03
dont you a lab to test this problem ?

kamilkurczak
31-05-10, 19:26
Ok, We will try to reproduce the problem

magmf
31-05-10, 21:05
any news for me ?

kamilkurczak
01-06-10, 14:24
I can not reproduce the problem, maybe I have an older version of the forum. Please write me what you have the exact version of vBulletin, and I'll try to reproduce it on vB version like your forum.

Please try to find a conflict with other mods. To do this, disable the other mods and leave only vBET. if the error does not occur, switch the turn further mods to see where is the conflict.

magmf
01-06-10, 15:29
vbulletin 4.0.3

kamilkurczak
02-06-10, 13:08
we can't reproduce this problem on our forum, but this problem is probably caused by removal of comments by a plugin (vBET uses comments NTA - not tranlated area - to describe the field without translation).

Try to turn off this plugin (removing of comments).

If you don't know whitch is a plugin, please try to find a conflict with other mods. To do this, disable the other mods and leave only vBET. if the error does not occur, switch the turn further mods to see where is the conflict.

magmf
02-06-10, 13:37
you are right... just confirmed that disabling this vbseo feature thanks :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vB Enterprise Translator 4.9.99