PDA

View Full Version : vBA CMPS



vBET
08-05-10, 21:13
If vBA CMPS generates your portal main page and you forum is in subdirectory you can integrate it just like it is described here: http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post54

Still you can have issue with flags, to solve it you have to:
1. Copy images from vBET package to your portal main directory
2. Edit file /includes/vba_cmps_include_top.php
3. Find:

eval('$navbar = "' . fetch_template('navbar') . '";');
4. Put BEFORE:


global $vbenterprisetranslatorflags;
global $vbenterprisetranslatorflagsdropdown;


Without this vBA CMPS will not see vBET flags variables because navbar is evaluated inside of a function.

Ramses
09-05-10, 10:56
Thanks Michal, works fine now.

vBET
09-05-10, 19:42
No problem :) vBA CMPS supports hooks - unfortunately in this place hook is after navbar is evaluated and all hooks before we found are inside of some if statements. So we are not able to write simple plugin which would add this automatically without any file edition. If we miss something in hooks there - let us know and we will check it again, and maybe it will be possible to give solution without file changes. At this moment please just made this simple change :)

tsak76
03-07-10, 23:53
If vBA CMPS generates your portal main page and you forum is in subdirectory you can integrate it just like it is described here: http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post54

Still you can have issue with flags, to solve it you have to:
1. Copy images from vBET package to your portal main directory
2. Edit file /includes/vba_cmps_include_top.php
3. Find:

eval('$navbar = "' . fetch_template('navbar') . '";');
4. Put BEFORE:


global $vbenterprisetranslatorflags;
global $vbenterprisetranslatorflagsdropdown;


Without this vBA CMPS will not see vBET flags variables because navbar is evaluated inside of a function.

http://www.vbenterprisetranslator.com/forum/54-post13.html

i couldnt make this to work for cmps. the flags show but the translation goes to page not found

i have vbadvnaced index.php in root and my forum is in /forums/

vBET
05-07-10, 07:06
http://www.vbenterprisetranslator.com/forum/54-post13.html

i couldnt make this to work for cmps. the flags show but the translation goes to page not found

i have vbadvnaced index.php in root and my forum is in /forums/

As I understand you fallowed instructions for integrate pages outside forum directory. Please show me your whole .htaccess file from your main directory (NOT from forum).

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations made by vBET 4.9.99