PDA

View Full Version : Solved Huge amount of Redirect Errors From Vbet



hotslot
01-05-10, 07:45
Crawl errors
Issues Google encountered when crawling your site.

All are from vbet language pages and has something to do with the tags.

http://www.example.com/af/tags/etcetc
http://www.example.com/ro/tags/etcetc

HELP

vBET
01-05-10, 12:23
All are from vbet language pages and has something to do with the tags.

http://www.example.com/af/tags/etcetc
http://www.example.com/ro/tags/etcetc

HELP

Please check does such link exist in original form - not translated. Maybe the tag was just deleted, so link doesn't exist anymore and we are talking about history...

Please give me real link which is broken.

hotslot
01-05-10, 16:51
I have sent You some photos.. The original form is still there.

vBET
01-05-10, 18:06
I have sent You some photos.. The original form is still there.

OK - going there.

vBET
01-05-10, 18:15
OK - this is vBET fault. I found one bug - it is already corrected and will be included in next release. You have quick fix below - please do it and confirm does it solve your issue.

Quick fix:
EDITED - please see new quick fix below.

hotslot
01-05-10, 18:48
Takes a man to admit fault. Thank You vBET for your help and attention in this matter. Your truly a good man.

Now regarding vbenterprisetranslator_seo.php

I cannot find this anywhere. Can You help please

vBET
01-05-10, 21:48
You will find it in your forum directory.

Also - I was still investigate this and I found that it has 2 causes. 1 - lack of '?' for parameters; 2 - % in URL. I made new solution which makes sure that '?' will be there if parameters are in URL and will handle % appropriately.

So for better quick fix please do this:
1. Edit file: vbenterprisetranslator_seo.php
2. Find:


$_SERVER['QUERY_STRING'] = str_replace('vbet_lang='.$_REQUEST['language'].'&redirected='.$_GET['redirected'], '', $_SERVER['QUERY_STRING']);
$queryString = &$_SERVER['QUERY_STRING'];
if ($addQueryString && $queryString) {
if ($queryString[0] == '&') {
$queryString[0] = '?';
}
$_SERVER['REQUEST_URI'] .= $queryString;
}

3. REPLACE BY:


if ($addQueryString) {
$index = strpos($_SERVER['QUERY_STRING'], '?');
if ($index) {
$_SERVER['QUERY_STRING'] = substr($_SERVER['QUERY_STRING'], $index);
$_SERVER['REQUEST_URI'] .= $queryString;
} else {
$_SERVER['QUERY_STRING'] = '';
}
}

hotslot
01-05-10, 23:57
This is only for that one tag.. Why did it error out for this particular one? Or is this a global thing and simply has not caught up to webmasters tools section yet>?

vBET
02-05-10, 00:55
This is only for that one tag.. Why did it error out for this particular one? Or is this a global thing and simply has not caught up to webmasters tools section yet>?

This one had % notation inside ant it appears that vBSEO didn't recognize it so made redirect (there was one vBET bug which is corrected in quick fix). Redirect which included vBET parameters from .htaccess rules, which normally are cut - but we had bug in cutting those (also corrected in quick fix).

hotslot
02-05-10, 19:27
Is this in the vbulliten admin area? I have no idea where the forum directory is. Remember im not a tech or computer wizard. Will You do this for me?

vBET
02-05-10, 22:28
You have to go to your forum directory structure by FTP and you will find it there :) According to your forum URL most probably you find the file in FTP main directory or public_html subdirectory (if such exists there).

This is simple copy, paste task and do not require any technical knowledge.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations delivered by vBET 4.9.2