PDA

View Full Version : Solved Installation problem



x00x
31-03-10, 22:37
HI have to install it the problem. Habs vBSEO and somehow things do not get along together Can someone help me there?

vBET
01-04-10, 12:19
Please first go to vBSEO integration section in readme.html file - you must edit 2 vBSEo files (all clearly described). Then do the rest of installation.

Let us know if you have any future issues with that.

x00x
01-04-10, 17:13
Well, there have now managed and managed the integration with vBulletin. Have only one small problem with the SEO URLs. In the settings I've set the following: Link Type: VBSEO_URI Create URL's SEO link according to consensus (ie '/ en / address') Forum Directory: / forum Nevertheless, it does not work wm-apps.de/forum Url is asking for help thank you:)

x00x
01-04-10, 17:20
I did that. Htaccess changed and now the translation as that! Can also be used for statistics at the top? If so, how this is handled? Please help, thank you:)

x00x
01-04-10, 21:01
Unless it works quite well with the translation. But if I English in a German forum post by writing this is unfortunately not translated but are shown in the original version. If I switch to english as the language and want to make a contribution can not be drawn because these are automatically bound to the root directory /. The Forum lies in / BB forum in the settings I changed the what have I set incorrectly? Maybe something needs to be changed even in htaxx?

vBET
02-04-10, 03:09
I did that. Htaccess changed and now the translation as that! Can also be used for statistics at the top? If so, how this is handled? Please help, thank you:)

Which statistics are you writing about? :)

vBET
02-04-10, 03:12
Unless it works quite well with the translation. But if I English in a German forum post by writing this is unfortunately not translated but are shown in the original version. If I switch to english as the language and want to make a contribution can not be drawn because these are automatically bound to the root directory /. The Forum lies in / BB forum in the settings I changed the what have I set incorrectly? Maybe something needs to be changed even in htaxx?

If message is written in other language it have to be marked by BBCode. Such bbcode will be automatically added for user who set his default language. Also you can turn on automatic language detection - then Google will be asked about language of message.
About your issue with creation of posts on translated view: which version of vBET are you using? what is your .htaccess content? does message is created or just redirection happens? Did you set your forum directory in vBET main settings?

x00x
02-04-10, 10:46
This seems to be working now with the translation. But when I select a different language, then no images, facilities, etc. displayed and no threads are created. Forum is in the / forum vBSEO Did it and vBET331 htaxx is:



# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

vBET
02-04-10, 21:16
This seems to be working now with the translation. But when I select a different language, then no images, facilities, etc. displayed and no threads are created. Forum is in the / forum vBSEO Did it and vBET331 htaxx is:

You set wrong .htaccess rules :) It is clearly described that in case if your forum uses subdirectory in URL you have to modify first 2 rules. Please check this one:


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Multilingual forum supported by vBET Translator 4.9.2