PDA

View Full Version : Solved vBSEO Sitemap does not work anymore



Kolbi
15-03-10, 20:36
Since installing 4.2.0 vBET is no longer the vBSEO Sitemap. The following error message occurs when you run:

[SECTION START] showthread [8,258.2Kb mem used] [66,382s (+66,382s)]

Fatal error: Call to undefined function vbet_vbseo_filter_replace_text() in .../htdocs/vbseo/includes/functions_vbseo_createurl.php on line 43

vBET
16-03-10, 22:55
Thanks for note - we miss this issue, because sitemap integration is our next step. Very draft solution - please open sitemap file which generates this error message and add there this code:


require_once(DIR. '/includes/vbenterprisetranslator_functions_vbseo.php');


Add it AFTER:


define('DIR', dirname(__FILE__).'/../');


Please let us know did it help

Kolbi
17-03-10, 12:41
I've tried to edit the vbseo_sitemap.php:

<?php
require_once(DIR. '/includes/vbenterprisetranslator_functions_vbseo.php');
/******************************************************************************************
* vBSEO Google/Yahoo Sitemap Generator for vBulletin v3.x.x by Crawlability, Inc. *
*****************************************************************************************-*
* *
* Copyright &#169; 2005-2009, Crawlability, Inc. All rights reserved. *
* You may not redistribute this file or its derivatives without written permission. *
* *
* Sales Email: sales@crawlability.com *
* *
*************************************-LICENSE AGREEMENT********************************---*
* 1. You are free to download and install this plugin on any vBulletin forum for which *
* you hold a valid vB license. *
* 2. You ARE NOT allowed to REMOVE or MODIFY the copyright text within the .php files *
* themselves. *
* 3. You ARE NOT allowed to DISTRIBUTE the contents of any of the included files. *
* 4. You ARE NOT allowed to COPY ANY PARTS of the code and/or use it for distribution. *
******************************************************************************************/

error_reporting(E_ALL & ~E_NOTICE);
Then I got the following error message:

Warning: require_once(DIR/includes/vbenterprisetranslator_functions_vbseo.php) [function.require-once (http://www.2-wheel-planet.de/)]: failed to open stream: No such file or directory in /htdocs/vbseo_sitemap/vbseo_sitemap.php on line 2

Fatal error: require_once() [function.require (http://www.2-wheel-planet.de/)]: Failed opening required 'DIR/includes/vbenterprisetranslator_functions_vbseo.php' (include_path='.:/opt/RZphp5/includes') in /htdocs/vbseo_sitemap/vbseo_sitemap.php on line 2

vBET
17-03-10, 17:25
Put it AFTER:


define('DIR', dirname(__FILE__).'/../');


In place where you added it there is no DIR defined yet. I know I ask you to add it at the beginning - sorry for confusion ;)

Kolbi
17-03-10, 18:13
I have now corrected as follows:

if(!defined('DIR'))
define('DIR', dirname(__FILE__).'/../');
require_once(DIR. '/includes/vbenterprisetranslator_functions_vbseo.php');

if (!is_object($vbulletin->db)&&!is_object($db)&&!is_object($DB_site))

And now works in the Sitemap again.

Thank you.


It may be that you have your voice BB-Code is used?

vBET
17-03-10, 18:47
We will work on full sitemap integration and we will see :)

Kolbi
17-03-10, 19:20
Had I prescribed above and that I meant if you do not use a BB-code language? :) Okay!

vBET
17-03-10, 19:25
At this moment it should translate it to forum language - we are before integration yet, so I cannot give you more precise answer.

Kolbi
18-03-10, 21:25
The site map is created, but, according to Webmaster Tools, this is still not working. Have got the following error message:


General HTTP error: 404 not found
In the attempt on your Sitemap access, an error has occurred. Make sure that your Sitemap follows our policies, and that the access will be at the specified Position is possible. Rich then the data again. HTTP error: 404
Problem detected on: 18.03.2010
https://www.google.com/webmasters/tools/images/error.png 9 Missing XML Tag
This required Tag is missing. Add it and send the data again. Parent Tag: sitemapindex
Day: sitemap
Problem detected on: 13.03.2010

vBET
19-03-10, 00:05
This message is not about issue with generating sitemap but about access to sitemap. Please make sure that your .htaccess rule for sitemap is ok and make sure that it is BEFORE vBET rules :)

Also I just added official integration instruction for vBET and vBSEO Sitemap Generator:
http://www.vbenterprisetranslator.com/forum/vbet4-integration-other-plugins/415-sitemap-generator-integration.html

vBET
19-03-10, 01:06
About your access issue once again:
1. Make sure that your sitemap rule is before vBET ruels
2. Make sure that your sitemap rule is finishing one (has L in []), example:


RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L,R=301]

On one of our forums which uses subdirectory in URL we modified rule adding forum directory at the beginning (because of dump redirects):


RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ /forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L,R=301]


If you still have issue please let us know :)

badawidollah
27-03-10, 16:16
Thanks for note - we miss this issue, because sitemap integration is our next step. Very draft solution - please open sitemap file which generates this error message and add there this code:


require_once(DIR. '/includes/vbenterprisetranslator_functions_vbseo.php');


Add it AFTER:


define('DIR', dirname(__FILE__).'/../');


Please let us know did it help

yeah
working
:D

vBET
27-03-10, 16:19
yeah
working
:D

Please note - this is old one and not appropriate now (that was only quick fix). For actual integration instructions please go to integration section :)

badawidollah
28-03-10, 06:40
Please note - this is old one and not appropriate now (that was only quick fix). For actual integration instructions please go to integration section :)
are important now 1. sitemap generator is already running 2. vBSEO is running 3. multiple languages is running short one. vbadvanced software can not run perfectly due vbadvance auto disable modules in index.php

vBET
28-03-10, 22:05
are important now 1. sitemap generator is already running 2. vBSEO is running 3. multiple languages is running short one. vbadvanced software can not run perfectly due vbadvance auto disable modules in index.php

It is great that you configure your vBET and sitemap :) If you have issues please create separate threads for each one and do not spam about same issue in many places :) We see your vbadvance issue in other thread - please stay with this issue there. It has nothing common with issue in this topic which is already solved :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.2