PDA

View Full Version : Solved server that falls



Valdo
08-03-10, 10:45
since I've installed the translator I have another problem: whenever I'm part of the planned operation of cleaning the Daily 0:10, I drop the server. Last night I even stalled for 8 hours, so now I had to disable this to avoid that happening again. How can I fix? Thanks

vBET
08-03-10, 16:22
Does it still happens when you disabled scheduled task "vB Enterprise Translator (Cache TTL)". How big are your cache tables? When server fall happens do you have any errors in log files? Did you try to use vBET parameter "Cache clearing timelap"? What clearing strategy are you using right now?

Valdo
08-03-10, 18:30
If I'm not mistaken there are several cache tables, one for each language. The total of all the database backups that I made on March 2 was 877 mb. If we make an average of cache tables, will be 5 mb each, ranging from a maximum of 14 mb of Chinese and Japanese, for a minimum of 2 MB for the Thai. The script that removes the old translations leaves at 3.30. Looking at the options vbet old translations should be removed every 15 days, the options are set as you put you at installation. If you mean by timelap parameter, cache clearing strategy, this deletion is set to Normal.

vBET
09-03-10, 03:44
You didn't answer most important information - does it still crashes when scheduled task is disabled? First we need to determine does vBET is real issue here.

In normal deletion old cache is deleted daily. If you want fastest way of deletion - use last strategy - this one will remove whole cache once per 15 days. It works immediate and use practically 0 server resources. But you have to fill whole cache again, not just old one.

Did you tried to use "Cache clearing timelap" option?

Valdo
09-03-10, 07:49
the server crashed again tonight: I disabled the cleaning of 0:10 but fell at 3:30 when he left BB Enterprise Translator (Cache TTL)

Valdo
09-03-10, 10:28
I looked, the value to which you refer is set to 1. To be precise, is this:

Cache clearing timelap
How many seconds to wait between clearing cache tables. Set 0 to disable. Please note that vBET has over 150 cache tables to clear - setting this value too high may cause that clearing which starts at night will continue even in day hours. Also please do not set it higher that your MySQL connection is waiting without usage (mysql setting: wait_timeout) - otherwise it will cause 'MySQL server has gone away error' and clearing will not be finished.

vBET
10-03-10, 16:26
the server crashed again tonight: I disabled the cleaning of 0:10 but fell at 3:30 when he left BB Enterprise Translator (Cache TTL)

Sorry - I don't get one thing - you have clearing twice a day? Please disable clearing task and tell does your server will crash when clearing is disabled (no matter at which hour - disable it completely). If server will not crash when cache clearing is disabled then it means that vBET is guilty. If still crasches then something else causes this.

If vBET is guilty then you have several options to tune it up:
- set bigger value to "Cache clearing timelap" - this will give time and more CPU for other threads between clearing each cache table. I suggest to do this in first place
- Set lower "Cache Time To Live (TTL)" - then your tables will be smaller so clearing will be less expensive.
- Play with "Cache clearing strategy" - the last one will solve your issue in 100% - it is designed for very large cache and will clear even huge cache immediately, because it just removes whole cache tables and creates it again. But it clears whole cache once per Cache TTL period, so cache have to be filled from beginning. This is last thing I advise to use, so if nothing else is working this will in 100%. It is added just for such situations :)

Valdo
18-03-10, 15:58
We tried the first solution you have proposed, setting the value to 3. The host said that there was a decrease of the load, but going forward in the day is increased. Decreasing the duration, in days, the cache, the problem could be solved? The server is under load, or by clearing the cache of the translations have not yet saved in the cache?

vBET
19-03-10, 03:15
OK so next steps which can help you:
1. Increase cache TTL - less data will be cleared each time
2. Change clearing strategy to: "Quick local deletion with optimize tables" - please note that this option can be worst if your cache is not big enough. For big caches it is better that normal.
3. EXPERIMENTAL: you can choose "Quick local deletion with optimize tables" and edit file /includes/vbenterprisetranslator_functions.php by comment 3 lines of code which includes OPTIMIZE LOCAL TABLE. With this modification it will remove only old data in very fast way, but your indexes will not be rebuild and will grow, so you will have to execute commented query manually once a while. If it will work for you then we can implement it as one of supported strategy - where is fast cleaning without indexes rebuild and rebuild itself can be made by other task running i.e. one a week. So if you tell us that it is working for you we will add it especially for you :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Multilingual forum supported by vBET Translator 4.9.99