PDA

View Full Version : Solved Long posts and error vbet_containsSeparated



dong
17-05-17, 23:30
Information from Users: Here we put forward the errors on the forum - Page 236 (Http://www.forum.alfaholicy.org/sprawy_organizacyjne/19274-tu_zglaszamy_bledy_na_forum-post1977959.html#post1977959) with longer fastings appear error:

Catchable fatal error: Argument 3 passed to vbet_containsSeparated() must be an instance of int, integer given, called in /usr/local/www/apache24/data/forum.alfaholicy.org/includes/vbenterprisetranslator_functions_detection.php on line 158 and defined in /usr/local/www/apache24/data/forum.alfaholicy.org/includes/vbenterprisetranslator_functions_detection.php on line 173

In file vbenterprisetranslator_functions_detection.php marked as a comment the following lines:

//if(vbet_containsSeparated($message, $ignoredLen, $index)) {^M
//$message = substr_replace($message, '<!--vBET_SNTA-->'.$ignored.'' $index, $ignoredLen);^M //$index += VBET_NOTRANSLATE_LENGTH;^M //}^M


The solution helped but I do not know whether or not oznaczylem comments something important?

Marcin Kalak
18-05-17, 15:44
You zakomentowałeś wrapping words/phrases from incoming messages in notranslate bbcode. If your file vbenterprisetranslator_functions_detection.php is surely the current? This function should be as follows:


if(vbet_containsSeparated($message,$ignoredLen, $index)) {
$message = substr_replace($message, '<!--vBET_SNTA-->'.$ignored.'' $index, $ignoredLen); $index += VBET_NOTRANSLATE_LENGTH; }

You can try to download the latest vBET and update the file (i see that you are using the latest version). If you do not ignore words/operative part in AdminCP->vBET->Translation Options->Ignored words/sentences It then this feature is not theoretically you need.

dong
18-05-17, 16:38
Unfortunately I use noise words. Because instead of Alfa Romeo explains me Alpha Romeo. How to do that was ok? Before purchasing and installing the latest version (few days ago) I used the free version. Perhaps because such flowers?

Marcin Kalak
18-05-17, 19:55
The best download again the latest version vBET and all the files from a folder upload overwriting them on the server .

Marcin Kalak
22-05-17, 18:36
To resolve this issue you must: 1), open the file: includes/vbenterprisetranslator_functions_detection.php
2) Find the line:
function vbet_containsSeparated($text, $ignoredLen, int $index) {
3) Replace the:
function vbet_containsSeparated($text, $ignoredLen, $index) {
This change will be implemented in the next release vBET. Please note that to wrappers old words in the tag <!--vBET_SNTA--> Use the option [notranslate]AdminCP->vBET Tools->Opaque Ignored Words.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.99