PDA

View Full Version : Solved Not translate and problem with Yandex



yogasek
04-04-16, 19:52
Hello today i bought this plugin.

1. This plugin work with DBSEO?

2. I have a problem with translate i check tools and there are results:

Yandex

Starting translation test for Yandex
Test result:
Test error: SSL certificate problem: unable to get local issuer certificate
Connection time (ms): 113.63793945312

Microsoft

Starting test for Microsft Translation API by Azure

Test result: ďťż"ArgumentException: No bearer information found in the token : ID=6346.V2_Json.Translate.5435451A"
Test error:
Connection time (ms): 98.109130859375

I be sure, that API for Yandex is correct.
If Microsoft i have a problem because i don't know which number and where i should place.


Best Regards

Marcin Kalak
05-04-16, 12:53
We currently do not support DBSEO. We currently support only friendly url and vBSEO.

Quick fix for issue with Yandex:

Open file includes/vbenterprisetranslator_class_translator.php
Find code:

function &vbet_getConnection($overrideGet=false, $headerToAdd=null) {
$connection = curl_init();
Put after it this code:

curl_setopt($connection, CURLOPT_SSL_VERIFYPEER, false);

This issue will be fixed in the next release.

Issue with microsoft suggests that your key is incorrect. See: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/3656-how-get-microsoft-api-key.html#post13830 and http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/3291-solution-no-translations-using-azure-translations.html#post12966.

yogasek
06-04-16, 13:09
I will try today.
Can you give me the best .htaccess (friendly url+vbet) ?

yogasek
07-04-16, 00:10
I edit this file, but i still have this problem.

Here you can my edited file:


i.imgur.com/PRTEbf2.png

I can upload image to this forum.

Marcin Kalak
07-04-16, 09:20
Setting the .htaccess according to SEO links is described in the http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq.html#post1539.

I see that your forum is already translated. If the issue occurs in test_yandex.php then add this code:

curl_setopt($connection, CURLOPT_SSL_VERIFYPEER, false);
after this code:

$connection = curl_init();
in test_yandex.php

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages thanks to vB Enterprise Translator PRODUCER_PRODUCT_VERSION