PDA

View Full Version : Solved Translator not working



kiroga3
09-10-15, 12:45
HI

Free Version works for me

vBET 4.8.1 does not work - Running vbulletin 4.2.3 (PHP Version 5.4.44)

Some errors:

PHP Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in ..../includes/vbenterprisetranslator_class_translator.php on line 343
PHP Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in ..../includes/vbenterprisetranslator_class_translator.php on line 343
PHP Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in ..../includes/vbenterprisetranslator_class_translator.php on line 343
PHP Warning: strpos(): Offset not contained in string in ..../includes/vbenterprisetranslator_functions.php on line 435


.htaccess

#RULES for SEO translation links without any SEO engine (on raw vBulletin links)
#If you are using vB 'Mod Rewrite Friendly URLs' then put those rules JUST BEFORE vB rules
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ $2?language=$1 [QSA]

Marcin Kalak
10-10-15, 10:19
Try setting in php.ini safe_mode to off and clear a value of open_basedir.

kiroga3
10-10-15, 11:04
Has made. Does not work. A mistake.

PHP Warning: strpos(): Offset not contained in string in ..../includes/vbenterprisetranslator_functions.php on line 435

Do not give select Yandex. Resets.

Marcin Kalak
10-10-15, 11:45
Please send me a PM access details to Admin CP and FTP. I will check what is going on there :)

Marcin Kalak
10-10-15, 13:12
Change AdminCP->Languages & Phrases->Language Manager->Russian->Edit Settings->HTML Character Set from UTF-8 to utf-8.

kiroga3
10-10-15, 13:30
Do not give select Yandex. Resets.

Marcin Kalak
10-10-15, 13:46
Please paste test result Yandex Translator API: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729

Marcin Kalak
19-10-15, 08:39
No response - considered the issue is gone. If not please write here.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.99