PDA

View Full Version : Solved Many problems installing on vbulletin 5



rafail
30-09-15, 00:03
Hello, i have some problems installing on vbulletin 5
I have uploaded files, set my google api key and all needed settings on admincp

When i tried to import the product-vbenterprisetranslator.xml i got the error:

[QUOTE]
Importing Product, Please Wait...

[:]
Warning: require_once(...//vbenterprisetranslator_functions_admin.php): failed to open stream: No such file or directory in .../includes/adminfunctions_product.php(881) : eval()'d code on line 2
Fatal error: require_once(): Failed opening required '/home/forumsrv/public_html/core//vbenterprisetranslator_functions_admin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/forumsrv/public_html/core/includes/adminfunctions_product.php(881) : eval()'d code on line 2
[\QUOTE]

[\QUOTE]

so i added this line to my "+core+includes+config.php" to decalre the "['Misc']['admincpdir']"
[QUOTE]$config['Misc']['admincpdir'] = 'admincp';[\QUOTE]
vbulletin 5.1.9 does not have this line from default.

How can this xml ask for a variable that is not present??

Anyway, after that it installed. I went to vbet settings and added my google api key and set all needed settings.

After i edited my .htaccess and added first this lines (provided on do-not-upload+tools+redirecting-rules):
[QUOTE]RewriteEngine On
Options FollowSymLinks

RewriteRule ^\?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)\archive\index.php\(.*)?$ archive\index.php?\$2&language=$1 [L,QSA]
RewriteRule ^\?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)\$ index.php?language=$1 [L,QSA]
RewriteRule ^\?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)\(.*)?$ $2?language=$1 [L,QSA]
[\QUOTE]


Did not worked at all, any language flag i selected language was still english

then i added the rest lines on the .htaccess:
[QUOTE]RewriteCond %{QUERY_STRING} !redirected=
RewriteCond %{QUERY_STRING} !do=
RewriteCond %{REQUEST_URI} !(admincp|modcp|clientscript|cpstyles|images|css|js|login|auth|ajax)
RewriteRule ^(.*)$ vbenterprisetranslator_front_controller.php?redirected=$1 [L,QSA][\QUOTE]

Worked, when i clicked on language flag it changed the forum language, BUT.. the image attachments were not showing and i could not logon on admincp,
when i tried to login on admincp i got this error:
[QUOTE] No input file specified. [\QUOTE]


EDIT 2-10-15:

Please read my last post on this thread to get helped for installing on vbulletin 5.1.9

Marcin Kalak
30-09-15, 08:10
Hi.
Thank you for the information about config.xml. Previous versions include a line $config['Misc']['admincpdir'] = 'admincp';. I do not know why it was removed in the latest version of vB.
Your .htaccess should look like this:


RewriteEngine On
Options FollowSymLinks

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1 [L,QSA]

<IfModule mod_rewrite.c>
RewriteEngine On

#In some cases where you have other mod_rewrite rules, you may need to comment out the following line
#and change it to match your folder name. This resets the other mod_rewrite rules for just this directory
#If your site was www.example.com/forum, the setting would be /forum/
#RewriteBase /

# Send css calls directly to the correct file VBV-7807
RewriteRule ^css.php$ core/css.php [NC,L]

# Redirect old install path to core.
RewriteRule ^install/ core/install/ [NC,L]

# Main Redirect
RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]

# Because admincp is an actual directory.
RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]
</IfModule>

<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/atom+xml \
text/javascript \
application/x-javascript \
application/javascript \
application/json \
application/rss+xml \
application/vnd.ms-fontobject \
application/x-font-ttf \
application/xhtml+xml \
application/xml \
font/opentype \
image/svg+xml \
image/x-icon \
text/css \
text/html \
text/plain \
text/x-component \
text/xml
</IfModule>

<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType application/x-javascript A1209600
ExpiresByType text/javascript A1209600
ExpiresByType application/javascript A1209600
ExpiresByType text/css A31536000
ExpiresByType image/x-icon A2592000
ExpiresByType image/icon A2592000
ExpiresByType application/x-ico A2592000
ExpiresByType application/ico A2592000
ExpiresByType image/gif A2592000
ExpiresByType image/jpeg A1209600
ExpiresByType image/jpg A1209600
ExpiresByType image/png A1209600
ExpiresByType application/x-shockwave-flash A1209600
ExpiresByType font/ttf A2592000
ExpiresByType font/otf A2592000
ExpiresByType font/x-woff A2592000
ExpiresByType image/svg+xml A2592000
ExpiresByType font/truetype A2592000
ExpiresByType font/opentype A2592000
ExpiresByType application/x-font-woff A2592000
ExpiresByType application/vnd.ms-fontobject A2592000
</IfModule>

<IfModule mod_headers.c>
Header set Connection keep-alive
<filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
Header set Cache-Control "max-age=2592000, public"
</filesmatch>
<filesmatch "\.(jpg|jpeg|png)$">
Header set Cache-Control "max-age=1209600, public"
</filesmatch>
<filesmatch "\.(eot|woff|otf|ttf|svg)$">
Header set Cache-Control "max-age=2592000, public"
</filesmatch>
# css and js should use private for proxy caching https://developers.google.com/speed/docs/best-practices/caching#LeverageProxyCaching
<filesmatch "\.(css)$">
Header set Cache-Control "max-age=31536000, private"
</filesmatch>
<filesmatch "\.(js)$">
Header set Cache-Control "max-age=1209600, private"
</filesmatch>
</IfModule>

RewriteCond %{QUERY_STRING} !redirected=
RewriteCond %{QUERY_STRING} !do=
RewriteCond %{REQUEST_URI} !(admincp|modcp|clientscript|cpstyles|images|css|js|login|auth|ajax)
RewriteRule ^(.*)$ vbenterprisetranslator_front_controller.php?redirected=$1 [L,QSA]

Please send me a PM access details to Admin CP and FTP. I would like check your settings.

rafail
30-09-15, 11:59
when i put that htaccess i cannot login on admincp, it says "no input file"
sent you pm with admin password
ftp is disabled and i access it through cpanel
if needed let me know

rafail
30-09-15, 12:04
sent you also ftp login pm

Marcin Kalak
30-09-15, 15:30
To disable add language code to an attachment on your forum:
add to AdminCP->vBET->Translation Options->Ignore URLs:

/filedata/
/fetch
/image.php.
To fix an issue with AdminCP, try turning off in server settings FastCGI.

rafail
30-09-15, 16:05
there is no such option in admincp and fastcgi is already off

Marcin Kalak
30-09-15, 17:11
This option should be in a AdminCP->vBET->Translation Options->Ignore URLs. Are you sure you disable FastCGI?

rafail
30-09-15, 18:11
i added urls, added the htaccess you provided and i got white characters and could not login to admincp. fastcgi is not even installed on my server

Marcin Kalak
30-09-15, 19:51
Do you have mod_rewrite enabled? In phpinfo is written that FastCGI is enabled.

rafail
30-09-15, 21:39
CGI is enabled, not FastCGI. FastCGi is not even installed. phpinfor says cgi/fastcgi because it means one or other.
I tried using DSO, it opens cpanel but i get an error on main page: Warning: Cannot modify header information - headers already sent in .../includes/vbenterprisetranslator_functions.php on line 223
also when i turned to dso and added the htaccess content i got white characters on forum (on default english language)
i have added the 3 lines on ignore urls.

So i turned back to CGI (not FASTCGI) and removed the htaccess lines so the forum can work.
I cannot understund this situation, is there any way it can work or not? have you even tasted it on vbulletin 5.1.9? I need help here, i have provided you with ftp and admincp credentials what else should i do to get it work?

Marcin Kalak
01-10-15, 18:44
Yes we tested vBET on vB 5.1.9. I suspect that this is a problem with the server configuration. Please try again using the DSO. If after completing .htaccess you will see the white pages try to disable translation providers in AdminCP->vBET->Translation Providers Availability. Do you have mod_rewrite enabled?

rafail
02-10-15, 07:08
On Translator providers only google was active from beginning.
mod_rewrite is installed by default by apache
dso except from white characters, gives me the error Warning: Cannot modify header information - headers already sent in .../includes/vbenterprisetranslator_functions.php on line 223

Marcin Kalak
02-10-15, 07:13
Have you tested your DSO after my last post? I corrected a little one vBET file and I'd like to see if the DSO will work. This warning and white page are known issues whose solution wheel should be easier.

rafail
02-10-15, 11:06
WORKED.

one question, sould i leave the lines you sent me on ignore urls?
also when i select a language the encoding needs to be set in browser to unicode in order to display correct characters. Is there a way to display translated language without need to select encoding on browser?

Marcin Kalak
02-10-15, 11:31
Do not remove ignore the URL. This allows your attachments will not be parsed. If you see a white page you do not change the server configuration, white pages usually means issues with connection to a translation provider.
Already I look and tests of character encoding issues.

rafail
02-10-15, 11:34
Also on translated pages the image attachemnts are not shown. please check that also

rafail
02-10-15, 13:15
I have changed Languages and phrases>Language manager>edit settings and edited "HTML Character Set" to "UTF-8" and the encoding issue solved.
The only problem now is that attachments are not displayed on translated pages

Marcin Kalak
02-10-15, 13:30
Did you could show such a link where attachments are displayed on not translated page, and where they do not appear on the translated page?

rafail
02-10-15, 17:22
I fixed attachments by doing a repair on attachment tables (admincp>repair/optimize tables)

My conclusion (to all vb5 users that want to install this plugin on their forums):

This addon had some installation problems that were fixed with "Marcin Kalak" Help (Many Thanks)

To install it on Vbulletin 5.1.9 you need to edit "/core/includes/config.php" by adding this line on the end of it:

$config['Misc']['admincpdir'] = 'admincp';

The PHP processor must be "DSO" , not "CGI". So if you have "cgi" you must chage it to "DSO" on your server. On WHM cpanel it can be changed by going to "Service configuration>Configure PHP ad SUExec" And select there "PHP 5 Handler" to "DSO"

The .Htaccess should have on the beginning these lines:

RewriteEngine On
Options FollowSymLinks

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1 [L,QSA]


And at the end this lines:

RewriteCond %{QUERY_STRING} !redirected=
RewriteCond %{QUERY_STRING} !do=
RewriteCond %{REQUEST_URI} !(core|admincp|modcp|clientscript|cpstyles|images|css|js|login|auth|ajax)
RewriteRule ^(.*)$ vbenterprisetranslator_front_controller.php?redirected=$1 [L,QSA]

You must add add to "AdminCP->vBET->Translation Options->Ignore URLs":

/filedata/
/fetch
/image.php

And go to "Admincp>Languages and phrases>Language manager>edit settings" and edit "HTML Character Set" to "UTF-8"


And Vbet Translate plugin will work on Vbulletin 5.1.9
EDIT 27-12-15: after some better checks i found many problems, pages not even translated and many db errors occured....

Marcin Kalak
02-10-15, 19:16
I am glad that I helped you. In the next release vBET will not be necessary to change the config file.

rafail
02-10-15, 19:47
One more thing Marcin, on htaccess "|core" must be added on RewriteCond %{REQUEST_URI}
so it should look like this:

RewriteCond %{REQUEST_URI} !(admincp|modcpclientscript|cpstyles|images|css|js|login|auth|ajax|core) (edited my guide above)
else avatars will not be shown (access denied)

Thanks

Marcin Kalak
02-10-15, 20:00
Thank you very much for the information.

rafail
27-12-15, 14:45
Just to inform that after such changes forum was performing very bad, some pages worked well as i said but i noticed many db errors and problems on translations. Many pages were not even translated. So i removed vbet (very hard to do since it had many entried on database).

Awaiting an update that will full work on vb 5.1.9 and not causing such problems.

Marcin Kalak
28-12-15, 11:22
The current version vBET should work for vB 5.1.9. No translation of page may be cause exhaustion translations limits. In an above configuration I tested vBET for vB 5.1.9. If you have any other issues please create a new topic.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vBET Translator 4.9.99