PDA

View Full Version : Solved Does not translate



Fabiano
09-06-15, 04:21
Well, I again plead for help....

It has been more than a month that I bought the vBET and until today I could not make it work, I have talked with the Marcin by Private Message to bad the same could not solve and asked me again that I opened a topic here.

The Marcin says that exhausted my limit of API from Microsoft, however this is not true, because if I do I log into my Microsoft account and it is there that still remain with me 2,000 to translate, or I use.

I need help, because my forum only translates to the English and Russian.

Thank you.

Marcin Kalak
09-06-15, 10:27
Please paste test result Microsoft Translator API: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729

Fabiano
09-06-15, 17:34
test_microsoftbyazure.php


Starting test for Microsft Translation API by Azure

Test result: "ArgumentException: No bearer information found in the token : ID=5641.V2_Json.Translate.11735732"
Test error:
Connection time (ms): 89.697021484375

test_apertium.php


Starting translation test for Apertium
Test result: {"responseData":{"translatedText":null},"responseDetails":"Unexpected Error: null","responseStatus":500}
Test error:
Connection time (ms): 17197.694091797

test_detectlanguage.php


Starting detection test for DetectLanguage API
Test result: {"data":{"detections":[{"language":"pl","isReliable":true,"confidence":24.09}]}}
Test error:
Connection time (ms): 375.67211914062

test_yandex.php


Starting translation test for Yandex
Test result: <?xml version="1.0" encoding="utf-8"?> <Translation code="200" lang="en-de"><text>Sein oder nicht sein?</text><text>Das ist die Frage.</text></Translation>
Test error:
Connection time (ms): 343.7978515625

Marcin Kalak
10-06-15, 10:05
Microsoft's test result suggests an incorrect key. Check key for Microsoft API. See: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/3656-how-get-microsoft-api-key.html#post13830 and http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/3291-solution-no-translations-using-azure-translations.html#post12966.
The result Apertium says that the service was temporarily unavailable. Apertium servers often fall. Try to do the test later.
The result DetectLanguage and Yandex says that all was well.

Fabiano
10-06-15, 16:56
Yes, I'm putting my key in the application that is the "Client secret" Even so, the test of Azure gives the same error.

Marcin Kalak
10-06-15, 17:27
I recommend sending such photos on the PM.

You must write contents of Client ID field in AdminCP->vBET->vBET Translation Providers->Microsoft FREE/Commercial Translation API key by Azure and write contents of Client Secret field in AdminCP->vBET->vBET Translation Providers->Microsoft FREE/Commercial Translation API secret by Azure.

Make sure that content of Client ID is the same as content of Microsoft FREE/Commercial Translation API key by Azure and content of Client Secret is the same as content of Microsoft FREE/Commercial Translation API secret by Azure.

Marcin Kalak
12-06-15, 09:36
No response - considered the issue is gone. If not please write here.

Fabiano
12-06-15, 16:53
Problem solved. Thank you!

Marcin Kalak
13-06-15, 10:03
I'm glad I could help you.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET PRODUCER_PRODUCT_VERSION gives automatic translations