PDA

View Full Version : Translation Flags Not Appearing



mykkal
25-05-15, 05:17
I uninstalled the version for vb 3.8 and installed the free version. I made uninstalled the edits for vBSEO and then put in the Yandex API. I places the flags in a custom location in the header and they do not appear. I'm using a child style of the vbulletin default style. When i view the source I don't see anything to do with vBET

Here is a link you can look at: PAID Other Talent - Dog Food Demo Hiring Dog Lovers For Long Term Position (http://mymodeltalk.com/jobs/model-castings-acting-auditions-atlanta-metro-ga/1466741-dog-food-demo-hiring-dog-lovers-long-term-position.html)

the code I used was:


<div>{vb:raw vbenterprisetranslatorflags}</div>

Marcin Kalak
25-05-15, 08:54
Do you have enabled vBET in AdminCP->Plugins & Products->Manage Products?

mykkal
25-05-15, 21:16
Do you have enabled vBET in AdminCP->Plugins & Products->Manage Products?


ahhh its working now.

mykkal
25-05-15, 21:21
Will this work with the default mobile style?

Fabiano
26-05-15, 01:55
The Mobile version does not appear the option to select the language.

mykkal
26-05-15, 02:04
The Mobile version does not appear the option to select the language.

huh? I don't know what you said. I'm able to visit pre-translated pages but I need a way to add the flags to the mobile style. 68% of my traffic is via smartphone, mobile phone, or tablet.

vBET has done this before. http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/2128-flag-not-showing-mobile-style.html?highlight=mobile

Fabiano
26-05-15, 02:17
On the Mobile version when the person is going to register, it does not appear the flags of the language.

mykkal
26-05-15, 02:38
On the Mobile version when the person is going to register, it does not appear the flags of the language.

Correct, they are not appearing. I'm wondering how to to get them to appear. Do you have any idea? My site is MyModelTalk Free Casting Calls for Models and Actors! (http://MyModelTalk.com/jobs/)

mykkal
26-05-15, 15:23
Do you have enabled vBET in AdminCP->Plugins & Products->Manage Products?

Martin, please reply. I need help getting this to work on the mobile style. It's working on my desktop child style. But I can't get it to work on the mobile style so far. please help. thx

Marcin Kalak
26-05-15, 17:29
To add a flag to a mobile style:
1. Open AdminCP->Styles & Templates->Style Manager->Default Style->Edit templates->vbenterprisetranslator_flags.
2. Change value Style from Default Style to your mobile style.
3. Save the template.
If you want to add other vBET template (e.g. add a flag to translated messages) then import other needed vbenterprisetranslator styles.

mykkal
26-05-15, 17:46
i need to use it on more than one style at a time. The mobile style is for mobile phones and only displays upon smartphone detection when a visitor visits the site. Otherwise they see the vB4 default style.

How do I use it on more than one still at a time?


To add a flag to a mobile style:
1. Open AdminCP->Styles & Templates->Style Manager->Default Style->Edit templates->vbenterprisetranslator_flags.
2. Change value Style from Default Style to your mobile style.
3. Save the template.
If you want to add other vBET template (e.g. add a flag to translated messages) then import other needed vbenterprisetranslator styles.

mykkal
26-05-15, 17:57
Nevermind I figured it out. I copied the vbenterprisetranslator style over to the mobile style instead of switching it. Now vBET works in both styles. Thanks for the tip. You may want to add this to your documentation so others know.

Marcin Kalak
26-05-15, 17:57
After you import a template vBET to mobile style, you can set the value {vb:raw vbenterprisetranslatorflags} both in mobile style and default style. Flags do not appear in mobile style, because in mobile style was not template vbenterprisetranslator_flags.

Marcin Kalak
26-05-15, 17:59
Nevermind I figured it out. I copied the vbenterprisetranslator style over to the mobile style instead of switching it. Now vBET works in both styles. Thanks for the tip. You may want to add this to your documentation so others know.
I'm glad I could help you.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 gives automatic translations