PDA

View Full Version : Solved URL's not working correctly when apostrophe in title



tavenger5
06-05-14, 18:51
See example here: V'mail problems w/ unlocked V3 on ********* (http://cellphoneforums.net/********/t194603-v'mail-problems-w-unlocked-v3-*********.html)

The flag links at the bottom are going to /********/t194603-v'

Everything after the ' is being cut off

tavenger5
06-05-14, 18:53
okay, something strange is happening. Since the word m otorola (without the space) is filtered on this site, the url is being redirected. On the redirection the ' is turning into %27. With %27 in the url things work fine. If you replace %27 with a ' you'll see what I'm referring to. The same does not happen on this forum, I'm guessing because the URL settings for vbSEO are not allowing special characters.

Marcin Kalak
07-05-14, 14:50
vBSEO should cut or replace special characters. I have not found a link on your site with special characters. Do vBSEO not replaced somewhere special characters in link?

tavenger5
07-05-14, 21:42
vBSEO should cut or replace special characters. I have not found a link on your site with special characters. Do vBSEO not replaced somewhere special characters in link?

No, it is not replacing special characters. Do you know how to set things so it does?

Marcin Kalak
08-05-14, 16:30
No. We support the configuration of vBET, not vBSEO.

tavenger5
09-05-14, 02:18
No. We support the configuration of vBET, not vBSEO.

Yeah, I know, but this setting in vbSEO is causing vBET to fail in the specific case :)

Marcin Kalak
10-05-14, 10:52
Are the links with ' will appear on the site? Does that cause issue you need to enter ' manually?
You can try to insert a rule in the AdminCP->vBSEO->Control Panel->General Setings->Character Replacement.

tavenger5
12-05-14, 19:58
The character replacement does not work unless Remove/Replace non-english characters in URLs is on. If it is turned on then naturally the non-english characters are then removed/replaced

Marcin Kalak
13-05-14, 16:10
Have you tried to add a rule to Define your Custom Character Replacements in AdminCP->vBSEO->Control Panel->General Setings->Character Replacement?

Are the links with ' will appear on the site? Does that cause issue you need to enter ' manually?

tavenger5
14-05-14, 15:42
yes I added this rule: '''=>'' but it has no effect. I also tried changing "Disable "urlencoding" in URLs ?" but this does not work correctly.

The only reason I noticed this is because Google like to take encoded URL's and change the encoding to the character. In the example above %27 is changed to ' and then Google indexes the different languages with ' in the URL. But in this case the URL's are being cutoff. If you change %27 to ' manually it does not redirect to %27.

Marcin Kalak
16-05-14, 09:20
Please send me a PM access details to Admin CP and vBSEO. I will check what is going on there :)

Marcin Kalak
19-05-14, 08:30
You do not have executed two steps from the manual:
Turn off option SEO Functions->Dynamic META TAGS->"Replace the 'META KEYWORDS' Content?"
Turn off option Other Enhancements->Cleanup HTML Code->"Cleanup HTML Code"
First do these steps.

Marcin Kalak
28-05-14, 08:46
No response - considered the issue is gone. If not please write here.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vB Enterprise Translator 4.9.2