PDA

View Full Version : Solved php warning on all pages



tavenger5
19-02-14, 18:38
Getting this on all of my pages. Running the latest version.

Warning: Invalid argument supplied for foreach() in /home/site/public_html/includes/vbenterprisetranslator_functions_hooks.php on line 734

Marcin Kalak
21-02-14, 12:57
Please give me a link to the issue. Please send me a PM access details to Admin CP and FTP. I will check what is going on there :)

Marcin Kalak
24-02-14, 12:23
I do not have access to FTP.

Marcin Kalak
25-02-14, 12:15
Quick fix for this issue:

Open file includes/vbenterprisetranslator_functions_hooks.php
Find:

if($vbulletin->options['vbenterprisetranslator_alternate_tag'])
Replace it to:

if($vbulletin->options['vbenterprisetranslator_alternate_tag'] && !$vbulletin->userinfo['userid'])

This quick fix will be added in the next release.

tavenger5
28-02-14, 16:42
thanks, that worked.

tavenger5
30-07-14, 20:30
I updated to the latest version of vBET. I had to re-apply this fix, however it is now showing on all guest pages no matter what.

Marcin Kalak
31-07-14, 11:37
I do not see the issue on your website.
The latest version vBET is 4.7.2. Your version is 4.7.1. Have you done a downgrade?

tavenger5
01-08-14, 21:21
Yes, I downgraded after I saw this, but it looks like it's happening in 4.7.1 as well. It's only happening when no translation providers are available (Google is marked as available in my case, but I don't have an API key entered for them). When this happens threads are also NOT being translated.

Marcin Kalak
04-08-14, 11:56
If you do not have a key Google then it should be automatically disabled. You manually turn off Google in AdminCP->vBET->Translation Providers Availability. Please let me know if Google turn on automatically in AdminCP->vBET->Translation Providers Availability.
Please let me know if this resolves the issues.

tavenger5
04-08-14, 23:08
If you do not have a key Google then it should be automatically disabled. You manually turn off Google in AdminCP->vBET->Translation Providers Availability. Please let me know if Google turn on automatically in AdminCP->vBET->Translation Providers Availability.
Please let me know if this resolves the issues.

Actually, it appears that I was wrong. Even though Google is now staying off after setting it manually, the error still appears. However, it doesn't appear all the time. I can't find a pattern. Naturally it goes away when "Add alternate tag" is turned off.

Marcin Kalak
05-08-14, 12:11
I do not see the issue. I can not reproduce the issue, if I do not know when it arises.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vB Enterprise Translator 4.9.2