PDA

View Full Version : Solved Unable to uninstall vbet without breaking the forum



Simon Lloyd
18-02-14, 18:03
Hi guys,
I have a need to uninstall vbet, I uninstalled via admincp and vbet is gone, however if I try to delete vbet files off my server (i'm trying to get my server back to standard files only before reinstalling just what I need) it kills my forum!!? here's the error I get if I try to remove files AFTER uninstalling via admincp:

Warning: require(/home/thecodec/public_html/forumz/includes/vbenterprisetranslator_functions_redirect.php) [function.require]: failed to open stream: No such file or directory in /home/thecodec/public_html/forumz/includes/init.php(304) : eval()'d code on line 135

Fatal error: require() [function.require]: Failed opening required '/home/thecodec/public_html/forumz/includes/vbenterprisetranslator_functions_redirect.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/thecodec/public_html/forumz/includes/init.php(304) : eval()'d code on line 135

I have removed all vbet rules from .htaccess.

Any ideas how to cure this?

Regards,
Simon

Marcin Kalak
19-02-14, 09:04
This looks like not removing some plugin vBET or not removing integration vBET with some plugin. Do you have vBSEO? Try turning off all the hooks/plugins (more info (http://www.vbulletin.com/forum/forum/vbulletin-3-8/vbulletin-3-8-questions-problems-and-troubleshooting/vbulletin-quick-tips-and-customizations/201532-disable-the-plugin-hook-system-globally)).

Simon Lloyd
19-02-14, 17:28
I have no option but to turn off all plugins, I had vbseo but I've tried getting rid of it!, when I try uninstalling vbet I get all sorts of issues, it's driving me nuts!

Marcin Kalak
20-02-14, 13:42
Before uninstalling vBET must remove its integration with vBSEO. Before uninstalling vBET also try to disable all hooks in config.php (more info (http://www.vbulletin.com/forum/forum/vbulletin-3-8/vbulletin-3-8-questions-problems-and-troubleshooting/vbulletin-quick-tips-and-customizations/201532-disable-the-plugin-hook-system-globally)).

Simon Lloyd
21-02-14, 12:02
I'll give it another go, VBSEO has been uninstalled so i don't know what integration you mean? VBSEO rules have been removed from .htaccess. where else should i be looking?

Marcin Kalak
21-02-14, 12:08
If you have removed vBSEO then you also removed integration vBSEO with vBET.
Please send me a PM access details to Admin CP and FTP. I will check what is going on there :)

Simon Lloyd
21-02-14, 15:09
PM sent :)

Marcin Kalak
26-02-14, 14:53
Before uninstalling vBET you must remove all of its integration. I found your integration in modules/recentthreads.php in lines 255-260. If you have done some other integration with vBET then delete them.

Simon Lloyd
26-02-14, 15:57
Thankyou for that, I forgot about the vbacmp, I will now try and clean up and uninstall - i'll let you know how it goes!

Simon Lloyd
26-02-14, 16:06
Uninstalled vbet then started to remove vbet files and got this:
Warning: require([path]/includes/vbenterprisetranslator_functions_redirect.php) [function.require]: failed to open stream: No such file or directory in [path]/includes/init.php(304) : eval()'d code on line 135

Fatal error: require() [function.require]: Failed opening required '/home/thecodec/public_html/forumz/includes/vbenterprisetranslator_functions_redirect.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/thecodec/public_html/forumz/includes/init.php(304) : eval()'d code on line 135

Simon Lloyd
26-02-14, 16:24
I had to reinstall the files (but not the product) in order to use my forums

Marcin Kalak
01-03-14, 10:13
Despite the removal of vBET still works. Your vB also launches plugins disabled. This problem also occurs in other plugins, so it is not a problem of vBET. Do you have a caching plugin? If so, clear the cache. vB has a duty to remove plugins and apparently did it because in AdminCP has no plugins, but they are in the cache database because they are further loaded.

Simon Lloyd
02-03-14, 09:52
The issue was with datastore/datastore_cache.php for some reason it became unwritable, so I made it writable and then uninstalled fine!

Marcin Kalak
03-03-14, 14:04
I am glad that you solved the issue.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vBET Translator 4.9.2