PDA

View Full Version : Solved Message from webmaster tools regarding incorrect rel-alternate tags



tavenger5
26-10-13, 13:08
Dear webmaster,

We have noticed that on a number of the pages on your site the rel-alternate-hreflang implementation is incorrect. For example:

In particular, there seems to be a problem with missing or incorrect bi-directional linking (when page A links with hreflang to page B, there must be a link back from B to A as well). When our algorithms detect conflicting signals like on these pages, they may make indexing and ranking decisions that do not match what you intended.

To learn more about rel-alternate-hreflang, see the following Help Center article: https://support.google.com/webmasters/answer/189077

If you have any questions about how to resolve this issue, please visit our Help Forum:

Google Groups (http://productforums.google.com/forum/#!categories/webmasters/internationalization)

Sincerely,
The Google Search Quality Team


This is no doubt because the translated URL is not being included in the tags. Can an option be added to just turn off translation of URL's? I believe this would solve a lot of problems I'm having.

vBET
28-10-13, 23:25
This is not about translation of URLs. This is only about hreflang in alternate link and you can simply turn it off by Admin CP -> vBET -> Translation Options -> Add Alternate tag

Also please note that disabling translation of URL will have bad impact on your SEO (lack of translated keywords in URL), so it is advised to not do this. If you still want, then it is enough to not integrate with vBSEO if your links are generated by vBSEO (some bad things can happen - this is not advised and not tested). And in case of native Friendly URL it is enough to disable some hooks (same thing, we will not give details now, only when needed).

Also Marcin will check how alternate are generated right now. We made changes before and now for guests URLs under flags are already generated translated, so no redirection happens (for logged users it do not have sense and it is better for performance to just redirect if ever language switch will happen for such user). But maybe we forgot about alternate. We will check it on our side. Right now it is simplest for you to just disable.

Marcin Kalak
29-10-13, 20:19
Please provide links to sites where alternative tags do not agree among themselves.

tavenger5
29-10-13, 22:32
I never did get URL's to translate properly in the flag links. Here is a page where this is happening: Galaxy Note 3: Disable "My Magazine"? (http://cellphoneforums.net/*******-galaxy/t365731-galaxy-note-3-disable-my-magazine.html)

Marcin Kalak
31-10-13, 13:40
OK, we are working on this issue.

tavenger5
03-11-13, 14:12
FYI, I updated to the latest version, hooked up yandex, and I still cannot get flag and/or re-alternate links translated. My caches are all turned on and guest cache is set to timeout in 3600 seconds.

Here's an example of a page that has been translated, but the flag links/alternate tag links are not linked as translated URL's:
How-to: ******* Galaxy S4 Mini: Transferring Contacts from an ****** to the SGS4 Mini (http://cellphoneforums.net/*******-galaxy/t365916-*******-galaxy-s4-mini-transferring-contacts-******-sgs4-mini.html)

Spanish page links to
[url=http://cellphoneforums.net/es/*******-galaxy/t365916-*******-galaxy-s4-mini-transferring-contacts-******-sgs4-mini.html](Espa

tavenger5
03-11-13, 14:13
alright, you guys really need to do something about your word filters...

tavenger5
03-11-13, 14:16
example using the linked page above:

Galaxy Note 3: Disable "My Magazine"? (http://cellphoneforums.net/*******-galaxy/t365731-galaxy-note-3-disable-my-magazine.html)

linked Spanish page:
[url=http://cellphoneforums.net/es/*******-galaxy/t365731-galaxy-note-3-disable-my-magazine.html](Espa

Marcin Kalak
04-11-13, 15:52
Do you have enabled Use database cache and disable cleaning cache in AdminCP -> vBET Cache -> Database Cache?

tavenger5
05-11-13, 18:52
Do you have enabled Use database cache and disable cleaning cache in AdminCP -> vBET Cache -> Database Cache?

Yes and yes

Marcin Kalak
06-11-13, 16:57
Please send me a PM access details to Admin CP, database and FTP. I will check what is going on there :)

tavenger5
07-11-13, 15:26
sent**********.

tavenger5
07-11-13, 17:27
sent**********.

Marcin Kalak
08-11-13, 12:06
To translate alternate links for guests enable AdminCP->vBET->Guest Cache->Use Full File Cache For Guests. This allows that site to guests will not have to be generated each time and speed up your page. The next version will fix this in order not translated alternate links do not appear on the site.

tavenger5
08-11-13, 19:56
Yes, that was previously enabled, but I turned it off because of this error: http://www.vbenterprisetranslator.com/forum/vbet4-bug-reporting/3774-webpage-has-redirect-loop-guests.html

I've never seen URL's translated for guests.

tavenger5
12-11-13, 18:34
I enabled the guest cache again because my google page response times shot through the roof.

Any insight on this and when I can expect a fix for the rel-alternate tags?

Is there something configured incorrectly on my end that prevents the flag URL's from being translated?

Marcin Kalak
12-11-13, 20:28
Enable Guest cache should not cause issues with http://www.vbenterprisetranslator.com/forum/vbet4-bug-reporting/3774-webpage-has-redirect-loop-guests.html.
To translate alternative tags must enable AdminCP->vBET->Guest Cache->Use Full File Cache For Guests.
In the next release not translated tags will not be added to site.

tavenger5
13-11-13, 01:40
Right but even with Use Full File Cache For Guests enabled flag URL's and rel-alternate tags are not being translated.

Marcin Kalak
13-11-13, 17:13
Translations for alternative links are retrieved from database cache. Translations of alternative links do not extort use of translators api. Links are sent to translator api when someone entered the site in that language. The aim is to reduce translation costs.

tavenger5
13-11-13, 18:39
Okay, I think something is literally getting lost in translation here.

I understand how everything works. I've reviewed how flag urls are supposed to be translated (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-3.html#post13517) only when guests are viewing the page. The problem is, they are not being translated. This is not because I am out of quota, it's because something isn't working properly.

Example:
English page: ** spectrum 2 change apn settings (http://cellphoneforums.net/**/t366482-**-spectrum-2-change-apn-settings.html)
The flag URL on that page for French: http://cellphoneforums.net/**/fr/t366482-**-spectrum-2-change-apn-settings.html
The flag URL for french should be: (Français) ** spectrum 2 modification des paramètres de l'apn (http://cellphoneforums.net/fr/**/t366482-**-spectrum-2-modification-des-param%C3%A8tres-de-l-apn.html)

Note that the flag URL's are not the translated URL's despite the pages being translated. The guest cache has cleared since the translations have been made.

Marcin Kalak
14-11-13, 19:04
Translated URL must first be found in database cache. Flags are translated when the address is already translated in database cache.

tavenger5
15-11-13, 18:11
Okay - so what would prevent a translated URL from being in the database cache? In the example I posted above the URL's are translated, but the flag links are not, so does that mean that they are not in the database cache?

Marcin Kalak
18-11-13, 19:36
We do not have the option to add to database cache only translated url - cache is enabled or not. We do not support this distinction. If URL is translated and the flag will not be translated then URL is not in the database cache.
So assuming: it is working for guests only, with delayed requests for translation - for performance reasons. More information: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-3.html#post13517

tavenger5
19-11-13, 20:21
Okay - I have done everything outlined in the faq, as previously stated, but flag URL's are not being translated.

tavenger5
19-11-13, 20:25
Okay, I think something is literally getting lost in translation here.

I understand how everything works. I've reviewed how flag urls are supposed to be translated (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-3.html#post13517) only when guests are viewing the page. The problem is, they are not being translated. This is not because I am out of quota, it's because something isn't working properly.

Example:
English page: ** spectrum 2 change apn settings (http://cellphoneforums.net/**/t366482-**-spectrum-2-change-apn-settings.html)
The flag URL on that page for French: http://cellphoneforums.net/**/fr/t366482-**-spectrum-2-change-apn-settings.html
The flag URL for french should be: (Français) ** spectrum 2 modification des paramètres de l'apn (http://cellphoneforums.net/fr/**/t366482-**-spectrum-2-modification-des-param%C3%A8tres-de-l-apn.html)

Note that the flag URL's are not the translated URL's despite the pages being translated. The guest cache has cleared since the translations have been made.

again, see the above. I'm either not setting something correctly or there is a bug in the software preventing flags from showing the translated URL.

Marcin Kalak
20-11-13, 16:27
OK, I tested this issue.

tavenger5
21-11-13, 19:45
OK, I tested this issue.

Thank you - if it helps, my forum charset is ISO-8859-1

Marcin Kalak
23-11-13, 12:26
The issue is that your hook parse_templates is triggered too quickly. Please, you update your vB.

tavenger5
23-11-13, 18:58
The issue is that your hook parse_templates is triggered too quickly. Please, you update your vB.

I'm not sure what that means. Do you mean update to vbulletin 4.2.2 ? What is the difference between 4.1.12 and 4.2.2 on how parse_templates is handled?

tavenger5
23-11-13, 19:00
...or do you mean update the execution order of "Generate flags" which uses the parse_templates hook?

Marcin Kalak
25-11-13, 20:22
Execution order changes order of plugins within the framework of a hook. Execution order does not change the order of the hooks. On our test forum this hook is working properly. vB license has no time limit, so you can do the upgrade. Your version vB has long been out of date so I recommend execution upgrade. I think that this will solve the issue, if that does not work then we'll look further.

tavenger5
26-11-13, 23:56
so in 4.2 the execution order of the parse_templates hook is different?

Unfortunately updating to 4.2 is a huge task as it would break several other addons that I use.

tavenger5
27-11-13, 20:48
I checked class_bootstrap.php and the parse_templates hook is in the same place in the file on both 4.1.12 and 4.2.2. Can you elaborate on what is causing the problem with that hook and it executing too early?

Marcin Kalak
28-11-13, 15:28
We support the latest versions and vBET is adapted to the latest version. Each version contains a lot of changes. If you do update, and you still have this issue then we will be happy to assist you.

tavenger5
29-11-13, 19:32
I'm not going to update vbulletin, and spend a lot of time doing so, unless I know that updating is going to solve the issue with the flags. You said that you "think" it will solve the issue. I need a confirmation on exactly what is causing the problem and that it WILL solve the issue.

Marcin Kalak
03-12-13, 20:10
We support the latest version. VB4 is a lifetime license, so please do update. If issue will remain then we can help, because now it seems that the fault of the old, unsupported version.

tavenger5
04-12-13, 01:47
We support the latest version. VB4 is a lifetime license, so please do update. If issue will remain then we can help, because now it seems that the fault of the old, unsupported version.

Okay, can you tell me what is going wrong with the old version?

vBET
04-12-13, 23:15
Okay, can you tell me what is going wrong with the old version?

It is old and differed that new, and not supported, since vBET4.x is tested on newest vB4 version. When you will have newest vB4 version and issue will still exists we will gladly help you.
At this moment we can assume that there is nothing wrong with vBET since the issue cannot be reproduced on newest vB version.
There is no bug in vBET4.x - you are just using it on not compatible old vB4 version. Wrong fuel for wrong engine - no service issue, just wrong using issue.

Please update vB4 to newest vB4 version.

If there is no bug on supported vB version, we will consider this issue closed, since there is no issue with vBET, just with wrong usage and you already got solution for that.

Marcin - please close the ticket if there will be no new input in next few days (bug exists on newest vB4 version).

We already gave you the support - if you do not want to use it it is your choice. We respect our clients - we also respect that you prefer to have the issue instead of using our support which was already given.
This is not a chat room and our staff will close this ticket, since solution was already given and as for now we have confirmation that on newest vB4 version it is all OK.

Thanks for your input.
Hope that you will decide to use the support you was asking for.
It not - still thanks for understanding that there is nothing to add in this area, until you use the support instead of repeat all the time that you want support and do not use it when it is given.

Marcin will continue to support this ticket in next few days and answer only when we will have your feedback that on newest (supported) vB4 version the issue also exists. If not it will be closed.

tavenger5
05-12-13, 15:34
I'm not asking you to fix the problem with an unsupported version of vBulletin. I'm asking you to tell me where the problem is, and confirm that it is, in fact, a problem with 4.1.12 so I can fix it. You've only told me that it might be a problem with 4.1.12. I need to know that it is a problem before I go out of my way to update vBulletin.

As stated, I'm not going to go through the trouble of upgrading vbulletin if I don't have to. It would cost me a considerable amount of time and money to update other custom mods. You have the login credentials for my site. It should be easy for you to tell me what is going wrong with the parse_templates hook. For example, x file is different between 4.1.12 and 4.2.2. Or parse_templates needs to execute before x hook.

I've had your product since the beginning and I just renewed my license. I would expect you would treat a long standing customer with a little more respect.

Again, all I need is to be pointed in the right direction. I'm not asking to rewrite the entire mod to work with 4.1.12. I honestly don't think this is an absurd request especially considering I am a long time customer.

Marcin Kalak
06-12-13, 12:38
Our product has been adapted to the latest version of vB, it is impossible to adapt the product to all versions.

tavenger5
07-12-13, 13:53
Maybe the translation isn't going through, I don't know, but for the 5th time I'm NOT asking you to change anything with the product. I'm simply asking you to tell me what is breaking in 4.1.12!

Marcin Kalak
10-12-13, 19:53
In your version of vB order of hooks is bad. In latest version of vB this problem does not occur. This is not an issue related to vBET, but with vB. We support vBET and its integration with latest version of vB and other plugins.

tavenger5
12-12-13, 19:27
In your version of vB order of hooks is bad. In latest version of vB this problem does not occur.


Okay. Which hook are you referring to? I've examined class_bootstrap.php and the parse_template/process_templates_complete hooks are in the same place in 4.2.2 as it is in 4.1.12. The same goes for global_bootstrap_complete, global_complete, global_bootstrap_init_start, global_shutdown and their corresponding files.



This is not an issue related to vBET, but with vB. We support vBET and its integration with latest version of vB and other plugins.
I know.

tavenger5
13-12-13, 13:30
Alright, I did the update to 4.2.2, because I was tired of waiting for a response. Now I have a whole new set of problems: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/3835-translated-pages-blank-not-redirecting-translated-url.html

Marcin Kalak
13-12-13, 20:02
OK. I answered you in that topic.

tavenger5
13-12-13, 20:15
Thanks. Those issues have been corrected.

Now, unless I'm missing something, I'm still not seeing the flags and rel-alternate tags being translated. They are just as they were on 4.2.2 as on 4.1.12.

Marcin Kalak
16-12-13, 13:46
OK. We work and test this issue.

Marcin Kalak
18-12-13, 19:01
OK. I found a solution. The sequence of hooks in you is different than ours, even though we have the same version of vB.
Quick fix for this issue:

Go to AdminCP->Plugins & Products->Plugin Manager->Product : vB Enterprise Translator
Edit plugin Translate link to thread
Change hook location to fetch_threadinfo
Replace the php code on this code:


require_once(DIR. '/includes/vbenterprisetranslator_functions_url.php');
if($thread[title]) vbet_translateUrls($thread[title]);
Save plugin.


After clearing a guest cache alternative tags should be translated correctly.

tavenger5
18-12-13, 20:56
After clearing a guest cache alternative tags should be translated correctly.

YES!! Finally!! That worked!

Any idea why the hooks are different to begin with?

Marcin Kalak
19-12-13, 17:29
I'm glad I help you.
I'm still looking for the cause of a different order execution hook.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Integration with Google translations by vBET Translator 4.9.2