PDA

View Full Version : Solved Error ...



krisp
08-02-10, 19:38
Getting this error on new server:


Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in [path]/includes/vbenterprisetranslator_functions.php on line 653

PHP safemode = Off and Curl installed: phpinfo() (http://www.thegameonline.dk/phpinfo.php)

krisp
09-02-10, 15:38
Its a little unstable, for the past few minuts I havent been able to reproduce:

Tried adding to httpd.conf


<Directory /var/www/vhosts/mydomain.com/httpdocs>
AllowOverride All
php_admin_flag engine on
php_admin_value open_basedir none
</Directory>

htaccess contains in top


<Files ~ (\.pl)>
Options ExecCGI FollowSymLinks
</Files>

Options +FollowSymLinks +SymLinksIfOwnerMatch

krisp
09-02-10, 21:46
does it all the time now, try fx, there Is a thread that deserves to be made by post the link here. (http://www.thegameonline.dk/sv/showthread.php?t=156)

I am a bit in the dark here ... ?

krisp
09-02-10, 22:43
vhosts.conf in httpdocs directory:


<Directory /var/www/vhosts/domain.com/httpdocs>
php_admin_flag engine on
php_admin_value open_basedir none
</Directory>

seems to have solved it

vBET
10-02-10, 13:40
Great to hear that you solved it and sorry for late answer. As I understood it was server configuration issue.

krisp
10-02-10, 21:24
yes, seems you have to use vhosts.conf instead of httpd.conf when using Plesk.

krisp
14-02-10, 19:48
Well, even if I managed to solve it for normal pages, it seems I am still getting this for rss feeds:


Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in [path]/includes/vbenterprisetranslator_functions.php on line 653

Please check my phpinfo: phpinfo() (http://www.thegame-online.dk/phpinfo.php) - safe mod should be off and curl should be activated

krisp
14-02-10, 21:11
Well, even if I managed to solve it for normal pages, it seems I am still getting this for rss feeds:



Please check my phpinfo: phpinfo() (http://www.thegame-online.dk/phpinfo.php) - safe mod should be off and curl should be activated

Fould solution here :)
Warning: curl_setopt() [function.curl-setopt]: - SugarCRM Forums (http://www.sugarcrm.com/forums/showthread.php?t=46071)

m_k
23-02-10, 21:05
I had a similar error which after exhaustive sleuthing around turned out to be a WHM security plugin that disallowed open_basedir for various domains on my server. Once I discovered this and tweaked the settings everything worked fine...

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vB Enterprise Translator 4.9.2