PDA

View Full Version : Solved Facebook error



sergarch
19-09-13, 12:37
Hello again!

Just updated my licence to contionue work with vBet :D

After upgrade to the last vBet version I've got a strange facebook error.

Instead facebook's button ("like", "recommend") I've got this error link:
https://www.facebook.com/plugins/error/api?code=100&message=action+must+be+one+of+the+following+values%3A+like%2C+recommend&hash=AQA8ooCrd6d-B4-2

This error happens only in translated articles, threads, etc.

In my default language ( Russian) facebook button works perfectly.

Please help.

Marcin Kalak
20-09-13, 12:35
Please, you give me a concrete example of the issue, because as I tested do not see the issue.

sergarch
21-09-13, 18:50
Hello Marcin,
Thank you for your responce!

I have invistigated this essue.

Here is an exaple:
Вся жизнь человека за пять минут (http://www.xpam.org/video/744-vsya-zhizn-cheloveka-za-pyat-minut.html)

1) If you are unregistered member:


If you are using default language (Russian) you can see facebook button (just under topic's name).
If you change default language for other languages (English, etc.) the button is simple dissapeare.


2) If you are registered member:


If you are using default language (Russian) you can see facebook button (just under topic's name).
If you change default language for other languages (English, etc.) the button is simple dissapeare, and you can see error link (https://www.facebook.com/plugins/error/api?code=100&message=action+must+be+one+of+the+following+values%3A+like%2C+recommend&hash=AQA8ooCrd6d-B4-2)


May be it's because of some VBSEO settings or something else, I don't know.

Please advise.

P.S. Please register in our portal and taste this issue.
Thank you.

Translations not works by now, because of Microsoft API limits reached.

Marcin Kalak
23-09-13, 09:59
OK, I see issue. Please send me a PM access details to Admin CP and FTP. I will check what is going on there :)

sergarch
23-09-13, 16:13
Thank you!
PM sent.
May be you'll check this issue http://www.vbenterprisetranslator.com/forum/vbet4-bug-reporting/3663-tables-doesnt-exist.html also?

;)

Marcin Kalak
24-09-13, 10:08
Quick will fix for the issue is:

Open file includes/vbenterprisetranslator_functions_url_tracking.php
Find code:


if (false !== strpos($address, '.css') || 0 === strpos($address, 'javascript:') || $address == '#' || vbet_isURLIgnored($address)) {

Replace it to code:


if (false !== strpos($address, '.css') || 0 === strpos($address, 'javascript:') || $address == '#' || vbet_isURLIgnored($address) || $address=='like') {


This should fix the issue. We will be add this fix in next release.
We are working on the second issue, but repair may not be so quick as this issue.

sergarch
24-09-13, 11:22
Thank you for outstanding good support!

The issue is fixed now :)

Marcin Kalak
25-09-13, 09:15
I'm glad I could help you.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations made by vBET 4.9.99