PDA

View Full Version : Solved vBET Manual translation minor issue



gopalmm2
05-08-12, 01:47
Hey guys. I have to say, I'm really impressed with the manual translation so far. Has worked in all the browsers that I use. The only problem for me is I can't seem to utilize the feature in the index page of my forum. It seems to work on all other pages, just not in the index home page (the Edit option doesn't come up in the index page). Is there any way to fix that issue? Or is that part of the issue since it's still in BETA testing stage?

Other than that, I don't seem to have encountered any major issues so far with the manual translation. So, great job :cool:!

Regards,
gopalmm2

vBET
05-08-12, 23:05
Most probably there is some conflict on youf forum. Please PM access details to Admin CP and FTP - I will check it on your side.

vBET
12-08-12, 12:23
Thanks for access details. I just logged in and enabled manual translations on your main page. Went to some translation and as I see Edit button shows and works properly. Please note that Edit button appears only under test which can be translated. If you have English forum and are on English page then there will be no Edit button under normal text - cannot translate from English to English (still you can see Edit button if some test is inside of langtitle or lang BBCode).

Please confirm that it is OK or describe in more details what is wrong. I tested it under Opera.

gopalmm2
12-08-12, 22:52
I'm using firefox and right now and the issue still exists. I also noticed that the main page also does not translate at all, and when it is not translated, the edit button also does not appear. Threads are being translated and edit button does appear there. This wasn't the case before I upgraded it. All I did to upgrade was to FTP the files and to over-write the xml. Is there something else I needed to do to upgrade? I think I upgraded from a 4.4.6 to the 4.5.1

gopalmm2
12-08-12, 23:08
OK, may be I wasn't clear, sorry. The issue is that the edit button along with translations disappear in the forum home page and the forum links. As soon as I go to a thread, the translation comes up and the edit button comes up too.

Sorry and thank you.

vBET
13-08-12, 12:26
OK - I see that main page is not translated. I will investigate this.

vBET
13-08-12, 16:47
Translation issue solved - it was configuration issue. I changed value of vBET > Database Cache > Stop looking after x failures - this made your cache was not used because too many missing translations (your Microsoft translation limit is already reached - when your cache fills more then you will be able to set lower value for this optimization parameter).

Right now I'm checking Edit button issue.

vBET
13-08-12, 17:18
I'm on the way. At this moment I know that Java Script is added and executed. Button doesn't show or at leas not in visible place - the issue can be related to some CSS - still working on it.

vBET
14-08-12, 18:35
OK. I found the reason and corrected it. Please check and confirm. I will set quick fix then - of course this will be included in next release.

gopalmm2
14-08-12, 18:42
It works! Awesome! :D :D :D

Thank you sooo much for your time and effort.

vBET
14-08-12, 18:57
OK - so it will be included in next release.

For quick fix:
1. Open file clientscript/vbet/vbet.script.js
2. Find:


var $edit_button = $("<span id='editCache_frame_button' style='position:absolute;'><div class='vbet_editCache_frame_button'>"+$('#vbet_edit').attr('title')+"</div></span>");
var new_top = offset.top+10;
var new_left = offset.left+25;

$('body').append($edit_button);
$edit_button.offset({ top: new_top, left: new_left});

3. Replace by:


var new_top = offset.top+10;
var new_left = offset.left+25;
var $edit_button = $("<span id='editCache_frame_button' style='position:absolute;z-index:1000;top: "+new_top+"px; left: "+new_left+"px;'><div class='vbet_editCache_frame_button'>"+$('#vbet_edit').attr('title')+"</div></span>");

$('body').append($edit_button);

basketmen
15-08-12, 08:17
OK - so it will be included in next release.

For quick fix:
1. Open file clientscript/vbet/vbet.script.js
2. Find:


var $edit_button = $("<span id='editCache_frame_button' style='position:absolute;'><div class='vbet_editCache_frame_button'>"+$('#vbet_edit').attr('title')+"</div></span>");
var new_top = offset.top+10;
var new_left = offset.left+25;

$('body').append($edit_button);
$edit_button.offset({ top: new_top, left: new_left});

3. Replace by:


var new_top = offset.top+10;
var new_left = offset.left+25;
var $edit_button = $("<span id='editCache_frame_button' style='position:absolute;z-index:1000;top: "+new_top+"px; left: "+new_left+"px;'><div class='vbet_editCache_frame_button'>"+$('#vbet_edit').attr('title')+"</div></span>");

$('body').append($edit_button);



Dear MichaƂ, what is above quick fix for actually?

my translated forumhome is showing the edit button, only sometime not showing the translated cache, even already translated before, so what should i do?

vBET > Database Cache > Stop looking after x failures, its stilll default

vBET
16-08-12, 12:16
Hello. This thread is for gopalmm2 issue. If you have new issue please just open new thread in this section, since this issue is already considered solved and confirmed by thread author.

Shortly - set the parameter to higher value or disable (0). If you need more help in this - please open your own thread for your own issue and we will be glad to help you :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2beta gives automatic translations