PDA

View Full Version : Solved Struggling to re-install VBET



hmspain
27-04-12, 22:59
When I enable VBET, the main VBET option page will NOT display (all the other options pages WILL display). Also, my forums will no longer display.

I'm running vBulletin 3.8.7 PL2.

I'm anxious to get VBET back online. I was forced to take it off my system since it was interfering with the thread display somehow.

Perhaps I should just buy the installation service and have you guys look at it...

hmspain
27-04-12, 23:00
I signed up for Google Translations API and entered the string as required in the VBET options.

hmspain
02-05-12, 16:19
I thought it might be that "execution order" problem we had in the past with our own plugin for authentication. I re-checked that our authentication plugin is execution order 1001 (it is), and vBulletin is 1000 (it is).

This is a different problem; the flags do not display, nothing displays, vBulletin just hangs :-). You ask vBulletin to list the new postings and just displays a white screen until you disable VBET.

vBET
05-05-12, 15:52
Hi. Sorry for response time - we had long weekend in Poland.

Please make sure that you have outgoing requests enabled in your system. vBET is using external translation providers if your system is blocking such requests then everything will just hang since it is blocked.

You can simply check it just by using out test file. Please see here for details how to check it: http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728
If you are blocked - the page hangs then you must contact your hosting provider and ask him to allow for outgoing http requests.
Please tell do you need more help :)

hmspain
09-05-12, 20:10
Bingo... here is the response:

Starting translation test for Google API v2
Test result:
Test error: couldn't connect to host
Connection time (ms): 21088.4240723

Is this saying I have a firewall issue connecting to Google's API? If so, please tell me what ports and what server I need to request :-).

hmspain
10-05-12, 16:03
My site is required to go through a proxy which is apparently preventing the connection to googleapis.com. Is there a way to set a proxy in VBET?

hmspain
10-05-12, 16:12
This may not help, but if I use the googleapis.php code modified to set a proxy, I get the following:

Starting translation test for Google API v2
Test result: { "data": { "translations": [ { "translatedText": "hello", "detectedSourceLanguage": "pl" } ] } }
Test error:
Connection time (ms): 196.223876953

Does this make any sense?

Simon Lloyd
14-05-12, 00:40
This may not help, but if I use the googleapis.php code modified to set a proxy, I get the following:

Starting translation test for Google API v2
Test result: { "data": { "translations": [ { "translatedText": "hello", "detectedSourceLanguage": "pl" } ] } }
Test error:
Connection time (ms): 196.223876953

Does this make any sense?
That shows that the translation took place ok :)

hmspain
14-05-12, 19:33
That shows that the translation took place ok :)

That is helpful, thank you! Now I need to find out why adding the proxy workaround to VBET does not solve my hang problem :-(.

r.dziadusz
14-05-12, 21:10
Hi
Please tell me if you need any further help with this issue

hmspain
18-06-12, 16:54
We just finished installing vBulletin 4.2 (upgrading from V3). vBulletin itself appears to be working fine.

We installed VBET is 4.4.6.

Googletest results in:

Starting translation test for Google API v2
Test result:
Test error: Failed to connect to 2001:4860:800a::5f: Network is unreachable
Connection time (ms): 150134.716064

Only blank pages display when a translation is requested, and the response is *very* slow.

My network team thinks all is well :-). If there something I can give them to point out the reason for my system NOT connecting to Google's API?

hmspain
18-06-12, 18:42
If you must run through a proxy, and my system does require a proxy setting... where in VBET would I set this?

hmspain
18-06-12, 19:00
curl_setopt($connection, CURLOPT_PROXY, 'http://proxy.mydomain.com:nnnn/');

added to vbenterprisetranslator_functions.php and vbenterprosetranslator_class_translator.php just above each CURLOPT_URL line appears to do the trick.

hmspain
18-06-12, 22:11
Next hurdle :-) ... the translation flags are not appearing on the posts. I posted something in Spanish... and as they say "nada". I was expecting the flags showing the original language, the translation to English, and the original text below. I keep going over and over and over the settings, but I can't seem to figure things out.

The flags now display at the top, and if you click on one, it translates the page to that language... progress. But the install is still not "right"...

m_jankowski
18-06-12, 22:44
Hi,
Could You please tell, just to be sure, if the proxy issue is solved.

About Your previous post - please tell what exactly is not working right now, and with what can I help You.
Also, please remember to open new thread for any new issue ;)

hmspain
20-06-12, 14:51
I need further help on this. By adding a CURL proxy line, I was able to get VBET to work, but the flags do not show on the individual postings (only at the top where I specified). If I click on one of the top flags, translation is performed.

The last time I got this working, I don't recall any special setting to get the flags to display in the individual postings. I'm stumped :-).

hmspain
21-06-12, 17:34
Hi,
Could You please tell, just to be sure, if the proxy issue is solved.

About Your previous post - please tell what exactly is not working right now, and with what can I help You.
Also, please remember to open new thread for any new issue ;)

I *think* I have my proxy issue resolved. Do you have other customers running through a proxy? What did they do to work around the issue? As far as I can tell, VBET has NO OPTION to set a proxy.

My "solution" may be causing other problems, so I need to know :-).

I inserted:

curl_setopt($connection, CURLOPT_PROXY, 'http://foo.com:nnnn/'); (the foo.com is my proxy, and the nnnn is the port number)

in front of every CURLOPT_URL line. Not very elegant.

---

At this point translation from the top flags works, but VERY slow response.

I DO NOT see any flags on the postings themselves.

vBET
23-06-12, 21:49
We never had any issue with proxies noted before. So maybe no one is using it with proxies or the issue is specific to your server configuration.

Great that you solved the issue. For new issue you already opened new thread and there I already send you answer. Please keep one issue per one thread - this will allow us to better manage the issues.

We are not aware of possible issues of your changes. As I wrote this is specific only to your server configuration. Just check how vBET behaves and how translation providers behaves.

Do you need more help with the issue? :)

vBET
07-07-12, 14:46
No response - considered the issue is gone. If not please write in this thread :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vBET Translator 4.9.2