PDA

View Full Version : Solved Outside pages not working on non base language, creates strange URL's



ctrenks
29-03-12, 15:09
I can go to my homepage and chnage the language ok, but pages in virtual folders create starnge broken URL's

Get USA friendly online casinos to enjoy USA playable slot machines (http://www.allfreechips.com/casino_guide/usa-online-casinos.html)

This page will break on a change?

ctrenks
29-03-12, 15:16
It appears it removes the "de" in casino_guide/page.html when changing.

I upgraded to VB4 and of course VBET446 about a month ago, and in webmaster tools i see a lot of 404 errors since. I have replaced all vbet files just to be sure there was no issue and I still see this.

r.dziadusz
29-03-12, 16:36
Hi
Becouse of your previos post and this issue - which is clearly .htaccess issue you can PM your access and I can check it on place if you want me to

ctrenks
29-03-12, 16:38
of course. note I have not changed fastCGI or any other files yet as I want to resolve this first.

ctrenks
29-03-12, 21:55
Seeing a large impact on google index pages.. this is looking worse that I first thought.

ctrenks
29-03-12, 21:59
ok, pages without the guide/ ie the de/ simply re-direct back to the english page?

such as Online casino banking information (http://www.allfreechips.com/casino-banking/online-casino-banking.html)

ctrenks
30-03-12, 19:30
I am getting very uneasy about this. I really want to have this resolved by the weekend.

r.dziadusz
30-03-12, 22:54
PM your access
By above I meant ftp access

ctrenks
30-03-12, 23:14
will do, ill setup an account and PM you

r.dziadusz
31-03-12, 15:39
Thank PM received checking on it

ctrenks
02-04-12, 15:44
ok, doing some debugging here.

If i add a die($url) into the function before or after

$url = preg_replace('/('.VBET_LANGUAGESMATCH.')\//','',$url);

I get this (i changed lang a few times)

BEFORE : /es/be/fr/casino_guide/100-percent-bonuses.html
AFTER: /casino_gui100-percent-bonuses.html

so its stripping all lanf params, even if they are not inside / /

ctrenks
02-04-12, 16:15
Its obvious were picking up de/ from casino_guide/ in the preg match here.

ctrenks
02-04-12, 18:29
Pages withough guide/ in them simply re-direct right back to the same non lang page as well. The index page works great ie Online Casino Guide | No Deposit Casinos | Online Casino Reviews and Casino Forum (http://www.allfreechips.com/) and the forums pages Allfreechips Casino Bonus Forum (http://www.allfreechips.com/phpBB2/)

There is something in this re-direct with the newer version that is not working right.

Can I deowngrade back to an older VBET version?

vBET
03-04-12, 12:07
Hi. I will support this thread since there is trouble with solution. Please give me some time to read whole story and check what is going on :)

vBET
03-04-12, 12:37
Hi. I saw that link to casino-banking are not working for translation. This is because you have it in virtual directroy - it is really redirected by this rule:

RewriteRule [.]*casino-banking/([a-z0-9-]+).html index.php?id=casino-banking/$1 [QSA]
And vBET rules are after that - at this moment language code included in URL is already miss. So we need to customize rules to make it working.

I will make copy of your .htaccess and work on it. In case if anything will stop working - just tell and we will give back your original .htaccess file.

vBET
03-04-12, 12:41
I will work using hints like for mod in other subdirectory included here: http://www.vbenterprisetranslator.com/forum/vbet4-integration-other-plugins/486-vbet-integration-instructions.html#post1785
But to start I need also access to your Admin CP. Please PM it to me :)

ctrenks
03-04-12, 14:16
I had the same before I upgraded is what is getting me on this one. PM'd login data for you.

Thanks,
Chris

vBET
03-04-12, 22:16
I used instructions from link above ant it is working. At this moment I made it only for page Casino Banks, but same way we can do it for others. Please check normal pages and tell does new issue didn't came. If not then we can add rules for rest of special 'logic' directories. To avoid too much rules I propose to change this one and add all possible logic directories in OR section. We can do it for you - just please check does new issues didn't came because of this change and give us green light for the rest :)

ctrenks
04-04-12, 02:17
I see that works. now I can do without that as I use one file (index.php) to generate all these pages so I would like to include vbet_outside=true and the lang ID into the index instead of the url if possible. then all I need to resolve is the fact the rewrite removes the de/ from casino_guide/

If that seems to make sense with you as well we can do that easily. If its better for re-writes thats fine as well as long as we resolve the de/ issue. Looking at my indexed pages in google now for domain/de/ its looking real bad with some strange URL's

r.dziadusz
05-04-12, 01:29
Your .htaccess has been edited, could you please confirm everything works fine?

ctrenks
05-04-12, 02:13
yes it does appear to be working correctly :)

ctrenks
05-04-12, 02:15
Do we still need all these rules at the end as well then?

RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ index.php?language=$1&vbet_outside=true [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ $2?language=$1&vbet_outside=true [L,QSA]

#This rule must be in each directory which have to be supported (without forum directory itself)
RewriteCond %{QUERY_STRING} !vbet_outside=true
RewriteRule ^(.*)$ $1?vbet_outside=true [L,QSA]

ctrenks
05-04-12, 04:19
OK, got it noe I believe, I was able to remove the rewite condition and enable fastCGI.. all looks like it is now correct.

Thanks again for the work!

r.dziadusz
05-04-12, 20:17
You welcome:)
I will mark this thread solved. However if you havy any further questions I will re-open it. For any other issue please open new thread

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages thanks to vBET Translator 4.9.2beta