PDA

View Full Version : Solved translation does not work



mza3et
21-03-12, 11:55
[B]I have installed VBET 3.5.4 properly, but translation does not work at all

r.dziadusz
22-03-12, 17:35
Hi
Could you please show me your .htaccess file? And please tell me if you are using vBSEO

mza3et
23-03-12, 10:06
htaccess

## Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.digifog\.com


RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]








#RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/index.php [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]



RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

Yes, I use vbseo 3.6

mza3et
23-03-12, 10:18
[B]Page appear blank . Even the original text does not appear

r.dziadusz
23-03-12, 21:36
Ok, it looks ok, could you please tell me which translatioan API are you using?
Ande pease make test which ou can find in you downloaded files in directory:
dowladed file / donotupload /
And for each transaltion please upload selected file to your forum root directory:
googleapiv2test
microsoftbyazuretest
microsofttest

If you are using apertium api please try to turn it off and check you forum again

mza3et
24-03-12, 17:08
same problem

Starting translation test for Microsoft translations API
Test result: "Hello"
Test error:
Connection time (ms): 100.077148438


Full token:
{"error":"invalid_request","error_description":"ACS90011: The required field \u0027client_id\u0027 is missing. \r\nTrace ID: 60fd9375-96fb-4e9b-a0db-c78403f65965\r\nTimestamp: 2012-03-24 15:51:43Z"}

Test result: "ArgumentException: No bearer information found in the token : ID=3641.V2_Json.Translate.40AF2BCD"
Test error:
Connection time (ms): 42.4240722656

r.dziadusz
24-03-12, 18:55
Ok
If you are using microsoft by azure, just for test remove:
Microsoft Comercial Translation API key by Azure and
Microsoft Comercial Translation API secret by Azure and check than

Most probably youe have insert wrong value of "client_id" wchich stands for vBETs "Microsoft Comercial Translation API key" please chceck it carefully

r.dziadusz
14-04-12, 16:48
No answer, consider it solved, please feel free to ask question and I will reopen this thread

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vB Enterprise Translator 4.9.99