PDA

View Full Version : Solved need help



scott
03-01-10, 01:41
hi,
on my forum if i translate any section, or language, then click the
hyper link to go back to main site, like i click Magical Pro Teachings on this links :-
Hello Magicians & Magic Introductions - Magical Pro Teachings (http://www.magicalproteachings.com/hello-magicians-magic-introductions/)

Magical Pro Teachings > New Arrivals Start Here > Hello Magicians & Magic Introductions

instead of going here :-
Magical Pro Teachings - Magic (http://www.magicalproteachings.com/)

it always takes me to VBad main page here :-
Magical Pro Teachings (http://www.magicalproteachings.com/index.php)

how can i fix please???

vBET
03-01-10, 02:07
I went to link you gave and click on link to main page in navbar - it goes to page without inxed.php in URL...

scott
03-01-10, 02:33
try in another language ;)

soon as you translate it goes here say :-
Magical Pro Insegnamenti (http://www.magicalproteachings.com/it/)

that was supposed to be :-
Magical Pro Teachings (http://www.magicalproteachings.com/index.php)

then click forum link there, and it goes back to same page here :-
Magical Pro Teachings (http://www.magicalproteachings.com/index.php)

also like if you was here :-
Card Magic - Magical Pro Teachings (http://www.magicalproteachings.com/card-magic/)

then translated, and click the link :-
Magical Pro aral

in the Magical Pro aral > Card & Coin Magic
it will go to again :-
Magical Pro aral (http://www.magicalproteachings.com/tl/)

well this link :-
Magical Pro Teachings (http://www.magicalproteachings.com/index.php)

1 other question, what does it mean when someone posts with borders like this please :-

http://img691.imageshack.us/img691/9095/aforum.jpg (http://img691.imageshack.us/i/aforum.jpg/) http://img691.imageshack.us/img691/aforum.jpg/1/w320.png (http://g.imageshack.us/img691/aforum.jpg/1/)

vBET
03-01-10, 16:17
Sorry - there is lot of thinking shortcuts in your description. I'm not able to reproduce it on your forum.

I do not understand first part - You are writing to go some place and that it should be other place that it is... Also you wrote that is suppose to be X and it is X... I'm confused here.

2nd part is also confusing, because you are telling me to go to any translation and then click something what doesn't exists anymore since it was translated and I'm not even able to figure out where it should be because you are giving me already translated text in unknown language.

Please describe it in other way. Exactly what do you mean - with exact link where to start, quote of link which should be clicked there (give me exact text, which I will see under the URL so I will be able to find it on your page). And what is wrong with final page.

About the box - this means that text was written in other language. You will find description when go mouse over arrow between flags. Also you can see the original text when click down arrow :)

scott
03-01-10, 16:48
ok so the box is a good thing then :)

ok lets make it easier :)
ok its hard as your site does not leave full address, so ill leave a gap in between the addresses

When i am here :-
http://www.magical ---Gap--- proteachings.com/

If i translate to say italian, it takes me to here :-
http://www.magical ---Gap--- proteachings.com/it/

the real address for the above is the vbad main page :-
http://www.magical---Gap--- proteachings.com/index.php

now if you click forum on vbad, it takes you right back to :-
http://www.magical ---Gap--- proteachings.com/index.php

it doesnt go to forum here :-
http://www.magical ---Gap--- proteachings.com/

NOW on here im at :-
vBulletin Enterprise Translator (vBET) > vBET Plugin/Mod > Troubleshooting

now if i clicked :-
vBulletin Enterprise Translator (vBET) >

that would take me here to main page :-
http://www.vbenterprise ---Gap--- translator.com/forum/

now like i said above on my site, if i did that, it would take me to the vbad front page here :-
http://www.magical ---Gap--- proteachings.com/index.php

instead of my main page here :-
http://www.magical ---Gap--- proteachings.com/

hope this helps, if not ill do afew screenshots thanks

vBET
03-01-10, 18:10
It is easier to use code BBcode ;) I will check it in a minute.

scott
03-01-10, 18:24
ya i know :)
but i cant use BBcode, or even know how sorry :(
im not good at this stuff

vBET
03-01-10, 18:27
ok so the box is a good thing then :)

ok lets make it easier :)
ok its hard as your site does not leave full address, so ill leave a gap in between the addresses

When i am here :-
http://www.magical ---Gap--- proteachings.com/

If i translate to say italian, it takes me to here :-
http://www.magical ---Gap--- proteachings.com/it/

the real address for the above is the vbad main page :-
http://www.magical---Gap--- proteachings.com/index.php

now if you click forum on vbad, it takes you right back to :-
http://www.magical ---Gap--- proteachings.com/index.php

it doesnt go to forum here :-
http://www.magical ---Gap--- proteachings.com/

Where to click? Give me location? Give me link text or describe image under which the link exist. I'm there and I do not know what to do... 'now if you click forum on vbad' - what is 'forum on vbad'? Where I will find it being at:


http://www.magicalproteachings.com/it/



NOW on here im at :-
vBulletin Enterprise Translator (vBET) > vBET Plugin/Mod > Troubleshooting

now if i clicked :-
vBulletin Enterprise Translator (vBET) >

that would take me here to main page :-
http://www.vbenterprise ---Gap--- translator.com/forum/

now like i said above on my site, if i did that, it would take me to the vbad front page here :-
http://www.magical ---Gap--- proteachings.com/index.php

instead of my main page here :-
http://www.magical ---Gap--- proteachings.com/

hope this helps, if not ill do afew screenshots thanks

I understood your description about our site - just use navbar to go back to main page. But I do not understand what you are describing about your page - please go to link which you point me on your site. Click what you have to click to see your issue, and then describe me exactly what you clicked. Sorry but I do not understood 'click forum on vbad'. I need exact link text, or describe image under which link exists (position and look).

I know what do you mean by returning to URL without index.php, but as I see it works ok (it returns to URL without index.php), so please give me information on what exactly I have to click being on described page to see this behavior.

scott
03-01-10, 18:58
go anywhere in main site here :-
Magical Pro Teachings - Magic (http://www.magicalproteachings.com)

translate to italian in drop flags

that then takes you to here, which is vbad :-
http://www.magical -- GAP-- proteachings.com/index.php

but its on this address here in italian :-
http://www.magical -- GAP-- proteachings.com/it/

and not on this vbad address :-
http://www.magical -- GAP-- proteachings.com/index.php

Anyway now click forum on the vbad to go back to main, and it wont, it takes you back to the vbad front page here :-
http://www.magical -- GAP-- proteachings.com/index.php

the same happens when you click the links
NOW on here im at :-
vBulletin Enterprise Translator (vBET) > vBET Plugin/Mod > Troubleshooting

now if i clicked :-
vBulletin Enterprise Translator (vBET) >

that would take me here to main page of this site :-
http://www.vbenterprise ---Gap--- translator.com/forum/

now like i said above on my site, if i did that, it would take me to the vbad front page here :-
http://www.magical ---Gap--- proteachings.com/index.php

instead of my own main page here :-
http://www.magical ---Gap--- proteachings.com/

hope you understand now, if not ill try more to help

vBET
05-01-10, 02:25
Ok so I went to


http://www.magicalproteachings.com/magic-shop-tricks-effects-dvd-reviews/


Then I used Italian flag (I checked booth - drop down menu and from top) and I was here:


http://www.magicalproteachings.com/it/magic-shop-tricks-effects-dvd-reviews/


According to your description it should be wrong address with index.php in it, but it is all alright.
I also tested it for your forum main page.

Please go yourself with steps which you are describing. I made it and I do not see the issue. What I made wrong?

vBET
05-01-10, 02:28
Wait. I think I finally got it. You have 2 different sites under those links:


http://www.magicalproteachings.com/index.php
http://www.magicalproteachings.com/


Is it right?

scott
05-01-10, 03:16
no thats not it lol :)
if you dont use the word gap in links, youll go where i said
ill try to video my screen to show you

yes theres 2 i think, but getting from index to other will not go

vBET
05-01-10, 17:28
vBET is suppressing index.php, because mostly it is same as / and it is better for SEO to keep only one of those.
When I'm on your page I see that there is other content with link having index.php and without it.

1st thing - do you really need it?
2nd thing - try this quick fix for you:
Remove/Comment code below in /includes/vbenterprisetranslator_functions_url.php


if ($index = strpos($address, 'index.php') && false === strpos($address, '/archive/')) {
$address = str_replace('index.php','',$address);
}

After this please test does everything is OK now.

If it is really needed and this quick fix is working, then we can make it configurable in next version.

scott
05-01-10, 17:55
ok ill try that thanks ;)

vBET
07-01-10, 05:27
Does it work?

Does it is really needed (should it be configurable in next release)?

scott
12-01-10, 14:40
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@magicalproteachings.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.magicalproteachings.com Port 80

also in error logs it says :-
Premature end of script headers: vbenterprisetranslator_seo.php

so what do i need to do??

scott
13-01-10, 02:05
also this is what my provider has done, and said :-
We had no choice but to suspend the account magicalproteachings.com on
your vps temporarily to keep both your vps and the entire hardware node
from crashing as these processes are over loading the server. Since the
cpu demand on your vps is more than what is available on your vps, you
may notice some slowness on your vps. Please try to reduce the resource
usage of your websites/scripts.

here the vbet info :-
The high apache traffic.

52-0 - 0/0/1 . 0.00 482 372 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/mt.gif HTTP/1.1
53-0 - 0/0/1 . 0.00 470 436 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/hi.gif HTTP/1.1
55-0 - 0/0/1 . 0.00 447 437 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/id.gif HTTP/1.1
56-0 - 0/0/1 . 0.00 457 436 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/ko.gif HTTP/1.1
57-0 - 0/0/1 . 0.00 481 370 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/mk.gif HTTP/1.1
58-0 - 0/0/1 . 0.00 472 434 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/no.gif HTTP/1.1
59-0 - 0/0/1 . 0.00 446 434 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/ms.gif HTTP/1.1
60-0 - 0/0/1 . 0.00 456 433 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/pl.gif HTTP/1.1
63-0 - 0/0/1 . 0.00 460 430 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/tr.gif HTTP/1.1
64-0 - 0/0/1 . 0.00 476 431 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/sw.gif HTTP/1.1
65-0 - 0/0/1 . 0.00 455 430 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/sv.gif HTTP/1.1
66-0 - 0/0/1 . 0.00 462 429 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/pt.gif HTTP/1.1
67-0 - 0/0/1 . 0.00 451 236 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/sr.gif HTTP/1.1
68-0 - 0/0/1 . 0.00 449 238 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/vi.gif HTTP/1.1
69-0 - 0/0/1 . 0.00 477 229 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /cb/misc/navbits_start.gif HTTP/1.1

vBET
13-01-10, 23:59
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@magicalproteachings.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at Magical Pro Teachings - Magic (http://www.magicalproteachings.com) Port 80

also in error logs it says :-
Premature end of script headers: vbenterprisetranslator_seo.php

so what do i need to do??

Does it happened after code changes which I propose you?

vBET
14-01-10, 00:05
also this is what my provider has done, and said :-
We had no choice but to suspend the account magicalproteachings.com on
your vps temporarily to keep both your vps and the entire hardware node
from crashing as these processes are over loading the server. Since the
cpu demand on your vps is more than what is available on your vps, you
may notice some slowness on your vps. Please try to reduce the resource
usage of your websites/scripts.

here the vbet info :-
The high apache traffic.

52-0 - 0/0/1 . 0.00 482 372 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/mt.gif HTTP/1.1
53-0 - 0/0/1 . 0.00 470 436 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/hi.gif HTTP/1.1
55-0 - 0/0/1 . 0.00 447 437 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/id.gif HTTP/1.1
56-0 - 0/0/1 . 0.00 457 436 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/ko.gif HTTP/1.1
57-0 - 0/0/1 . 0.00 481 370 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/mk.gif HTTP/1.1
58-0 - 0/0/1 . 0.00 472 434 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/no.gif HTTP/1.1
59-0 - 0/0/1 . 0.00 446 434 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/ms.gif HTTP/1.1
60-0 - 0/0/1 . 0.00 456 433 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/pl.gif HTTP/1.1
63-0 - 0/0/1 . 0.00 460 430 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/tr.gif HTTP/1.1
64-0 - 0/0/1 . 0.00 476 431 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/sw.gif HTTP/1.1
65-0 - 0/0/1 . 0.00 455 430 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/sv.gif HTTP/1.1
66-0 - 0/0/1 . 0.00 462 429 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/pt.gif HTTP/1.1
67-0 - 0/0/1 . 0.00 451 236 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/sr.gif HTTP/1.1
68-0 - 0/0/1 . 0.00 449 238 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /images/vbet/flags/vi.gif HTTP/1.1
69-0 - 0/0/1 . 0.00 477 229 0.0 0.00 0.00 120.28.64.76
magicalproteachings.com GET /cb/misc/navbits_start.gif HTTP/1.1

Please see here:
http://www.vbenterprisetranslator.com/forum/general-discussions/284-vbet-loads.html

Shortly:
1. vBET is taking resources only for translated page - additional CPU usage is because of additional traffic which you get to those pages.
2. You can do several things which can made vBET better for performance: http://www.vbenterprisetranslator.com/forum/general-discussions/243-vbet-performance.html
3. This Sunday will be released vBET 3.3.0 with many performance improvements.

Also please open new threads for new issues - this will allow us for better management of issues. At this moment this thread have 2-3 different issues and I have no idea can I close it or what ;)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.99 gives automatic translations