View Full Version : Solved Thread content not being translated

27-12-11, 07:40
when I'm inside a thread and click on a language my thread content is not being translated but everything else is?

Problem Resolved

28-12-11, 04:55
Not resolved, sometime it translates the thread content and sometimes it only translates the thread title only.

PS. Why does it take so long for support?

As you can see from the image everything gets translated except the text?!?

28-12-11, 11:16
Pleae read this threads about partial tranlation and untranslated text:
http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-3.html#post10876 and http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-3.html#post10970

28-12-11, 16:27
It never translated from the start, I think that the other problems (my other threads) should be resolved first before reaching this decision.

Microsoft api test:

Starting translation test for Microsoft translations API
Test result: "Welcome to"
Test error:
Connection time (ms): 114.572265625

Of course I'm getting a token error like I stated on my other post on my Microsoft Azure test:

Starting test for Microsft Translation API by Azure

Full token:
{"error":"invalid_request","error_description":"ACS90011: The required field \u0027client_id\u0027 is missing. \r\nTrace ID: 17e65ab5-5618-4277-ab3c-d9d3ac7a6368\r\nTimestamp: 2011-12-28 15:33:26Z"}

28-12-11, 19:41
Ok lets start with token error

09-01-12, 07:53
Content is still not being translated!!

09-01-12, 12:43
Right now, as we know that your microsoft by azure is not working becouse of your php version, try to disable Microsoft by Azure - just left both of its settings blank.

Here is why I asked to do it:
vBET tried to use Microsoft by Azure but while it didn't work, vBET doesn't get a receive data, so couldn't set it as disabled automatically. If microsoft by azure is not set as disable vBET will try to use it again.

Please also take a look on this post:
click2 (http://www.vbenterprisetranslator.com/forum/vbet-announcements/2646-vbet-4-4-5-3-5-3-released.html#post11514)

12-01-12, 05:02
Microsoft is disabled but the content is still not being translated just the title?!?
You have access to my ftp, can you please check it out?
Best regards

12-01-12, 19:37
Ok I will browse it through:

Microsoft is disabled
Setting Microsft API(both of them - no just one by Azure) as disableb won't make anny diference.
Right now I make blank Microsoft Comercial Translation API key by Azure(BETA) and Microsoft Comercial Translation API secret by Azure(BETA)
and it seems to work, please check it:

Also all fixes are implemented in latest vBET releas, so you can just update vBET:)

13-01-12, 10:37
I tried again and the content is not being translated, this is what I do -> I click on a specific thread (showthread) and I press the English Language the result is that the thread title in post 1 gets translated in English but its content remains in its original language(does not translate), even if I press English on the index page then go to any specific thread the content will not be translated but just the title.

PS. If I update vbet won't I have the invisible icons problem again in the archive?

Thank You!! :)

13-01-12, 14:50
I implemented those quickfixes for you - withour updating vBET.
If you do update your vBET you will have to modify code again, becouse do not oficialy supports older version of vBulletin

I checked and you reach your limits in both Microsoft and Apertium, like it is said here (http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-3.html#post10970)
You've reached your limits so text is not translated, but once translated text like thread title will show up.

Please note you use only free translations API's you can always use paid ones: Google API translation v2, and paid subscription of Microsoft Trabnslation by Azure(if you update your PHP)

14-01-12, 06:43
Hi, Can you add the additional modifications steps to the already posted one by vBET here: http://www.vbenterprisetranslator.com/forum/vbet-integration-other-plugins/810-vbet-vbulletin-3-6-a.html , the guide wasn't updated. I paid an additional fee to make this compatible, when an update comes out I'll mod it myself without bothering anyone. :)

To use the Google V2 I have to update my PHP? I thought it was for Microsoft only?!?

PS. Once translated shouldn't the translated words remain in the cache?

Thank You!!

14-01-12, 13:32
It's updated:

To use the Google V2 I have to update my PHP? I thought it was for Microsoft only?!?
Right now I'm reimplementing function, that it will not use json_translate so you could use it without updating your PHP

PS. Once translated shouldn't the translated words remain in the cache?
vBET is caching whole phrases. But yes once translated text stays in the cache.

18-01-12, 17:24
Here is quicx fix for your issue:
FIX (http://www.vbenterprisetranslator.com/forum/vbet-announcements/2734-vbet-4-4-6-3-5-4-released.html#post11567)

Now you will be able to use Microsoft Translation by Azure even with older php version

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vB Enterprise Translator 4.9.99