PDA

View Full Version : Solved not translating pages completely in vbulletin 4.1.8



begin
21-11-11, 17:45
when i upgrade to vbulletin 4.1.8 , vbet 4.4.4 is not translating pages completely.

r.dziadusz
21-11-11, 21:01
Hi
Could you please provide me more information:
-which translation API are you using (Google 1(free), Microsoft, Google 2(paid))
-please run test for app APIs that you use: TESTS (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729)

r.dziadusz
30-11-11, 11:50
No answer, I considered it solved, If you have any questions about this issue I will remark it open, for any other please open new thread

begin
07-12-11, 05:00
my translate page do not translate content when viewing . only static text on forum is translate .

自動車保険 (http://www.insurancemaking.com/ja/auto-insurance/)

begin
07-12-11, 05:04
my translate page do not translate content when viewing . only static text on forum is translate .
i used Microsoft and Apertium Translation .


http://www.insurancemaking.com/microtrans.php

r.dziadusz
07-12-11, 19:12
In the test I link you was no test for google apertium (this had been created after vBET with Microsoft via Azure was created)
Can you please run test for Microsoft by Mazure, you can find it in :
download files -> do-not-upload -> tools -> microsoftbyazuretest.php
Just upload it into your forum root folder, and type destination URI into your web browser

begin
09-12-11, 03:20
Starting test for Microsft Translation API by Azure

Full token:
{"error":"invalid_request","error_description":"ACS90011: The required field \u0027client_id\u0027 is missing. \r\nTrace ID: 65630e6f-adc7-467b-afd9-7506f26eca2f\r\nTimestamp: 2011-12-09 02:17:06Z"}

Test result: "ArgumentException: No bearer information found in the token : ID=3737.V2_Json.Translate.16E26BDE"
Test error:
Connection time (ms): 130.547119141

how to repair this ?

r.dziadusz
09-12-11, 12:30
Most probably you didn't insert anything in youradmincp -> vBET -> Translations Providers->Microsoft Comercial Translation API key by Azure(BETA)

To use Microsoft Translation via Azure you have first subscribe for Mcrosoft Translation API (also free option) in here click (http://go.microsoft.com/?linkid=9782667)
and then register you aplication here, by filling brackets(there is a field client name which you have to use in Microsoft Comercial Translation API key by Azure(BETA))

begin
13-12-11, 17:23
i'm sorry, i registered Microsoft API and application but i can not define what is API number of Azure.
Please tell me details.

r.dziadusz
13-12-11, 20:32
Here you go:
Your Microsoft Comercial Translation API secret by Azure is your "Client Secret" - starting with GSBlBL...
Your Microsot Comercial Translation API key by Azure is your "Client ID" - starting with ins...

Also i deleted your Image, becouse somebody else might use your client id/client secret, hope you don't mind:)

begin
14-12-11, 09:34
it is not well for me. Do you need my admin account access to forum and Microsoft API ?

http://www.insurancemaking.com/trouble/trans4.jpg

microsoftbyazuretest.php test result is:


Starting test for Microsft Translation API by Azure

Full token:
{"error":"invalid_request","error_description":"ACS90011: The required field \u0027client_id\u0027 is missing. \r\nTrace ID: 17beac4d-d6ee-4b61-8e51-998aefa90122\r\nTimestamp: 2011-12-14 08:27:56Z"}

Test result: "ArgumentException: No bearer information found in the token : ID=3737.V2_Json.Translate.2472B68D"
Test error:
Connection time (ms): 128.82421875

http://insurancemaking.com/microsoftbyazuretest.php

r.dziadusz
14-12-11, 13:32
Yes please PM access details to your admincp, and ftp (have to run some specyfinc test if something will still be wrong) and access to Microsoft API to check if everything is ok

begin
15-12-11, 11:05
Yes please PM access details to your admincp, and ftp (have to run some specyfinc test if something will still be wrong) and access to Microsoft API to check if everything is ok

I sent, thank you

r.dziadusz
15-12-11, 15:22
I'm checking it

r.dziadusz
18-12-11, 08:11
Is the problem solved? IF you have questions about this issue please ask, for any other please open new thread

mario06
26-12-11, 17:22
Starting test for Microsft Translation API by Azure

Full token:
{"error":"invalid_request","error_description":"ACS90011: The required field \u0027client_id\u0027 is missing. \r\nTrace ID: 17beac4d-d6ee-4b61-8e51-998aefa90122\r\nTimestamp: 2011-12-14 08:27:56Z"}

Test result: "ArgumentException: No bearer information found in the token : ID=3737.V2_Json.Translate.2472B68D"
Test error:
Connection time (ms): 128.82421875
I'm getting the same error

r.dziadusz
27-12-11, 14:32
please use this code for test:


<?php
require_once('./global.php');

function get_token(){
global $vbulletin;
$obj_connection = curl_init();
$arr_query_bits = array (
'grant_type' => 'client_credentials',
'scope' => 'http://api.microsofttranslator.com',
'client_id' => $vbulletin->options['vbenterprisetranslator_Microsoft_key'],
'client_secret' => $vbulletin->options['vbenterprisetranslator_Microsoft_secret']
);
$str_query = http_build_query($arr_query_bits);

curl_setopt($obj_connection, CURLOPT_URL, 'https://datamarket.accesscontrol.windows.net/v2/OAuth2-13');
curl_setopt($obj_connection, CURLOPT_HEADER, 0);
curl_setopt($obj_connection, CURLOPT_FOLLOWLOCATION, 1);
curl_setopt($obj_connection, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($obj_connection, CURLOPT_POSTFIELDS, $str_query);
curl_setopt($obj_connection, CURLOPT_SSL_VERIFYPEER, FALSE);
curl_setopt($obj_connection, CURLOPT_POST, TRUE);
print_r('Full token: </br>'.curl_exec($obj_connection).'</br></br>');
$token = json_decode (curl_exec($obj_connection));
curl_close($obj_connection);
return 'Authorization: Bearer '.$token->{'access_token'};
}

echo 'Starting test for Microsft Translation API by Azure<br/><br/>';
$connection = curl_init();
curl_setopt($connection, CURLOPT_URL, 'http://api.microsofttranslator.com/V2/Ajax.svc/Translate?&from=pl&to=en&text=Witaj!');
curl_setopt($connection, CURLOPT_HEADER, 0);
curl_setopt($connection, CURLOPT_FOLLOWLOCATION, 1);
curl_setopt($connection, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($connection, CURLOPT_SSL_VERIFYPEER, false);
curl_setopt($connection, CURLOPT_HTTPHEADER, array(get_token()));
$str_response = curl_exec($connection);
$time = microtime(true) * 1000;
$result = curl_exec($connection);
$time = microtime(true) * 1000 - $time;
echo 'Test result: '.$result."<br/>\n";
echo 'Test error: '.curl_error($connection)."<br/>\n";
curl_close($connection);
echo 'Connection time (ms): '.$time;


?>

wowglider.de
08-04-12, 11:29
I don't understand. I don't find the correct APIs it's a horror! Why you dont put Images up? Or ANY Tutorial on how to fill the correct APIs in...

r.dziadusz
09-04-12, 00:05
Ok here it is:
1.) Go to : Microsoft Translator | Windows Azure Marketplace (http://go.microsoft.com/?linkid=9782667)
2.) Login/Register
3.) Choose youre subscription:
http://img24.imageshack.us/img24/3622/70988075.jpg (http://imageshack.us/photo/my-images/24/70988075.jpg/)
4.) Go to: https://datamarket.azure.com/developer/applications/
5.) Click the "REGISTER" button
6.) Fill all required fields and click "CREATE" button.
7. Get the values from ClientID and Secret - bordered-insert it in your admincp:
ClientID -> Microsoft Comercial Translation API key by Azure,
Secret ->Microsoft Comercial Translation API secret by Azure
http://img688.imageshack.us/img688/1048/24962926.jpg (http://imageshack.us/photo/my-images/688/24962926.jpg/)

wowglider.de
14-04-12, 11:32
Thank you, thats excactly what i wanted (!!) Its working now, thanks.

r.dziadusz
14-04-12, 15:26
You welcome I will mark this thread as solved, if you still have any questions about this issue I will mark it open again

hanhthai
08-11-12, 10:02
Ok here it is:
1.) Go to :Microsoft Translator | Windows Azure Marketplace
2.) Login/Register
3.) Choose youre subscription:
4.) Go to: datamarket.azure.com/developer/applications/
5.) Click the "REGISTER" button
6.) Fill all required fields and click "CREATE" button.
7. Get the values from ClientID and Secret - bordered-insert it in your admincp:
ClientID -> Microsoft Comercial Translation API key by Azure,
Secret ->Microsoft Comercial Translation API secret by Azure


Big thank ;)
It works perfect for me

Marcin Kalak
08-11-12, 16:11
I'm glad that you found the information.

hanhthai
09-11-12, 04:54
anyone help me how to get a google translation API code?

Marcin Kalak
09-11-12, 12:34
To get Google API v2 Key log into your google account in https://code.google.com/apis/console/. Go to API Access, and here should be the API key. If he is not here, then turn on Translate API in Services and configured your Billing.

hanhthai
12-11-12, 05:43
To get Google API v2 Key log into your google account in https://code.google.com/apis/console/. Go to API Access, and here should be the API key. If he is not here, then turn on Translate API in Services and configured your Billing.

Thank you,
But this is paid service. May i get it for free?

Marcin Kalak
12-11-12, 12:17
No, Google Translate API is only a paid service.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vB Enterprise Translator 4.9.99