View Full Version : Open All translations stopped working - all threads are blank when a flag is clicked

30-10-11, 06:31
I didn't make any changes. I am on vBulletin 3.6.8 with vBET3.4.1.

Did Google change its Translation API or something?

30-10-11, 06:45
I just upgraded to vBET 3.5.2 now my translation page is completely blank. What am I missing?

30-10-11, 07:17
Ok. I got this running googletest.php. Looks like I am suspended by Google

Starting translation test for Google API v1
Test result: {"responseData": null, "responseDetails": "Suspected Terms of Service Abuse. Please see http://code.google.com/apis/errors", "responseStatus": 403}
Test error:
Connection time (ms): 566.118164062

30-10-11, 07:21
My Microsoft API test seems good. Shouldn't my vBET still translate with Microsoft API?

Starting translation test MS
Test result: "Hello"
Test error:
Connection time (ms): 492.813964844

30-10-11, 09:10
Yes it could but the test you did can be misleading, becouse it test translation only in one second
Please could you check:
- did you set
admincp -> vBET -> Translation Providers -> Use Google Only : NO
- did you update = upload again folder upload-once -> vbet_translation_options if no please, do that

30-10-11, 18:46
Yes I did 'Use Google Only: NO' and I did upload vbet_translation_options folder.

Now if I click a flag, I get the following error:

Fatal error: Call to undefined function save_settings() in /home/smera/public_html/forums/includes/vbenterprisetranslator_class_translator.php on line 28

I vaguely remember I started getting above error after I made some changes based on FAQ recommendation on performance. Feel like it might be related to memory cache or something

31-10-11, 09:36
Did you remove/edit any files, (other than for vbseo integration)
Could you please tell me which steps (of FAQ performance hint) were made?
If you don't remember any of this please PM me your access detailes I will check it on your server

31-10-11, 16:37
I remember the problem occurred after I changed Memory Cache from None to something. But now even though I changed the Memory Cache back to 'None' the problem still exists

I did not remove/edit any files, (other than for vbseo integration)

01-11-11, 14:11
The line of the code where fatal error occurs seems to be the following. Can I get some answers?

save_settings(array ('vbet_provider_availability_'.$provider => $availability));

02-11-11, 12:21
You error appears becouse of the system can't find function save_settings which is vBulletin function and should be in adminfunctions_options.php right now i don't know why it can't be found, please reconsider reupload all vBet files, or please PM me access details, and I will check it.
It's hardly possible this error was provoked by changing Memory Cache value

02-11-11, 13:50
Ok. It would appear to me this is probably why: My adminfunctions_options.php does not have save_settings because I am on vBulletin 3.6.8. vBulletin 3.8.x would have it.

vBET worked for me before when I was on vBET 3.4.1 which does not use save_settings.

Now that I upgraded to vBET 3.5.2 and I am running into the problem with save_settings.

So what do you think we should do?

02-11-11, 14:20
Updating vBulletin to latest version (3.8.7) would solve it

03-11-11, 13:19
My vBulletin is highly customized and integrated with other software. Upgrading vBulletin is not an option.

Is there any other way to make vBET work for me?

03-11-11, 14:40
Yes. You need to made code changes and change calling of save_settings to other function/code which will save the setting. vBulletin 3.6 is not officially supported, but we can do it official in next release (one if checking does function exists). So we will check how in this old version vBulletin saves settings and we will give you hints about code changes. Until then - just please disable vBET.

03-11-11, 15:24
This is NOT TESTED solution. Please check it and confirm does it help. If yes then we will include it in next release. We cannot test because we do not support officially so old version of vBulletin and we do not have testing forum for this one.

Quick fix:
1. Open file /includes/vbenterprisetranslator_class_translator.php
2. Find:

save_settings(array ('vbet_provider_availability_'.$provider => $availability));

3. Replace by:

if (function_exists('save_settings')) {
save_settings(array ('vbet_provider_availability_'.$provider => $availability));
} else {
global $vbulletin;
UPDATE " . TABLE_PREFIX . "setting
SET value = '" . $vbulletin->db->escape_string($availability) . "'
WHERE varname = '" . $vbulletin->db->escape_string('vbet_provider_availability_'.$provider) . "'

05-11-11, 04:32
Thanks. With the change the error is gone but it does not translate anymore. Whatever language flag I click it still displays English

05-11-11, 15:10
It is not because of the change. This is because you reach your limits in translation providers.
Please read this for more info: http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-3.html#post10876

05-11-11, 19:23
Ok, in which case I will just wait for Google or Microsoft miraculously become available again? Or purchase Google Translate API 2?

06-11-11, 11:17
vBET will automaticaly checked which API is available in every 10 minutes, and switch it on, also if you are sure you didn't reach your limits - f.e. you've translated only one page and nobody else was on forum you could write to microsoft - mtcont@microsoft.com, maybe it appears becouse of Microsoft internal error, but most probably you've just normaly reached your limits
Also please note that vBET supports Google (paid) translation v2 API and tests new api: Apertium (click for more info (http://www.vbenterprisetranslator.com/forum/vbet-announcements/2543-apertium-another-translation-api-will-supported-vbet.html#post11064))

08-11-11, 21:21
Do you still need help with this issue? If not I will marked it solved, for any other issue please open new thread

10-11-11, 02:38
could you give some instruction on how to test Apertium?

10-11-11, 23:27
right now we are testing Apertium, it will be usable in next vBET release

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations made by vBET Translator 4.9.99