PDA

View Full Version : Solved Unable to disable vBET? (Urgent)



Simon Lloyd
27-10-11, 20:18
Hi all i'm trying to track down a problem that became apparent about a week ago, for this purpose i need to disable all plugin's, however when i disable vbet the forum doesn't load at all, just a completely blank page?

Can some one help as i need to do this urgently because my forum style is broken for guests.

Regards,
Simon

Simon Lloyd
28-10-11, 06:23
Michael, if you read this you still have admin access, view the forum in a logged out/guest status and you will see styling is missing, log in and styling is there, this is why i need to disable vbet to eliminate it as a possibile cause.

r.dziadusz
28-10-11, 12:26
Hi michal is currently doing workshop, he will answer you as soon as possible, but here is what I've got for you, how to disable vBET:

1. Disable it in Admin CP
2. Comment vBET rules in .htaccess. If you do not remember which are those then check in vBET package in do-not-upload/tools/redirecting-rules directory
3. Revert integration changes in vbseo files. Easiest way - just upload original files. If you do not have the zip - download it from provider page. Hardest way - just open readme.html in vBET package and there you have exactly described which changes was made - just do it in opposite way.

Simon Lloyd
28-10-11, 17:22
Thanks for the reply, i'm snowed under with work at the moment so my forum style for guests will have to remain broken until tomorrow where i can perform this action, although i do have a sneaking suspicion that it's the very latest vbet causing this - i will updaate you tomorrow when i can successfully disable vBET.

vBET
28-10-11, 21:37
Michael, if you read this you still have admin access, view the forum in a logged out/guest status and you will see styling is missing, log in and styling is there, this is why i need to disable vbet to eliminate it as a possibile cause.

Do you have Guest Cache turned on? If yes please try to turn it off (just temporarily for test) and check again. Most probably it is turned on and you made some style changes and your styles are stored in files. So after changes style files are different (different names) but cached full HTML outputs in guest cache still have URLs to old style files. That would perfectly explain what happens. So if it is really the cause then please:
1. Just wait until Guest Cache expire and the issue will go away itself
2. Or if you do not want to wait just clean Guest Cache

If it is not the cause then please let us know and we will check it again.

Simon Lloyd
28-10-11, 22:51
Michael, tuning off guest cache worked, but i have only ever used one style anything ever cached or shown to guests has been my style that i use now, the user has never been shown another style, EVER!, i find that if in vbulletin settings i change the style shown to guests it will not honour my choice exactly, its hit or miss but mostly a non styled version of the current style. If i do as you ask and turn off guest cache then it behaves as it should meaning that vbet iscausing an issue!.

Simon Lloyd
29-10-11, 21:31
I left guest cache turned off since 22:15 yesterday and the guest view unregistered/not logged in view was as it should be, when i turned it back on 21:20 today the guest view was broken again, if i then change the style that id available by default vbulletin does not honour that change insted the guest view gets fixed but shows it fixed in the previous style, then when someone tries to view a thread the view reverts to the style i just changed to??

I've turned guest cache off again so that my styles are fixed, as i stated above i haven't changed style or look so there is no reason why vBET should cause this issue, can you please release a fix or tell me what i can do to get this working properly?

Simon Lloyd
30-10-11, 11:04
I solved this issue myself but vBET still needs a fix so this doen't need to be done manually:

Accessed Admincp>vBET Cache
> Guest Cache
Disabled Guest Cache and Saved
Made Guests Cache Time To Live & Guest Cache Time To Live for Less Relevant Pages values zero
Enabled Guest Cache & Saved
Guest Views are now showing your correct style
Made Guests Cache Time To Live & Guest Cache Time To Live for Less Relevant Pages the value i had them at before & Saved
Checked logged out view to confirm styling was still ok

Now the view for guests is fixed but i guess when the cached time runs out if a guest views my website and there is an issue with the styling or some error then every guest after that will see the broken style or error when really that error doesn't exist anymore!

r.dziadusz
31-10-11, 08:47
Sorry that you had to solve it by your own, we are checking possibilities, why it appears and how to solved it once for all

vBET
31-10-11, 12:21
I solved this issue myself but vBET still needs a fix so this doen't need to be done manually:

Accessed Admincp>vBET Cache
> Guest Cache
Disabled Guest Cache and Saved
Made Guests Cache Time To Live & Guest Cache Time To Live for Less Relevant Pages values zero
Enabled Guest Cache & Saved
Guest Views are now showing your correct style
Made Guests Cache Time To Live & Guest Cache Time To Live for Less Relevant Pages the value i had them at before & Saved
Checked logged out view to confirm styling was still ok

Now the view for guests is fixed but i guess when the cached time runs out if a guest views my website and there is an issue with the styling or some error then every guest after that will see the broken style or error when really that error doesn't exist anymore!

Hi. vBET do not need changes in this area - there was no error at all - we already explained how it works. It works as it suppose to - shows fully cached HTML pages until those expire. And it was working same on your forum. Your description of how you solved the issue is the proof. You changed cache TTL to really low value, so all pages expired and was replaced where new requests came. Everything works perfectly. Just as I described in my first response here - your cached pages point to not existing CSS files, because most probably some CSS was changed on your forum. And just as I described before in such case you can just wait until cache expires (if time to live has low values) of flush guest cache. Please remember - do NOT flush database cache - this one works perfectly no matter what changes you will do on your forum :)

Also you didn't have to solve it yourself. In fact you just did what I wrote you in my first answer in this thread:

So if it is really the cause then please:
1. Just wait until Guest Cache expire and the issue will go away itself
2. Or if you do not want to wait just clean Guest Cache
You just flushed Guest Cache as you was asked. Please note that, there is much simpler way for this - you do not have to do all those steps, it is enough to go to Admin CP -> vBET Cache -> Cache Cleaner. Sorry I didn't mention this option in last response - I assumed you know it.

Simon Lloyd
31-10-11, 20:10
Thanks for the response Michael, and i did understand you perfectly, the steps i performed were, as you say, pretty much the same as flushing the cache, however, after doing this and confirming normal view i raised the Cache TTL above the 3600 (3 times the amount) that it was set to made no changes to my forum an hour or so later checked the logged out view and again all CSS was missing. I now have it set to 3600 so the most time that a person will see the forum without the CSS will be one hour.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations made by vBET Translator 4.9.2