PDA

View Full Version : Solved VBET cache working, but providers not translating



gopalmm2
21-10-11, 06:52
VBET was working quite well for me, until I decided to do an upgrade. Right after I upgraded to 4.4.3, I also tried to integrate with vbseo and I messed up. Thanks to the staff here, all issues were fixed, except the translations suddenly stopped. I don't think I've used much of google or microsoft API to make them block me. In fact I haven't tried to touch microsoft API until now. But the translations do not work now. Previously stored cache still works well.


My website is at:

http://ftazeta.com
If I click on spanish translation, it translates because of the cache, but noen of the other languages translate and also, new posts posted in the forum do not translate either.

I can provide any other info required. Any help would be much appreciated.

gopalmm2
21-10-11, 06:56
Ok.. here is the weird issue... translations do occur, but only in the already translated text?

PLease compare:

http://ftazeta.com/issues-nfps-service/8456-are-we-down-4.html
vs.

http://ftazeta.com/it/issues-nfps-service/8456-are-we-down-4.html

Does that seem weird?

Previously, the text at the first link wasn't translated to english either from spanish. But I renewed google API v1 key and entered the new one and added my website to it's list and it worked, but still no clue why th ewhole page isn't translating in the second link.

r.dziadusz
21-10-11, 14:49
Hi
Most probably you are blocked by translation provider, as I sad in our private conversation, provider set new strict limits.
You can find out if you are blocked in two ways:
first - simply see in

Admin CP -> vBET -> Translation Providers Availability
And there is a second way, run tests for each provider you use: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729

Also please read this: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post10869

gopalmm2
21-10-11, 15:07
I have not been blocked by google.

I get this response:


Starting translation test
Test result: {"responseData": {"translatedText":"powitanie"}, "responseDetails": null, "responseStatus": 200}
Test error:
Connection time (ms): 83.6840820312


Thank you.

gopalmm2
21-10-11, 15:12
I have not been blocked by microsoft as well.

I get this:


Starting translation test
Test result: "Hello"
Test error:
Connection time (ms): 239.824951172


SOme of the text is being translated for sure. But others aren't translating... this happened as soon as I upgraded and tried to integrate with vbseo. Thanks again!

r.dziadusz
21-10-11, 15:30
Test shows your current status, Microsoft has time limits, i can work in this second, and stop working in another.
As you sad, some translations are made, so it translated, turns off and turn on again in some time(vBet check it every 10 minutes)
Please read carefully: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post10869

Edit:
I figured it out, using acces you'd given me last time I checked your vbet_translation_options folder, and I noticed that you didn't upgrade it,
now it should be better

gopalmm2
21-10-11, 16:13
THANK YOU! It works! I knew I missed something. Thanks a lot and sorry for the trouble again.

r.dziadusz
21-10-11, 16:25
You welcom:) Happy to help you
Do you need any help with this issue? For any other problem please open new thread:)

gopalmm2
21-10-11, 21:05
OK... same issue still exists.. sigh, sorry for the trouble, but the pages do translate now... I kept testing google API and I'm not blocked. Translation does occur, because I tried translating in different languages, never translated before, so it can't be cache. And the translated threads are from today, so they are new.

BUt check this out:

http://ftazeta.com/spanish/8508-greetings-brothers.html
the text translation does not seem to work. Any ideas? Page translation does work.
Thanks... sorry for being a pain.

gopalmm2
21-10-11, 21:38
Here is an exmaple of half the text translating - the first post translates, but the second one doesn't:


http://ftazeta.com/nfps-channel-list-channel-requests/8496-puerto-rico-local-channels.html#post47497

I kept checking if google API was blocking, but I never got the abuse error. This seems really weird.

vBET
23-10-11, 01:29
At this moment those all are translated. And when it was just first and 2nd not it wasn't nothing wrong. Simply - someone wrote message and it was translated because you had limits. Then when next message was written limits was reached and translation providers unavailable - so you saw translated text from cache and original, for next message, because translation services where not available. After some time those where available again, so translation happens (and was cached) and now when I go there I see all 3 posts translated. Everything is OK - when translation is available vBET uses translations. When then only cached translations are available and new text will be translated if during next visit you will have limits. Everything automatic, so you quit worrying, relax and just wait until your cache fills up with translations :) Also we are working to support more translations API so limits will not be so often reached (more APIs more limits).

Do you still have some question here or it is OK now after explanation? :)

gopalmm2
23-10-11, 23:54
No, thank you :). I understand now. I was worried I messed up bad somewhere. As long as they work well, all is good :D. Thank you for your concern and patience.

vBET
24-10-11, 00:45
No problem :) Please note that we are already working to support another translation API in vBET :) So all limits will be not reached so fast. For details please see announcements.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vBET Translator PRODUCER_PRODUCT_VERSION